Nhawks17

[1.6.1] RealPlume - Stock [v1.3.1 - 1/14/19] - Better Late than Never Update

Recommended Posts

3 hours ago, SpartanJack17 said:

There's a limit on how many particles can be shown at a time, and with lots of engines you're hitting that limit.

Ow ok thanks so how can I fix the thing that even with 1 engine for example on Ventor,Mamooth,KE-1 engine plumes I can see every individual ball of plume on lower atmosphere how or even can I fix it (my game is running 10FPS)

Share this post


Link to post
Share on other sites
2 minutes ago, Jack the Green Ghost said:

 Ow ok thanks so how can I fix the thing that even with 1 engine for example on Ventor,Mamooth,KE-1 engine plumes I can see every individual ball of plume on lower atmosphere how or even can I fix it (my game is running 10FPS)

That's happening because your computer is struggling to render all the particles.  You might have more luck reducing the number of particles, to do that go to the smokescreen folder in gamedata, open SmokeScreen.cfg and change the maximumactiveparticles number to a lower value.

Share this post


Link to post
Share on other sites

This is one of my "must have" mods for KSP,  RSS or otherwise, so I'm glad to see the stock configs kept alive.

Curious how easy it would be to config this for scaled systems (e.g. 2.5x stock)?

Edited by Nittany Tiger

Share this post


Link to post
Share on other sites
1 hour ago, Enzo-004 said:

Does this Mod work for version 1.4.2 ??

Why not try it and find out for yourself?

Then you'll know for sure.

Share this post


Link to post
Share on other sites

 

On 7/28/2018 at 3:34 PM, Nittany Tiger said:

This is one of my "must have" mods for KSP,  RSS or otherwise, so I'm glad to see the stock configs kept alive.

Curious how easy it would be to config this for scaled systems (e.g. 2.5x stock)?

I've used it in rescaled systems, why should it be different?

Share this post


Link to post
Share on other sites
On 17/08/2018 at 04:42, JAFO said:

Por que não experimentar e descobrir por si mesmo?

Então você saberá com certeza.

 

I just asked if it works, why I tested it and it did not work, do not need this ignorance...

Share this post


Link to post
Share on other sites

We were all newbies once, guys. No need to be rude to them about it. And if you are met with rudeness, newbies, please do not reply in kind. 

Share this post


Link to post
Share on other sites

@Enzo-004

Yes, this mod does work in 1.4.2. I consider it an almost essential mod and have used it from version 1.2.2 to 1.4.5.

In case you don't know, here's how to install it:

Download it, unzip the file you receive, drop everything in that file in to your "GameData" folder, and launch the game.

Go to the VAB and mouse over an engine. If the mod is working, then at the end of the engine's description it will say "Plume configured by RealPlume."

If it is working for the default parts but not for a specific mod, that mod might not be supported by RealPlume.

 

Enjoy!

Share this post


Link to post
Share on other sites
On 8/17/2018 at 10:39 AM, Nightside said:

 

I've used it in rescaled systems, why should it be different?

It works in rescaled systems, but I think you have to edit the scaling factor so the plume expands properly.  It's honestly an aesthetic choice, and probably not a big deal, especially for rescales close to stock or RSS size.

Share this post


Link to post
Share on other sites
25 minutes ago, Nightside said:

@Nhawks17, @sarbian or anyone else familiar with the configs of this mod or Smokescreen, what variables should be changed if I want the plumes to get really fat at low atmospheric pressure?

It depends on the exact effect you want but the logGrow and logGrowScale curves are most likely what you want. The Smokescreen post has the info.

Share this post


Link to post
Share on other sites
5 hours ago, GearsNSuch said:

@ Enzo-004

Sim, este mod funciona em 1.4.2. Considero um mod quase essencial e usei-o da versão 1.2.2 para a 1.4.5.

Caso você não saiba, veja como instalá-lo:

Faça  o download , descompacte o arquivo recebido, coloque tudo nesse arquivo em sua pasta "GameData" e inicie o jogo.

Vá para o VAB e passe o mouse sobre um motor. Se o mod está funcionando, então no final da descrição do motor, ele dirá "Plume configurado por RealPlume".

Se estiver trabalhando para as partes padrão, mas não para um mod específico, esse mod pode não ser suportado pelo RealPlume.

 

Apreciar!

Thank you, you really helped me, different from some people here ...

Share this post


Link to post
Share on other sites

I'm getting a lot of log errors about FloatCurve: Invalid Line. Requires two values 'time' and 'value.'

I Googled this error and found a seven month old thread that says it has to do with a Real Plume issue that was "fixed."

I'm wondering if even though this mod technically "works," it may need an update at some point....

Either that or I must  have bad configs for some engines....

Share this post


Link to post
Share on other sites

My ion engine hasn't plume. How can I fix it? I tried to reinstall the mod, install it without other mods and reinstall the game, but it doesn't work. 

Share this post


Link to post
Share on other sites

Most of my engine plumes look great...This one FASA engine with 4 nozzles has the plumes coming out at different heights - 1 of the 4 is correct, the other 3 are way too high. Anyone know how to fix this?

Thanks!

S1lSesN.png

Share this post


Link to post
Share on other sites

Missing History and Squad plumes conflicting

It looks like the contents of both the Missing History and Squad folders try to patch the same five engines, and as a result there are two Plume{} sections for these engines after Module Manager has its way with them. This is noticeable with the LV-T45 and LV-T30 stock engines having their engine plumes start too far back in the engine model.

The workaround seems to be to either install Missing History to get the adjusted engine models, or to delete the Missing History plume configs from RealPlume-Stock if not using Missing History.

There might be a similar workaround to @Tyko's problem with engine plumes being in the wrong place. Tyko, can you inspect your Module Manager cache and look for that engine's part definition? I wonder if there's more than one Plume{} section in there, or more Plume{} sections then there are supposed to be. I don't know that engine's part name or I'd look for myself.

Share this post


Link to post
Share on other sites

Adding more plumes?

Right now I have a slightly customized plume set for Explodium Breathing Engines and I have my explodium-breathers using those plumes. They're clones of the generic turbojet and turbofan plumes with a different colour.

Currently those plumes and engine configs are bundled with the part pack. If I fork RP-Stock, add my plumes and engines and do a pull request, will they still be considered for review and merging? Is it better practice to have the plumes and configs added to RP-Stock or to keep them attached to my part pack? I think the patches are smart enough to detect RP-Stock though there were some conflicts with Jet Sounds Continued.

Share this post


Link to post
Share on other sites

What is the difference between realplume and realplume stock in the download? Last time I have tried to download this, it did not work. does having both of them in the gamedata folder for ksp make it not work?

Share this post


Link to post
Share on other sites

@Pippipylup You always need RealPlume.

You need RealPlume-Stock at least.

When using RealFuels you have to use RealPlume-RFStockalike and NOT RealPlume-Stock.

If you use RealismOverhaul (and also RealFuels then ofc) you don't need anything else than RealPlume, because RealismOverhaul provides it's own configs.

Share this post


Link to post
Share on other sites
25 minutes ago, Gordon Dry said:

@Pippipylup You always need RealPlume.

You need RealPlume-Stock at least.

When using RealFuels you have to use RealPlume-RFStockalike and NOT RealPlume-Stock.

If you use RealismOverhaul (and also RealFuels then ofc) you don't need anything else than RealPlume, because RealismOverhaul provides it's own configs.

Ah, ok. I was putting in only the Realplume file. I'll try using the Realplume and Realplume-stock file. If that doesn't work, I'll try only the Realplume-stock file. I don't use RealFuels either.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.