Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

1 hour ago, themaster401 said:

let it lag, let it lag, let it possibly lag!

ayyyyyyy :D

Share this post


Link to post
Share on other sites

LATE NIGHT UPDATE

1.1.21

  • Added a light dust on Minmus
  • Included optional cfg for Snow on Kerbin and Geysers on Eeloo

Please note: Snow is a WIP and comes at a small price. 15 fps at least. Feel free to give it a shot though. Feedback always welcome. I think its too thick so I will probably change it.

 

If you mess with the EVE GUI, you will see some major artifacting with Scatterer. To fix this issue, enter and exit the tracking station and everything should return to normal.

 

 

**DO NOT INSTALL EVE SEPERATELY, EVERYTHING IS BUNDLED IN THIS DOWNLOAD**

 

Download Links

For 1.2 version 1.1.21                          
xO68iAc.jpg         

Edited by Galileo

Share this post


Link to post
Share on other sites

Any chance you could split your releases up into configs and not include all the plugin mods? It's horrible to use SVE from CKAN as it requires uninstalling other mods and redownloading them in your packages. This snow tweak for example could be an alternative install option.

Share this post


Link to post
Share on other sites
3 minutes ago, Waz said:

Any chance you could split your releases up into configs and not include all the plugin mods? It's horrible to use SVE from CKAN as it requires uninstalling other mods and redownloading them in your packages. This snow tweak for example could be an alternative install option.

yeah i can do that

Share this post


Link to post
Share on other sites
4 minutes ago, Galileo said:

yeah i can do that

You've probably already done such things, but certainly I found the NetKAN guys helpful and responsive. The EVE config was updated to my one in just a couple of days just by opening an issue on the NetKAN github, and as I understand it, that will continue to work automatically when I post new releases.

 

Share this post


Link to post
Share on other sites
5 minutes ago, Waz said:

You've probably already done such things, but certainly I found the NetKAN guys helpful and responsive. The EVE config was updated to my one in just a couple of days just by opening an issue on the NetKAN github, and as I understand it, that will continue to work automatically when I post new releases.

So what you are saying is i only need to include my cfgs for EVE and not include the entire mod in my package? I can get behind that, but with scatterer, im afraid if i just include my cfgs and sun flare, people or CKAN will overwrite it with scatterers default items. Im only apprehensive because i dont want to deal with people showing up with pitch forks because their install doesn't look right

Share this post


Link to post
Share on other sites

Wait.

 

 

Geysers on Eeloo?

 

 

This will work so well with OPM and a cloud config for it.

 

(Also, could you put thicker cloud cover on Eve, but keep the atmospheric "bands" that are there in the current build?)

Edited by TheJewelOfJool

Share this post


Link to post
Share on other sites
1 minute ago, TheJewelOfJool said:

(Also, could you put thicker cloud cover on Eve, but keep the atmospheric "bands" that are there in the current build?)

Im not sure what you mean? Eve is entirely covered with clouds. If you mean you want more volumetric clouds then i don't think i can do that just due to performance issues. I just recently optimized this mod for better performance and adding anything else to Eve, especially volumetric clouds, would likely do more harm than good

@Waz Also, i remove the EVE eclipse shadows because they are so "hard" compared to scatterers "soft" eclipses. So im at a crossroads. 

Share this post


Link to post
Share on other sites
3 minutes ago, Galileo said:

Im not sure what you mean? Eve is entirely covered with clouds. If you mean you want more volumetric clouds then i don't think i can do that just due to performance issues. I just recently optimized this mod for better performance and adding anything else to Eve, especially volumetric clouds, would likely do more harm than good

I meant I would like Eve's clouds to look a bit more like this:

LUOvAqj.png

But have the wisps and bands that are shown in some Mariner images, like this one:

venusmar1.jpg

Sorry that I did a poor job at explaining what I meant. I have difficulty with that.

Share this post


Link to post
Share on other sites
7 minutes ago, Galileo said:

So what you are saying is i only need to include my cfgs for EVE and not include the entire mod in my package? I can get behind that, but with scatterer, im afraid if i just include my cfgs and sun flare, people or CKAN will overwrite it with scatterers default items. Im only apprehensive because i dont want to deal with people showing up with pitch forks because their install doesn't look right

CKAN handles all that for you. For example, they already split out your sunflare. If a user selects scatterer now, they're immediately prompted for which sunflare to install - the default, SVE, or Astroniki's. It would be the same for other configs, and if the user simply picked "Stock Visual Enhancements" (which would basically be a meta-package), they'd automatically get all the plugin mods and all your content mods. Certainly your mod is a bit more complicated than the average, but it's also a great one, so I imagine the NetKAN/CKAN guys will be happy to help ensure it's smooth for users, given they have the packages they need to make that possible. You might even start by posting an issue and get their feedback about what repackaging would be best for end users.

 

10 minutes ago, Galileo said:

@Waz Also, i remove the EVE eclipse shadows because they are so "hard" compared to scatterers "soft" eclipses. So im at a crossroads. 

To be honest, I'd prefer to remove them from EVE. The implementation is a bit ugly, and there are strange bugs with it (eg. it was crashing if a certain tracking station level model was drawn, so I specifically excluded that model from being blackened). To me, EVE is animated clouds and city lights.

Share this post


Link to post
Share on other sites
24 minutes ago, Waz said:

CKAN handles all that for you. For example, they already split out your sunflare. If a user selects scatterer now, they're immediately prompted for which sunflare to install - the default, SVE, or Astroniki's. It would be the same for other configs, and if the user simply picked "Stock Visual Enhancements" (which would basically be a meta-package), they'd automatically get all the plugin mods and all your content mods. Certainly your mod is a bit more complicated than the average, but it's also a great one, so I imagine the NetKAN/CKAN guys will be happy to help ensure it's smooth for users, given they have the packages they need to make that possible. You might even start by posting an issue and get their feedback about what repackaging would be best for end users.

 

To be honest, I'd prefer to remove them from EVE. The implementation is a bit ugly, and there are strange bugs with it (eg. it was crashing if a certain tracking station level model was drawn, so I specifically excluded that model from being blackened). To me, EVE is animated clouds and city lights.

Maybe you could remove them next update? ....  Maybe when you fix city lights?  Lol :D

25 minutes ago, TheJewelOfJool said:

I meant I would like Eve's clouds to look a bit more like this

But have the wisps and bands that are shown in some Mariner images, like this one:

venusmar1.jpg

Sorry that I did a poor job at explaining what I meant. I have difficulty with that.

This is exactly the cloud layer that the older Eve had, I dont think I want to go back to that. However, that cloud texture is still included in the textures in the mod. You can play around with the cfgs and add that particular cloud texture to Eve and get the effect you want

Edited by Galileo

Share this post


Link to post
Share on other sites

While you are looking at ckan side things you don't get the option for the different HR, MR, LR versions,

The .21 download just appeared, and when you download you get 2 files: 

Downloading "https://github.com/Galileo88/StockVisualEnhancements/releases/download/1.1.21/SVE.HR.1.1.21.zip"
Downloading "https://github.com/Galileo88/StockVisualEnhancements/releases/download/1.1.21/SVE.LR.1.1.21.zip"

Think one is due to the sunflare.

Share this post


Link to post
Share on other sites
33 minutes ago, Galileo said:

This is exactly the cloud layer that the older Eve had, I dont think I want to go back to that. However, that cloud texture is still included in the textures in the mod. You can play around with the cfgs and add that particular cloud texture to Eve and get the effect you want

This.... please.... that cloud texture is awful, what is in the mod now is so much better.

Share this post


Link to post
Share on other sites

For those who struggle with FPS with this mod or any other visual pack, I would like to point you towards this awesome visual mod by @parameciumkid!!

I will also provide a link in the OP.. Enjoy! 

Share this post


Link to post
Share on other sites

Is the FPS hit with snow only while you're in the snowy scene? Or always?

Share this post


Link to post
Share on other sites
1 hour ago, fourfa said:

Is the FPS hit with snow only while you're in the snowy scene? Or always?

technically its always. See, I have the volumetric clouds only popping up when you see clouds over head but really they are always around you, even when there arent any clouds. they are just invisible. 

Share this post


Link to post
Share on other sites

Extreme lag with good specs. 

Hello, I have been experiencing heavy lag issues while using stock visual enhancements in my game, I have removed all mods except for it and it is the one clearly causing the lag. The problem is, I don't have half bad specs,

my GPU is a GTX 980ti

CPU is a AMD FX-8350 8 core clocked at 4.0 ghz

I have 8GB of ddr3 ram

and I run the game on the 64 bit setting

I usually get around 30 fps on kerbins surface, and 40 in orbit, however this can drop to as low as 15 during launches (even with small rockets.)

IIRC I can play scatterer + E.V.E. fine with fps ~120 but i really am wondering what it is about this pack that makes the game crawl so much.

Share this post


Link to post
Share on other sites
1 hour ago, treesniper said:

Extreme lag with good specs. 

Hello, I have been experiencing heavy lag issues while using stock visual enhancements in my game, I have removed all mods except for it and it is the one clearly causing the lag. The problem is, I don't have half bad specs,

my GPU is a GTX 980ti

CPU is a AMD FX-8350 8 core clocked at 4.0 ghz

I have 8GB of ddr3 ram

and I run the game on the 64 bit setting

I usually get around 30 fps on kerbins surface, and 40 in orbit, however this can drop to as low as 15 during launches (even with small rockets.)

IIRC I can play scatterer + E.V.E. fine with fps ~120 but i really am wondering what it is about this pack that makes the game crawl so much.

We are running almost the exact same setup except i have an i5 4690k overclocked to 4.1ghz and a regular gtx 980 with 32gb of ram. So i have no idea what could be causing your performance to suffer. i get 100+ fps pretty steady.

Are you running the latest version?

Edited by Galileo

Share this post


Link to post
Share on other sites
21 minutes ago, Galileo said:

We are running almost the exact same setup except i have an i5 4690k overclocked to 4.1ghz and a regular gtx 980 with 32gb of ram. So i have no idea what could be causing your performance to suffer. i get 100+ fps pretty steady.

Are you running the latest version?

(On my old account, got the password back)

Yes I am running the latest version, I noticed my ram was almost full (6gb out of 8) while i was playing, maybe it has something to do with that? Or maybe its just that there isn't any multicore support (4.0ghz spread across 8 cores is painful if a game doesn't atleast have 2 core support.)

Share this post


Link to post
Share on other sites
9 minutes ago, treesniper12 said:

(On my old account, got the password back)

Yes I am running the latest version, I noticed my ram was almost full (6gb out of 8) while i was playing, maybe it has something to do with that? Or maybe its just that there isn't any multicore support (4.0ghz spread across 8 cores is painful if a game doesn't atleast have 2 core support.)

All of those are definite possibilities.  I would try a fresh install of SVE and remove scatterer to see if that's the issue. If the performance is still bad,  try a fresh install of ksp if you can

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.