Jump to content

[1.9.x, 1.10.x] Kerbal Launch Failure Revived


Recommended Posts

1 hour ago, linuxgurugamer said:

Are you sure it was Kerbal Launch Failure and not Dang It!  ?  KLF doesn't do anything after launch.

Positive, Dang-it not installed and it was the whoop-whoop and flashing warning button of the tool bar to alerted me. I have my max time before failure set to 300 in the KLF settings - would that mean there is still has a change to effect craft even though I'm well in orbit?

Link to post
Share on other sites
  • 4 months later...

This mod is killing me!

The stress!

And it hasnt even worked yet!  I don't even know if it is working!  (Running 1.3.1, seems to be)

Coming up on my 50th launch or so, so I know I'm due...

-I know the probabilities, 1 in 50 chance of failure, not every 50th launch.  But can you imagine if it was every 50th launch?    Jeb would be first in line every 50th.  

 

So feature request:  A button in the settings that enables a guaranteed failure.

 

Thanks for all the work LGG!  

Link to post
Share on other sites
8 hours ago, Gargamel said:

This mod is killing me!

The stress!

And it hasnt even worked yet!  I don't even know if it is working!  (Running 1.3.1, seems to be)

Coming up on my 50th launch or so, so I know I'm due...

-I know the probabilities, 1 in 50 chance of failure, not every 50th launch.  But can you imagine if it was every 50th launch?    Jeb would be first in line every 50th.  

 

So feature request:  A button in the settings that enables a guaranteed failure.

 

Thanks for all the work LGG!  

Just increase the probabilities in the settings to 100%

Link to post
Share on other sites
6 hours ago, linuxgurugamer said:

Make them higher, the higher they are, the more chance of a failure

Ok I thought they were supposed to be at 5% based on your first post.

 

turned to 100% and was getting failures.

How does this work with aircraft does it keep re-rolling the chance for failure since I’m in atmosphere or is it a one time per launch roll?

 

 

 

 

 

 

 

 

Link to post
Share on other sites
29 minutes ago, HaydenTheKing said:

Ok I thought they were supposed to be at 5% based on your first post.

 

turned to 100% and was getting failures.

How does this work with aircraft does it keep re-rolling the chance for failure since I’m in atmosphere or is it a one time per launch roll?

Once per launch

I need to add a way to disable this for aircraft, not yet sure how to do that

Link to post
Share on other sites
22 minutes ago, linuxgurugamer said:

I need to add a way to disable this for aircraft...

Why?  Aircraft have failures, too.  Plus, it's a great reason to use some sort of ejection/parachute mod.

Link to post
Share on other sites
1 hour ago, razark said:

Why?  Aircraft have failures, too.  Plus, it's a great reason to use some sort of ejection/parachute mod.

I love it when I have to make a emergency landing

1 hour ago, razark said:
Edited by HaydenTheKing
Link to post
Share on other sites
  • 2 months later...
  • 1 month later...

In 1.4.4 with most recent version of Launch Failure, I've had 2 different craft suffer failures in orbit.  Both occurred long after launch - days later in one case - and happened immediately after switching to the craft.  The second one actually caused the command pod to fail, and I had to reload the game as it was stuck at 0 speed at 80 km and the crewmember was gone.  This one occurred immediately after separating a "Pea" pod in preparation for reentry - and the parachute (only other attached part) continued on its trajectory after the pod froze in place.

Link to post
Share on other sites
On 7/16/2018 at 7:04 PM, Cavscout74 said:

In 1.4.4 with most recent version of Launch Failure, I've had 2 different craft suffer failures in orbit.  Both occurred long after launch - days later in one case - and happened immediately after switching to the craft.  The second one actually caused the command pod to fail, and I had to reload the game as it was stuck at 0 speed at 80 km and the crewmember was gone.  This one occurred immediately after separating a "Pea" pod in preparation for reentry - and the parachute (only other attached part) continued on its trajectory after the pod froze in place.

That is strange, because if you weren't in atmosphere, it won't fail.  However, I can see that if you switched to a vessel in orbit, and then the orbit dipped into the atmosphere, it could possible happen

I did find a problem related to what you described, will release a fix soon.

Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

That is strange, because if you weren't in atmosphere, it won't fail.  However, I can see that if you switched to a vessel in orbit, and then the orbit dipped into the atmosphere, it could possible happen

I did find a problem related to what you described, will release a fix soon.

I can't remember for sure, it's definitely a good chance I was in the upper atmosphere when it happened.  Looking forward to updating it tonight.  Thanks for all your hard work!

Link to post
Share on other sites
  • 4 weeks later...
22 hours ago, Skyrunner84 said:

I know this has probably already been asked but I can't find it.... Does this mod play nice with Dangit!? Are there very bad side effects from using these side by side? Maybe some recommended settings for using these mods together?

I wouldn't recommend it.  There shouldn't be any significant interaction, but I have no idea what would happen if both decide to fail the same part at the same time.

Link to post
Share on other sites
3 hours ago, linuxgurugamer said:

I wouldn't recommend it.  There shouldn't be any significant interaction, but I have no idea what would happen if both decide to fail the same part at the same time.

Ok, I think I have gone away from the Dang it! Idea anyway. I just updated to 1.4.5 and I like it. I am using Oh Scrap along with this (and many more mods). I have had some failures (mostly while simulating with KRASH). I have not had any problems with conflicts so far but I have not played very far in my new save. Are there any known issues with this setup or would it be the same unknows?

Link to post
Share on other sites
  • 2 months later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...