politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.4 - Orion

Recommended Posts

4 hours ago, Hoddd9000 said:

EDIT 2: Alright, new issue. I get a massage saying:

One or more downloads were unsuccessful:

Error downloading HeatControl 0.4.11: The remote name could not be resolved: 'spacedock.info'
Error downloading KerbalAtomics 1:1.0.1: The remote name could not be resolved: 'spacedock.info'

this message continues to about half of the mods I've selected. What's the problem?

See

The Spacedock servers are moving currently, it comes to outages.  Just wait and retry :)

Share this post


Link to post
Share on other sites
On 5/23/2019 at 10:56 PM, cakepie said:

[snip]

Note: I consider NetKAN#7201/#7202 to be an unrelated matter, and will deal with separately after this is resolved.

hello

your post is very well written and if you wer a customer of ckan worded correctly, but alas ckan is not a Business and is only offering its services as is.

if the structure of ckan at the moment can`t support this mod then its is necessary to publish the mod marking it as not indexed by ckan.

not getting to  decision at the end of a discussion is unfortunate (and common in unorganized hobby meetings) and i understand its frustrating but stil ckan has no customer services.

Share this post


Link to post
Share on other sites

Some content has been removed.  Let's try to keep things civil, please. Thank you.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/27/2019 at 7:29 PM, kerbnub said:

Lol, I meant 1.20.20.3 :D

But now I'm confused...... I've been installing KSPI through CKAN, where I assumed it gave me the latest for my KSP version (1.6.1). But my CKAN compatible versions look a lot older.  Is CKAN several patches behind?0J9KQ91.png

 

I don't see any version file in the KSPI folders, so I'm half wondering if it's just a labelling issue. I'll try replacing what I have with a manual KSPI install from the OP here and see how it works.

Edit: it's clearly a newer version (has a kerbalism patch, wooo!), but I still have the same issues with it installed.

Weird, I honestly tough CKAN install framework would automatically look for the most recent version available for a KSP version. In contrast to most other mods, I actually upload every new release for KSPIE for multiple KSP versions to Spacedock. So why wouldn't CKAN make them available for lower KSP versions?

Edited by FreeThinker

Share this post


Link to post
Share on other sites
Posted (edited)

There are versions missing in CKAN. It's only the "last" release of every group that's indexed. The others are missing.

A quick investigation shows that this is the case since 1.20.14:t3NlK3M.png

That was indexed/released on:
mNAFCAJ.png

So after the ksp-ckan.org domain expired. Version 1.20.13 was released one day before, that one had luck :D

So I strongly believe that due to https://github.com/KSP-SpaceDock/SpaceDock/issues/192 CKAN doesn't get notified for new mod releases on Spacedock, and when the bot runs every four hours, he only gets the latest release.

So to back-fill the missing versions  we need to do some handwork, I think.
For future versions, @HebaruSan, should we re-enable staging?

Edit: The automatic --releases run would have a use case here too.

Edited by DasSkelett

Share this post


Link to post
Share on other sites
Posted (edited)

InnerLock mod is not installed completely. Plugin and essential files are installed in "InnerLock" folder.
However, that mod also have parts that should be installed in "MagicSmokeIndustries" folder:

https://github.com/whale2/InnerLock/tree/master/GameData/MagicSmokeIndustries/Parts/Rework_Utility/Probe/Misc/IR_LockConnector

CKAN only install files within InnerLock folder. While part itself is also modeled by Zodiusinfuser it is not within packed parts of Infernal Robotic Next mod.
It can work by it's own without IR plugin. Maybe just a bad choice to place it inside MagicSmokeIndustries folder, but since IR next is also released, might be possible to add additional check for part if it can be installed when IR mod is also present or not.

Don't know what to suggest to properly resolve issue.

EDIT:

Also, CKAN bot might have issues to catch properly new version of KJR Next:

 

 

Edited by kcs123

Share this post


Link to post
Share on other sites
23 hours ago, FreeThinker said:

Weird, I honestly tough CKAN install framework would automatically look for the most recent version available for a KSP version. In contrast to most other mods, I actually upload every new release for KSPIE for multiple KSP versions to Spacedock. So why wouldn't CKAN make them available for lower KSP versions?

We backfilled the missing versions: https://github.com/KSP-CKAN/CKAN-meta/pull/1453.
Also the Spacedock hook is fixed, so it should work in the future.

 

16 hours ago, kcs123 said:

InnerLock mod is not installed completely. Plugin and essential files are installed in "InnerLock" folder.
However, that mod also have parts that should be installed in "MagicSmokeIndustries" folder:

https://github.com/whale2/InnerLock/tree/master/GameData/MagicSmokeIndustries/Parts/Rework_Utility/Probe/Misc/IR_LockConnector

CKAN only install files within InnerLock folder. While part itself is also modeled by Zodiusinfuser it is not within packed parts of Infernal Robotic Next mod.
It can work by it's own without IR plugin. Maybe just a bad choice to place it inside MagicSmokeIndustries folder, but since IR next is also released, might be possible to add additional check for part if it can be installed when IR mod is also present or not.

Don't know what to suggest to properly resolve issue.

Fixed in https://github.com/KSP-CKAN/NetKAN/pull/7212, thanks for bringing it to us.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/29/2019 at 12:33 PM, DasSkelett said:

We backfilled the missing versions: https://github.com/KSP-CKAN/CKAN-meta/pull/1453.
Also the Spacedock hook is fixed, so it should work in the future.

1

Great to hear that! But I wonder if there are any other mods suffering from the same fate...

Edited by FreeThinker

Share this post


Link to post
Share on other sites
25 minutes ago, FreeThinker said:

Great to hear that! But I wonder if there are any other mods suffering from the safe fate...

Well, that's definitely possible. At least it works again for all future releases, but if there are already some missing, we don't know that :/
I can't think of an easy way to find missing versions right now, maybe it's possible with the Spacedock API.
Something like checking whether the download link of every release uploaded after the domain change of every mod marked for CKAN indexing is present in one .ckan file in the metadata repository? Or maybe the API supports hashes? Or find releases uploaded in a time frame smaller than 4 hours? Have to take a look at that.

But for now, the best would be if users (or mod authors) spot missing versions and bring it on us.

Share this post


Link to post
Share on other sites
On 5/26/2019 at 4:10 PM, Snark said:

Let's try to keep things civil, please.

A bit belated since I've been ill for the past couple of days, but I do want to apologize for going over the top in the post that had to be redacted.
I can only plead extreme frustration; I was trying my utmost to do the right thing for my end users and ensure that they could continue to be served without interruption, but failed to get any response at all.

 

On 5/26/2019 at 1:15 AM, danielboro said:

if the structure of ckan at the moment can`t support this mod

It should be pointed out that there is no technical hurdle involved here. What I requested is already possible within CKAN's existing capabilities.
If CKAN acceded to my preferred method they could very easily accept and incorporate the settings changes that I submitted.
If they declined, then I had a second option, a compromise approach that is also equally trivial to do.

 

In any case, it looks like there is finally some activity on CKAN's part so we shall see what happens.

Share this post


Link to post
Share on other sites
1 minute ago, HebaruSan said:

CKAN doesn't index pre-releases:

A5kx7TZ.png

Ah, mystery resolved, thanks. I need to stop reporting things in late hours, better to go sleep than to write more false bug reports :).

Share this post


Link to post
Share on other sites
On 5/29/2019 at 2:25 PM, DasSkelett said:

But for now, the best would be if users (or mod authors) spot missing versions and bring it on us.

Ok, in that case, most likely the same problem applies to my other mods which I release for multiple KSP versions

 

I guess they need to be indexed as well...

 

Share this post


Link to post
Share on other sites
On 5/31/2019 at 4:55 AM, FreeThinker said:

Ok, in that case, most likely the same problem applies to my other mods which I release for multiple KSP versions

I guess they need to be indexed as well...

Done. https://github.com/KSP-CKAN/CKAN-meta/pull/1455

9 hours ago, Poodmund said:

Kopernicus also backports releases to previous versions of the game. I'm not sure that they're indexed either.

https://github.com/Kopernicus/Kopernicus-Backport/releases

Done. https://github.com/KSP-CKAN/NetKAN/pull/7219 https://github.com/KSP-CKAN/CKAN-meta/pull/1456

Share this post


Link to post
Share on other sites

Hi,
it's not very important, but I'm wondering why CKAN (1.26.2) offers me to update some mods despite them clearly being shown as not compatible?
Example: Indicator Lights by @Snark:
CKAN-v1-26-2-KSP-1-7-0-2483-D-Kerbal-Spa

CKAN-v1-26-2-KSP-1-7-0-2483-D-Kerbal-Spa

Share this post


Link to post
Share on other sites
1 minute ago, VoidSquid said:

despite them clearly being shown as not compatible?

Not quite:  qJxHxIg.png

Share this post


Link to post
Share on other sites

Well, the mod versions info states that 1.5 is compatible with KSP 1.7.1, while 1.4.2 is compatible with 1.7.0 (which I'm running), this is what I mean with "clearly".

Anyway, not a biggie at all, just thought to let you know.

And a thanks for CKAN, reduced the time for my migration from 1.3.1 to 1.6 from one full day (all mods manually with 1.3.1) to about three hours (1.6.1 plus CKAN) :)

 

Thanks, and take care :)

Share this post


Link to post
Share on other sites

Yes, as this is the version I'm playing. It's unfortunate that there are now mods incompatible within the minor versions, i.e. 1.7.0 and 1.7.1, maybe the code for compatibility check can be expanded to minor version?

Share this post


Link to post
Share on other sites

 

5 minutes ago, VoidSquid said:

maybe the code for compatibility check can be expanded to minor version?

It already does that. Did you click the above link?

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, HebaruSan said:

Did you click the above link?

No, as I did already did chose some versions as "compatible" when I started using CKAN, I'm familiar with that dialog box. But one can only select 1.7, not minor versions, hence my idea of a minor version check.

Just to avoid any misunderstandings: by major versions I mean 1.3.x, 1.4.x, etc., by minor I mean versions like 1.4.0, 1.4.1, etc.

Edit: the checkbox for 1.7.1.2539 is unchecked, of course.

Edited by VoidSquid

Share this post


Link to post
Share on other sites
4 minutes ago, VoidSquid said:

No, as I did already chose some versions as "compatible" when I started using CKAN, I'm familiar with that dialog box. But one can only select 1.7, not minor versions, hence my idea of a minor version check.

There's a box Add Version to list below the list of Versions where you can add specific versions, so you can get 1.7.0 and 1.7.1 on the list as separate entries.

Share this post


Link to post
Share on other sites
11 minutes ago, VoidSquid said:

But one can only select 1.7, not minor versions, hence my idea of a minor version check.

The "1.7" checkbox includes all "1.7.x" versions. 1.7.0 has a separate entry if you scroll down.

kU6XC6h.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.