linuxgurugamer

[1.8.x,1.9.x] GravityTurn continued - Automated Efficient Launches

Recommended Posts

Posted (edited)

Originally written by @Overengineer1, it was adopted by @AndyMt and continued for a while.  @AndyMt stopped and gave permission for anyone else to adopt it.  Since I really like this and use it, I've done so.

Also thanks @sarbian for all the useful MechJeb code of which parts were/are incorparated into this plugin.

New Dependencies

HxgCx6P.png

So this is what it does:

Launch a craft into a low orbit with a few customizable settings.

Performing a Gravity Turn is arguably the most efficient launch procedure. The plugin will take care of the entire ascent for you by maintaining a strict hold to prograde (as much as possible) and varying the throttle to keep the desired ascent curvature. The circularization burn will be up to you, but it's normally less than 50 m/s.

The "First Guess" button tries to find the best settings for a particular rocket. After the trajectory reaches the destination height and the vehicle leaves the atmosphere, you can revert back to launch and use the "Improve Guess" button to get a better set of parameters. Do this multiple times and you will get a very efficient launch.

There is now a settings page, to change the skin of the mod:

The following are what's available, going from the stock skin, to a "normal" skin, to a "compact" skin:

hHXcwiq.png k6N7pOf.png ee2AgnZ.png

And the settings page:

nEjhqse.png

Availability

Now available in CKAN

Changes

  • Merged in FAR compatibility changes by @ildifa 
  • Reorganized directories slightly
  • Added Changelog.txt, deploy.bat, GravityTurn.version, deploy.bat, buildRelease.bat, AssemblyVersion.tt
  • Replaced InstallChecker with updated version
  • Added support for ToolbarController
  • Fixed nullref in CopyCompactSkin due to uninitialized skin
  • Changed backslashes to forward slashes for the stored config files (needed for OSX/Linux)
  • FOLLOWING CHANGE INCOMPATIBLE WITH PREVIOUS VERSIONS
    • Moved storage directory from GravityTurn/Plugins/PluginData/GravityTurn/" + sub to "/GameData/GravityTurn/PluginData/" + sub
  • Fixed error when the "Previous Best Settings" was pressed when there weren't any 
  • Added settings page (stock settings) to allow selection of compact skin (default) normal or stock skin

Donations accepted via Patreon

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Thanks so much for picking this up, it's been holding me back from upgrading... and now that I have time...

Share this post


Link to post
Share on other sites

Thanks. I just now deleted the old one and installed this manually. Seems to work (I'm on 1.9.1). I do see the same old UI style instead of the nicer (mostly larger) one in the image you show above. Guessing the image above might be from something later than the beta I just installed? Also, the icon in the standard toolbar (not Blitzy) is just a white square for me; works though. If you want some logs, I can do that... well after I come back from walking the dog. :-)

Share this post


Link to post
Share on other sites

Thanks for yet another excellent mod kept fresh.

Something I've been meaning to ask about this: I believe I read somewhere that it doesn't play nice with Mandatory RCS, and that's what kept me from using that mod - I can't play without gravityturn anymore.

But, doing an actual search on it, I couldn't find anything on compatibility. So... Anyone know more?

Share this post


Link to post
Share on other sites
1 minute ago, Morphisor said:

Thanks for yet another excellent mod kept fresh.

Something I've been meaning to ask about this: I believe I read somewhere that it doesn't play nice with Mandatory RCS, and that's what kept me from using that mod - I can't play without gravityturn anymore.

But, doing an actual search on it, I couldn't find anything on compatibility. So... Anyone know more?

I'll do some tests this evening.

One thing I do know is incompatible is WorldStabilizer, if you don't have launch clamps.  I have some ideas on how to fix that, will be working on it during my stream this evening

Share this post


Link to post
Share on other sites

New release, 1.8.0.1

  • Fixed missing textures for toolbar buttons
  • Changed to allow window dragging from anywhere in the window

Note:  After testing, I do not see any issues with either WorldStabilizer (even without launch clamps) or MandatoryRCS.  It worked fine with either/both of them

Share this post


Link to post
Share on other sites

Hello, thank you for your results, but it bleeds some problems while I'm running. 1, when I entered the game interface, the sidebar did not show an icon, and after installing this MOD, I can not use the other. 2, after installing this MOD, I can't re-enter the game after I exit from the game to the main menu (click continue the game's archive without responding). These issues, after I deleted this MOD, have returned to normal. My version is 1.9.1

Share this post


Link to post
Share on other sites
Posted (edited)

KSP v1.8.1

You don't list Clickthroughblocker and ToolbarControl as dependencies, though I think they are. At least, one of them is :)

With them installed along with nothing else (except modulemanager but no configs) I get a white box instead of an icon, and when I click it I get a window titled "Gravity Turn V 1.8.0" with buttons I can click but nothing does anything. I can't put focus in the text boxes and clicking the buttons makes them animate but they don't do anything. In particular, "Launch" doesn't launch.

Here's my log that ends on the launch pad after clicking launch a few times, I'm pretty sure though the problem is this, which is repeated thousands of times:

[LOG 04:56:43.492] GravityTurn : could not load lock_on icon!

http://pulpaudio.com/ksp/ksp_gravityturn.zip

 

Edited by 5thHorseman

Share this post


Link to post
Share on other sites
3 hours ago, 5thHorseman said:

KSP v1.8.1

You don't list Clickthroughblocker and ToolbarControl as dependencies, though I think they are. At least, one of them is :)

With them installed along with nothing else (except modulemanager but no configs) I get a white box instead of an icon, and when I click it I get a window titled "Gravity Turn V 1.8.0" with buttons I can click but nothing does anything. I can't put focus in the text boxes and clicking the buttons makes them animate but they don't do anything. In particular, "Launch" doesn't launch.

Here's my log that ends on the launch pad after clicking launch a few times, I'm pretty sure though the problem is this, which is repeated thousands of times:

[LOG 04:56:43.492] GravityTurn : could not load lock_on icon!

http://pulpaudio.com/ksp/ksp_gravityturn.zip

 

Make sure you have the latest version (1.8.0.1), that fixes the white box.

And thanks for the hint about dependencies.  FYI, it needs both the ToolbarController and the ClickThroughBlocker.

Please retry your test after updating to the latest version, thanks

Share this post


Link to post
Share on other sites
8 hours ago, Anjun_Li said:

Hello, thank you for your results, but it bleeds some problems while I'm running. 1, when I entered the game interface, the sidebar did not show an icon, and after installing this MOD, I can not use the other. 2, after installing this MOD, I can't re-enter the game after I exit from the game to the main menu (click continue the game's archive without responding). These issues, after I deleted this MOD, have returned to normal. My version is 1.9.1

First, please make sure you have the dependencies installed.

Not sure what you mean when you say "I can not use the other", please explain.

After you've installed the dependencies, please rerun your tests, and if still having problems, provide a log file, please.

 

Share this post


Link to post
Share on other sites

Will this work with KRASH for using the Best Guess feature?

Share this post


Link to post
Share on other sites
2 hours ago, Daelkyr said:

Will this work with KRASH for using the Best Guess feature?

Good question.  I have no idea, it's something to look into.  

Share this post


Link to post
Share on other sites
2 hours ago, Daelkyr said:

Will this work with KRASH for using the Best Guess feature?

 

12 minutes ago, linuxgurugamer said:

Good question.  I have no idea, it's something to look into.  

Yes, it works.

Share this post


Link to post
Share on other sites
6 minutes ago, leatherneck6017 said:

Yes, it works.

Thank you

Share this post


Link to post
Share on other sites
12 hours ago, 5thHorseman said:

KSP v1.8.1

You don't list Clickthroughblocker and ToolbarControl as dependencies, though I think they are. At least, one of them is :)

With them installed along with nothing else (except modulemanager but no configs) I get a white box instead of an icon, and when I click it I get a window titled "Gravity Turn V 1.8.0" with buttons I can click but nothing does anything. I can't put focus in the text boxes and clicking the buttons makes them animate but they don't do anything. In particular, "Launch" doesn't launch.

Here's my log that ends on the launch pad after clicking launch a few times, I'm pretty sure though the problem is this, which is repeated thousands of times:

[LOG 04:56:43.492] GravityTurn : could not load lock_on icon!

http://pulpaudio.com/ksp/ksp_gravityturn.zip

 

 

8 hours ago, linuxgurugamer said:

Make sure you have the latest version (1.8.0.1), that fixes the white box.

And thanks for the hint about dependencies.  FYI, it needs both the ToolbarController and the ClickThroughBlocker.

Please retry your test after updating to the latest version, thanks

Hi @linuxgurugamer, I'm having the same problem as @5thHorseman, although with KSP 1.9.1. I have version 1.8.0.1 of GravityTurn, as well as both dependencies. Log: https://www.dropbox.com/s/hbeocv7k5c5ezif/KSP.log?dl=0 

I also noticed that the GT window ingame is titled "Gravity Turn V 1.8.0" and I'm wondering if there was an upload issue to Github, since the zipfile is named "GravityTurn-1.8.0-1.8.0.1.zip".

 

Share this post


Link to post
Share on other sites
36 minutes ago, IntoSpaceAgain said:

 

Hi @linuxgurugamer, I'm having the same problem as @5thHorseman, although with KSP 1.9.1. I have version 1.8.0.1 of GravityTurn, as well as both dependencies. Log: https://www.dropbox.com/s/hbeocv7k5c5ezif/KSP.log?dl=0 

I also noticed that the GT window ingame is titled "Gravity Turn V 1.8.0" and I'm wondering if there was an upload issue to Github, since the zipfile is named "GravityTurn-1.8.0-1.8.0.1.zip".

 

I'll get the version number to display the full version number, the V1.8.0 is correct, missing the final digit 1.

Seems that a directory is missing from the build, I'm looking into it.

 

Share this post


Link to post
Share on other sites

I've also observed the launch button not launching,  am looking into that as well. 

I hope to get something out later this evening

Share this post


Link to post
Share on other sites
12 hours ago, linuxgurugamer said:

Make sure you have the latest version (1.8.0.1), that fixes the white box.

Sorry for the late reply, I sleep all day and just got to my computer after waking up to start working from home :)

The reported problems all happened after installing the contents of the zip GravityTurn-1.8.0-1.8.0.1.zip into Gamedata of a fresh 1.8.1 KSP install. I did this after seeing the same problems in a full JNSQ install. GravityTurn.version shows the version of the mod as 1.8.0.1

It seems you got more feedback during the day but I hate leaving a bug report dangling :)

Share this post


Link to post
Share on other sites

Update, I've solved the problem, but want to do a few more tests before I update.  

Will explain the issue later, was very strange

Share this post


Link to post
Share on other sites

New release, out of beta, 1.8.0.3

  • Fixed total unresponsiveness of mod 
  • Fixed error when the "Previous Best Settings" was pressed when there weren't any 
  • Added settings page (stock settings) to allow selection of compact skin (default) normal or stock skin

Now available on Spacedock:  https://spacedock.info/mod/2372/Gravity Turn

For those interested in what was wrong, I had changed the parameters to the DragWindow() to allow dragging from anywhere in the window.  What happened was due to the way all the windows were implemented, the DragWindow() which is supposed to be at the end of the window function was at the beginning.  So the RECT which was defined was eating all the events.  So clicking on a button, while appearing to do something, wasn't doing anything.

Very strange, but I'll now know what to look for in the future.

Share this post


Link to post
Share on other sites

Speaking of the "previous best settings", button, I've been meaning to ask if someone knew what happens when I don't press any of the "first guess", "improve guess", or "previous best settings" buttons, but just hit "launch" without pressing any of those. I assume one of those is essentially the default? Or is that actually some different thing?

Share this post


Link to post
Share on other sites
3 minutes ago, rmaine said:

Speaking of the "previous best settings", button, I've been meaning to ask if someone knew what happens when I don't press any of the "first guess", "improve guess", or "previous best settings" buttons, but just hit "launch" without pressing any of those. I assume one of those is essentially the default? Or is that actually some different thing?

By default, when launching a new vessel (as in never seen by GT before), the mod will automatically make a first guess. Improve guess only works after a "recorded" launch. Recorded meaning either it was successful or you aborted and saved in the GT GUI.

Share this post


Link to post
Share on other sites
30 minutes ago, rmaine said:

Speaking of the "previous best settings", button, I've been meaning to ask if someone knew what happens when I don't press any of the "first guess", "improve guess", or "previous best settings" buttons, but just hit "launch" without pressing any of those. I assume one of those is essentially the default? Or is that actually some different thing?

I haven't tried LGG's version yet - but in all previous versions of the mod if you didn't hit anything there is a 'default' set of settings that it always uses.  First guess tries to work out something better than that (I think based on initial TWR).

Share this post


Link to post
Share on other sites

Just tried it out in JNSQ and it works great. Ignoring margins of error it was essentially the same fuel spent (though it spent the tiniest freaction more so SUCK IT COMPUTER ALGORITHM) as my own best launch.

Yet Another Must Install Mod :)

Share this post


Link to post
Share on other sites
1 hour ago, 5thHorseman said:

though it spent the tiniest freaction more

Compared to what?

4 hours ago, DStaal said:

I haven't tried LGG's version yet - but in all previous versions of the mod if you didn't hit anything there is a 'default' set of settings that it always uses.  First guess tries to work out something better than that (I think based on initial TWR).

I haven't changed any of that, only the gui stuff

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.