Nhawks17

[1.6.1] RealPlume - Stock [v1.3.1 - 1/14/19] - Better Late than Never Update

Recommended Posts

I've added plumes to the new "Missing History" atomic engines. I hope @Snark likes them. You can grab them here before the next release. There is still no pull request, as the changes are too small to justify that.

odLMCME.png

Share this post


Link to post
Share on other sites

Hey, I'm running MM  v3.1.2 so I've had to install v3.1.1 alongside it for this to work. If I just use v3.1.2 I lose engine sound and plume. 

Does this sound right or am I missing something blatantly obvious?

 

Share this post


Link to post
Share on other sites
Posted (edited)

@DeadJoe You should only use one Module Manager. I've testet MM v3.1.2 and all engines that i've testet so far worked for me.

your Gamedata folder should look like this:

  • RealPlume
  • RealplumeStock
  • SmokeScreen
  • Squad
  • SquadExpansion
  • ModuleManager.3.1.2.dll

If you installed RPS via CKan, the RealPlumeStock folder will be inside the RealPlume folder. you should check this!

You can try the following:

go to your Gamedata folder and delete

  • ModuleManager.ConfigCache
  • ModuleManager.ConfigSHA
  • ModuleManager.Physics
  • ModuleManager.TechTree

check if there is only ModuleManager.3.2.1.dll installed. if not, delete MouleManager.3.1.1.dll

Go to your Kerbal Space Program folder an delete

  • PartDatabase.cfg
  • Physics.cfg

Then do the following

  • Load the game until you get to the main screen.
  • close the game
  • Load the game again an test your engines
Edited by woeller

Share this post


Link to post
Share on other sites

Cheers for that bud, I'll give it a go.

I know to only run with one MM just odd that it only worked with them both in there.

 

Appreciate the response :cool:

Share this post


Link to post
Share on other sites

The configs do not seem to be loading for me on a modded 1.6.

I have them installed in the correct location (I think), in GameData/Realplume-Stock/(lotsoffolders)

I have module manager 3.1.2, RealPlume 11.1.0 and Smoke Screen 2.8.00, which creates its icon on the toolbar, and set to 5,000 particles.

I do not see a "Plume" entry in any of the engine's right-mouse information pop up in the VAB.

Here is a link to my log file: https://www.dropbox.com/s/w4jijksj9v0961d/KSP.log?dl=0

I do not know what I did wrong buut I do have a lot of stuff installed :/ soo yeh. I have tried this without the various visual enhancements and it does the same thing. Do you have any ideas about this?

Share this post


Link to post
Share on other sites
Posted (edited)

@jospannerThere is a newer version of SmokeScreen available. You can get it via CKan or download it directly here: https://ksp.sarbian.com/jenkins/job/SmokeScreen/

Incidentally, this is a fairly large modified installation, and troubleshooting is likely to be difficult. Maybe it's better to start from scratch by moving your KSP Folder out of E:\Program Files (x86)\Steam\steamapps\common\ and do a fresh install of KSP via Steam, then install your mods one after an other and test run KSP between its installation.

Edited by woeller

Share this post


Link to post
Share on other sites

@woeller so just an update, I  removed v3.1.1 and it still works. I have no idea why it only ran with both versions before and not just v3.1.2 but I'm runnin with it. 

Cheers

Share this post


Link to post
Share on other sites
Posted (edited)

@Nhawks17 Arrrgh I just realized that in the configs I made available for the Sounding Rockets mod I left in my custom thrust curve for the SRM-XL booster :sealed: Could you please repack a release with that removed or at least make a note in the OP? Sorry!

Edited by Drew Kerman

Share this post


Link to post
Share on other sites
13 hours ago, Drew Kerman said:

@Nhawks17 Arrrgh I just realized that in the configs I made available for the Sounding Rockets mod I left in my custom thrust curve for the SRM-XL booster :sealed: Could you please repack a release with that removed or at least make a note in the OP? Sorry!

Woops, will do! I'll try and have a repack out by tommorow at the latest :P

Share this post


Link to post
Share on other sites

v1.3.1 Better Late than Never Update

- Updated Module Manager to v3.1.3
- Updated Making History configs
- Updated Sounding Rockets config
- Updated .version file

Download Here

Share this post


Link to post
Share on other sites

so um @Nhawks17 are you redoing the mod now for just big updates or are you back in full blast or is this a one time thing?

Share this post


Link to post
Share on other sites
2 hours ago, Natokerbal said:

so um @Nhawks17 are you redoing the mod now for just big updates or are you back in full blast or is this a one time thing?

I'll just be releasing the pull requests we receive on Github with updated dependencies 

Share this post


Link to post
Share on other sites

So, my rockets have realistic fire effects - at higher altitudes they billow outwards instead of just keeping the normal little flame.

 

But smoke. I have like... ZERO smoke. Worse than stock. There's a teeny-tiny amount there, but it is barely anything.

 

It sure as hell doesn't look like this: 

pEIGWsm.png

Edited by Frostiken

Share this post


Link to post
Share on other sites
4 hours ago, Frostiken said:

But smoke. I have like... ZERO smoke.

LREs do not produce as much smoke as the SRMs so the result that you are seeing is correct.

Share this post


Link to post
Share on other sites
1 hour ago, Phineas Freak said:

LREs do not produce as much smoke as the SRMs so the result that you are seeing is correct.

Sure they aren't as smokey but the current smoke is kind of pathetic. It's like half the length of the rocket flame. LFEs produce a dark smoke and some thick contrails at altitude.

Edited by Frostiken

Share this post


Link to post
Share on other sites
On 1/20/2019 at 11:25 AM, Frostiken said:

LFEs produce a dark smoke and some thick contrails at altitude.

The current assets have white smoke (an all-around solution for both low and high altitude smoke + a kind of condensation). Contrails cannot really be modeled, as they depend on more parameters than just atmospheric pressure.

In any case, the "LREs do not produce smoke" issue has been beaten to death in the past.

Share this post


Link to post
Share on other sites

I'm having a problem with the way cryogenic engines mod looks with realplume. Is it supposed to look like this:vvQepKK.jpgThey don't look anything like the engine exaust on the cryo engines pictures. Also real plume looks fine on all the other engines. As in they look great. My installed mod list is:

B9 Part Switch

Community Resorce Pack

Community Tech Tree

Cryogenic Engines

Cryogenic Tanks

Deployable Engines Plugin

Dynamic Battery Storage

Easy Vessel Switch

Engine Lighting

Kerbal Alarm Clock

Kerbal Atomics

Kerbal Attachment System

Kerbal Engineer Redx

MechJeb2

Module Manager

Real Plume

Real Plume Stock Configs

Scansat

Smoke Screen Extended FX Plugin

Would the log files also help?

Edited by XenophonAnabasis
Original issue was not an issue. Hopefully this one is though.

Share this post


Link to post
Share on other sites

CKAN will not let me download this mod because it isn't compatible with 1.6? Even though the front page says it IS compatible... Perhaps some version file for CKAN was incorrectly configured?

Share this post


Link to post
Share on other sites
41 minutes ago, MysticDaedra said:

CKAN will not let me download this mod because it isn't compatible with 1.6? Even though the front page says it IS compatible... Perhaps some version file for CKAN was incorrectly configured?

Try refreshing 

Share this post


Link to post
Share on other sites

Anyone know how to change a plume type of an engine? I want to change the poodle and the Terrier to orange hypergolic not the white one

Share this post


Link to post
Share on other sites

@Natokerbal Facepalm.png You should read more than just a title.

It is the same method. Find the config you wish to change. Read the documentation how to add a plume to an engine and you will figure out how to change the plume of an engine. Don't expect anyone to write a "how to" for you when there is already exactly what you are looking for.

Share this post


Link to post
Share on other sites

@Jack the Green Ghost As you may know, RPS depends on Real Plume and Smoke Screen. You can see all available plumes here: https://github.com/KSP-RO/RealPlume/wiki/PreFabbed-Plumes-and-Screenshots

For now, there is no possibility to change a plume by config to get a green one. But you could make and add your own particle and config to Real Plume to get something like this:

o8GLGd9.png

Edited by woeller

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.