Jump to content

[1.8-1.11.x] Trajectories v2.4.0 (2021-02-07) : atmospheric predictions


Recommended Posts

8 hours ago, kurgut said:

Hi @Kobymaru , Is there a way so I can see the predicted trajectory after staging, since most of the time, i've got something like reentry pod+service module/engine I decouple before reentry, then the predictions change slightly.

Is that possible, or do I need to eyeball it?

Thanks :)

The best, and not entirely unrealistic, workaround is to leave little bit of a maneuvering dV on your final stage to clean up the trajectory after staging. Aim for an initial periapsis that has some room to lower and/or raise

Link to post
Share on other sites
52 minutes ago, dlrk said:

The best, and not entirely unrealistic, workaround is to leave little bit of a maneuvering dV on your final stage to clean up the trajectory after staging. Aim for an initial periapsis that has some room to lower and/or raise

Ye, that's what I went for, and with RCS, it's all right (also set 0 force to the decoupler).

Link to post
Share on other sites
2 hours ago, infinite_monkey said:

Is it possible to change the color of the crosshair indicator somewhere? I recently installed SciFi Visual Enhancements, and on Duna it's REALLY hard to see the indicator in full daylight.

Currently the colour is set in the code, so no unless you make a private build.

Link to post
Share on other sites
  • 4 weeks later...

I just noticed this, too.

When in the VAB, there's a strange error to most of my spacecraft. Something like "Unknown Trajectories Module."

The mod's toolbar button doesn't appear after loading a fresh copy.

I'll consider that workaround until things are updated.

Link to post
Share on other sites
On 4/11/2019 at 7:26 AM, Devoblue said:

On a fresh install of 1.7.0 this mod (v2.2.2) doesn't work, but after copying the file \GameData\Trajectories\Plugin\Trajectories16.bin to Trajectories17.bin, limited testing indicates it still works fine.

Looking at the 2.2.2 folder, I found Trajectories13.bin, 14, 15, and 16.bin. Didn't find a 17.bin in that or the 2.2.1 folder. Can you point us to where that 17.bin file was and where to place it again?

Link to post
Share on other sites
15 hours ago, OrbitsR4Sissies said:

Looking at the 2.2.2 folder, I found Trajectories13.bin, 14, 15, and 16.bin. Didn't find a 17.bin in that or the 2.2.1 folder. Can you point us to where that 17.bin file was and where to place it again?

You just need to make a copy of Trajectories16 and rename it to Trajectories17. That's it. 

Edited by dok_377
Link to post
Share on other sites
15 hours ago, Kilo60 said:

Is there any way to get this to work with 1.7?

The answer was three posts above yours.  It is generally accepted practice that one reads the last couple of pages of a thread to which one is a new visitor before posting problems just to see if the issue has been addressed already.  It saves on people repeating themselves.

Link to post
Share on other sites
  • 4 weeks later...
On 5/13/2019 at 8:45 PM, dlrk said:

This still being worked on?

I'm busy with real life, and looks like PiezPiedPy is too. We could probably push out a point release for 1.7 compatibility, but it would basically be a recompile and wouldn't have new stuff in it.

Link to post
Share on other sites

Did you rename /GameDataTrajectories/Plugin/Trajectories16.bin to Trajectories17.bin? (If not, this is the third time it's been mentioned on this page alone; *please* read the last few pages of a mod's thread before asking support questions.)

Edited by Blothorn
typo
Link to post
Share on other sites
  • 3 weeks later...
On 4/19/2019 at 1:52 AM, 3PoundsOfFlax said:

Yes, go to \GameData\Trajectories\Plugin and rename Trajectories16.bin to Trajectories17.bin

I had copied Trajectories16.bin to Trajectories17.bin and replaced the 8 line from \GameData\Trajectories\Trajectories.version.

This specific line is now "KSP_VERSION_MAX":{"MAJOR":1,"MINOR":7,"PATCH":1}

Is working now.

Link to post
Share on other sites
On 6/7/2019 at 8:03 PM, N70 said:

Hey, I suggest ya'll change the .bin to .kbin, for Kopernicus 1.7.1 compat, like I had to do for Kerbalism.

Does it work OK once that's been changed?

Link to post
Share on other sites
41 minutes ago, dlrk said:

Does it work OK once that's been changed?

Yes, but you can't just rename them to .kbin, it won't work.

It has to be changed code-side on the mod.

Link to post
Share on other sites
8 hours ago, dlrk said:

Anyone got a compiled one to share?

Just rename Trajectories16.bin to Trajectories.dll, delete the other .bins and the bootstrap.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...