politas

CKAN (The Comprehensive Kerbal Archive Network); v1.22.1 - Georgy

213 posts in this topic

Hi, 

Could someone take a look at Stock Visual Enhancements please, 3 versions have come out in the last 2 weeks which ckan isn't picking up. @Galileo has made some changes to the format of the mod so guessing that's probably why ckan isn't updating automatically?

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, Torih said:

Hi, 

Could someone take a look at Stock Visual Enhancements please, 3 versions have come out in the last 2 weeks which ckan isn't picking up. @Galileo has made some changes to the format of the mod so guessing that's probably why ckan isn't updating automatically?

Thanks

We're working on it. 

1 person likes this

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

First one is difficult, I've started, but asked for help

2nd one (new reaction wheels) is done

I'll look into why the UpgradeGUI isn't there yet

Why don't you merge the two NK-33 mods into one? Doesn't make sense to have a single part in a mod.  What I'd do is have a single directory (for now, call it MadScientist) as follows:

GameData/MadScientist/Parts/NK33

GameData/MadScientist/Parts/NK33_125

Last one (antenna progression), I've asked the author for permission.

 

Hey linuxgurugamer,

Thank you very much!! :wink:

 

And the NK-33 mods aren't mine, they were made by Mad Rocket Scientist .

 

I just want to help with CKAN. :wink:

 

1 person likes this

Share this post


Link to post
Share on other sites
Just now, N3N said:

 

Hey linuxgurugamer,

Thank you very much!! :wink:

 

And the NK-33 mods aren't mine, they were made by Mad Rocket Scientist .

 

I just want to help with CKAN. :wink:

 

I understand, but you really should ask for permission from the author before this sort of request.

Share this post


Link to post
Share on other sites
Just now, linuxgurugamer said:

I understand, but you really should ask for permission from the author before this sort of request.

 

Oh, sorry, I didn't want to do the wrong thing, I listed it, because I read it in his post, that he wanted to add it to CKAN and thought he might want help with it.

I didn't want to make a request without his permission. Sorry! :(

Share this post


Link to post
Share on other sites
20 minutes ago, N3N said:

 

Oh, sorry, I didn't want to do the wrong thing, I listed it, because I read it in his post, that he wanted to add it to CKAN and thought he might want help with it.

I didn't want to make a request without his permission. Sorry! :(

Not a problem, I've already asked

1 person likes this

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

@Olympic1

I make the following as a start for the KPBStoMKS, but it's going to need some work.

specifically, it needs to have at least one of the following mods installed:

MKS, Konstruction, USI-LS, or OSE Workshops

So I'm wondering if you could help:


{
  "spec_version": "v1.4",
  "install": [
    {
      "install_to": "GameData",
      "find": "KPBStoMKS"
    }
  ],
  "depends": [
    { "name": "ModuleManager" },
    { "name": "KerbalPlanetaryBaseSystems" },
    { "name": "FirespitterCore" }
  ],
  "$vref": "#/ckan/ksp-avc",
  "$kref": "#/ckan/github/DanStaal/KPBStoMKS",
  "x_via": "Automated Linuxgurugamer CKAN script",
  "identifier": "KPBStoMKS",
  "license": "MIT"
}

 

It's a bit of an annoying one but after looking into it, it needs KPBS (obviously) and MM. Because it is mostly made for MKS, I should depend on UKS and recommend/suggest USI-LS, Workshop, ExtraPlanetaryLaunchpads and ConnectedLivingSpace.

Share this post


Link to post
Share on other sites
2 hours ago, Olympic1 said:

It's a bit of an annoying one but after looking into it, it needs KPBS (obviously) and MM. Because it is mostly made for MKS, I should depend on UKS and recommend/suggest USI-LS, Workshop, ExtraPlanetaryLaunchpads and ConnectedLivingSpace.

It definitely shouldn't reccomend EL because RoverDude has dropped EL in favor of GroundConstruction (which is now a required and bundled dependency). Also don't know why you'd suggest CLS because while both KPBS and MKS have compatibility patches, I wouldn't call it a recommended mod. 

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites

CLS should probably be Suggested, not Recommended, IMHO. You can throw an explicit dependency to GC Core if you don't want to depend on the one bundled with USI/MKS. Similar goes for CC core (Alista's configurable containers).

Share this post


Link to post
Share on other sites
On 2017-4-19 at 0:51 PM, politas said:

We're working on it. 

Hi, ckan is now trying to update SVE, I've double checked Github and it appears the work has been done.

However it's trying to install version 1.0 and not 1.2.2, it's also only attempting the textures, the configs are not showing the update:

https://www.dropbox.com/s/osa18rpgaj7ynmz/Screenshot 2017-04-21 02.24.24.png?dl=0

Apologies if its still being worked on :)

Share this post


Link to post
Share on other sites
10 hours ago, Torih said:

Hi, ckan is now trying to update SVE, I've double checked Github and it appears the work has been done.

However it's trying to install version 1.0 and not 1.2.2, it's also only attempting the textures, the configs are not showing the update:

https://www.dropbox.com/s/osa18rpgaj7ynmz/Screenshot 2017-04-21 02.24.24.png?dl=0

Apologies if its still being worked on :)

Yes, as is often the case with SVE updates, the packaging method is all different. You will now need to install "Stock Visual Enhancements", which requires you to install one of the three texture options. The texture packs can thus remain far more stable, and version 1.0 is the correct version number for them (It's actually version 3:1.0 in CKAN) It will probably be easier if you uninstall the existing SVE version and install the new one de novo rather than trying to upgrade.

2 people like this

Share this post


Link to post
Share on other sites

Hi, Mac user here, and whenever I try to run ckan, whether through the command line or the new ckan.app, terminal tells me it can't find my ksp version in my readme.txt. The readme is still there and displays the correct version number, so I'm not sure what's going on.

 

Edited by Deus Zed Machina

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now