Jump to content

[WIP][1.0.2] WarpShip 0.3.2 - Update/expansion of IXS Enterprise


Sophia
 Share

Recommended Posts

4 hours ago, Nansuchao said:

Thanks a lot. 

Yes, the works of Sophia made this mod better also than the initial release of Stevie, that was revolutionary.

 

On a side note, congratulations for your others mods. You're one of the best contributors of this community.

Thanks! :) I am building mods to have the stuff I want in my save and I'm happy to share. Speaking of which, here is the recompiled dll.

Link to comment
Share on other sites

  • 2 weeks later...
On 8/27/2015 at 3:53 AM, Kershu5 said:

As I'm not using KSPI:E, I may be missing something important- how the heck do I generate warp plasma? I'm just using this along with USI's stuff. I like the idea of the plasma generators but unless I bring positively HORRENDOUS amounts of plasma with me it's not really worth it..

e: also, how the deuce to get the develocitizer to work, keeps saying it has no power..?

ee: figured most of it out, just gotta work out why the warp ring is giving me trouble now. Almost there!

Can anyone enlighten me about the develocitizer ?

I have full elec charge on the Main Hull, no other systems draining but it still says "no power"

Link to comment
Share on other sites

The Develocitizer has HUGE energy requirements based on how fast you're going- if you're going at like say 8000 m/s then you need truckloads of EC to /stop/.  If you don't have enough power to come to a dead stop, it won't work and will say "no power".  I should have mentioned that, sorry.  So either bring metric truckloads of EC or do warp-jumping until you can slow yourself down manually.

Link to comment
Share on other sites

  • 2 weeks later...

Gotta say thanks to everyone who has contributed to this mod , ever since i've seen pics of it i've been hooked on the idea of flying it

screenshot2_2.png

Pretty much what I expected an some more , its running really well with no issues in Win7/KSP 1.05/ 64Bit workaround , very happy , hopefully look forward to future updates when you have the time .

Link to comment
Share on other sites

  • 2 weeks later...

I'm getting CTDs with the spacedock part. Try adding 6-7 spacedocks to any station or ship in the SPH or VAB. Gives me a CTD every time. Absolutely nothing in either log file - it's a real, instant crash. My guess for the cause would be the number of light sources, since each dock has 8 omnidirectional lights, so it could be dependent on whether OpenGL or DirectX is used. I'm on Linux (GL only) and can't test for Windows (i.e. DirectX) - can anybody else verify that the CTD does, or doesn't, happen on Windows too?

edit: in fact, it's trivially easy to get a CTD, just by moving a part that has a few (4+) large docks attached to it.

Edited by Bluebottle
clarity
Link to comment
Share on other sites

On 1/5/2016 at 1:15 AM, Kershu5 said:

The Develocitizer has HUGE energy requirements based on how fast you're going- if you're going at like say 8000 m/s then you need truckloads of EC to /stop/.  If you don't have enough power to come to a dead stop, it won't work and will say "no power".  I should have mentioned that, sorry.  So either bring metric truckloads of EC or do warp-jumping until you can slow yourself down manually.

Not the point but i found the Problem - if you deactivate the Warp Drive before develocitising it doesnt matter how much EC you have on board - it always says "No Power"

@Sophia Can you perhaps share the names of the nodes used in the QV Thruster model ? I am trying to add a docking port to the aft part - i wanted to have some way to re-dock the Ship inside the Spacedock withoud adding any extra parts

 

Link to comment
Share on other sites

  • 3 weeks later...

Well, the Downloadlink is offline. Kerbalstuff.com has been shut down.

I tried using this one: http://www.curse.com/ksp-mods/kerbal/224077-ixs-class-1-0-for-stock-ksp
From this Thread:

Which is the old Mod this one here is based on. But it's incredibly out of date and while the Parts DO show up and can be placed... many of them just won't connect / attach to ANYTHING, not even Surfaces, much less the Nodes they were clearly intended to attach to.

I learned just now that the old Stock IXS has been abandoned ever since 0.25 or something, and is riddled with Bugs, despite its BEAUTIFUL Design... you can't even buid it since some Parts won't snap to anything. Reports where it did get past this Stage are even worse.

 

Is there any other Way to download and get this Mod to work, instead?

Edited by BlackSun
Link to comment
Share on other sites

4 minutes ago, BlackSun said:

Thank you very much!

So, basically, this Mod is destined to fail working at some Point, if nobody gets on it?
That's a Shame, the Ship looks so pretty. :<

Well if it's warp travel you want to do, you can use KSPI-E which has integrated the Warp Coils into a coherend balanced warp drive mechanism

Link to comment
Share on other sites

14 hours ago, FreeThinker said:

Well if it's warp travel you want to do, you can use KSPI-E which has integrated the Warp Coils into a coherend balanced warp drive mechanism

Nu, it's the Ship I like. But the Ship without Warp Capability isn't all that useful, either. I've recently informed myself about the interesting Concept, and it sure as Hell looks frakkin' cool. Still have to figure out how to work her, though - blew up on me as soon as I activated the Alcubierre Drive. :0.0:

Ooookay, are there any Tutorials or Manuals available for this Thing...? Keeps blowing up XD
1) Don't activate the Warp when not on full Throttle.
2) Don't decrease the Throttle at all while in Warp.
3) Don't set the Warp Drive to Warp 0. Ever.
4) Don't waste your Time building Escape Pods...

Edited by BlackSun
Link to comment
Share on other sites

It's the same Ship Model, but I thought the Mod now uses different, stand-alone Ressources for the Funtionality?
USI Alcubierre Warp Drive Warp Drive Mod, as linked in the first Post here, works differently, though. The Warp Drive isn't Throttle controlled, instead it blows up if you touch the Throttle! But, if it's still the same as over there, sure I'll give it a Look. Thx!

Edited by BlackSun
Link to comment
Share on other sites

On 3/2/2016 at 4:23 AM, BlackSun said:

It's the same Ship Model, but I thought the Mod now uses different, stand-alone Ressources for the Funtionality?
USI Alcubierre Warp Drive Warp Drive Mod, as linked in the first Post here, works differently, though. The Warp Drive isn't Throttle controlled, instead it blows up if you touch the Throttle! But, if it's still the same as over there, sure I'll give it a Look. Thx!

Yes from what I understand, @Sophia reworked the mod to use different resources. I just recompiled the DLL so it would work in KSP 1.0.5 and fixed the develocitizer so that it would use whatever energy was available to slow the ship down as much as possible instead of claiming "No power" and doing nothing. It's a pretty fun mod, I must say. :)

Link to comment
Share on other sites

  • 2 weeks later...
2 hours ago, Denko666 said:

Ok, what would one need to continue this mod?

Not much, actually. All you'd need to do is fork the repro (mine is updated to KSP 1.0.5), and keep the plugin compiled to the latest version of KSP. If there are bugs, you'd need to fix them, and of course add whatever enhancements that you feel the mod needs. :)

Link to comment
Share on other sites

38 minutes ago, Angel-125 said:

Not much, actually. All you'd need to do is fork the repro (mine is updated to KSP 1.0.5), and keep the plugin compiled to the latest version of KSP. If there are bugs, you'd need to fix them, and of course add whatever enhancements that you feel the mod needs. :)

 

Ive been watching the first of the mod tutorial videos on here, So:

- Parts: text editor,... Somehow i think i can manage that.

- Models: I guess ill finally get to learning blender.

- Modules: not a clue how to do these, havent seen that video yet.

So, if i'm right modules are stored in DLLs? I noticed most repositories contain Visual Studio project files... I'm a Mac and Linux user... With a firm aversion of anything M$. Is Visual Studio required? Or in short: how do i keep the dll updated?

I probably should have started with this: would you be willing to help get me on track?

 

Link to comment
Share on other sites

2 minutes ago, Denko666 said:

 

Ive been watching the first of the mod tutorial videos on here, So:

- Parts: text editor,... Somehow i think i can manage that.

- Models: I guess ill finally get to learning blender.

- Modules: not a clue how to do these, havent seen that video yet.

So, if i'm right modules are stored in DLLs? I noticed most repositories contain Visual Studio project files... I'm a Mac and Linux user... With a firm aversion of anything M$. Is Visual Studio required? Or in short: how do i keep the dll updated?

I probably should have started with this: would you be willing to help get me on track?

 

For the DLL files, not sure. You might be able to use MonoDevelop, but honestly I use Visual Studio so I don't have experience with it.

Link to comment
Share on other sites

4 hours ago, Angel-125 said:

For the DLL files, not sure. You might be able to use MonoDevelop, but honestly I use Visual Studio so I don't have experience with it.

Ximarin for MacOS X seems to do the trick. its even so much the same that i could follow the first few modding tutorials without having to look for stuff.

1st thing i am looking to change is the sound the QV drive makes.... doesn't that just drive you utterly nuts? 

Next thing i guess is learning ModuleManager language, so i can start integrating with other mods, like DeepFreeze and KIS and the switchable containers from Pathfinder ;)

Link to comment
Share on other sites

Made my fork of the mod here: https://github.com/bartblommaerts/warpship....  For those brave enough to deal with beta software. 

Changelog included in zip.

Warpship for KSP 1.1.1 : https://www.dropbox.com/s/saeg236rk6aukow/IXSWarpship0S-0.3.4-1.1.1.zip?dl=0

Warpship for KSP 1.1.2 : https://www.dropbox.com/s/bur8dwdvfq4l6mm/IXSWarpshipOS-0.3.5-1.1.2.zip?dl=0

Warpship for KSP 1.1.2 test: https://www.dropbox.com/s/hoelvsl1k76hv47/IXSWarpshipOS-0.3.6b-1.1.2.zip?dl=0

Edited by Denko666
Drive not working in space fix
Link to comment
Share on other sites

8 hours ago, Nightside said:

@Denko666 Glad someone is taking care of this mo! But do you really need Deep Freeze when you can warp?

Not sure if cryogenics are still necessary in a warp capable ship. But it 'll be a MM generated part based on the crew cylinder. So you can choose how you want to fit the ship

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...