Jump to content

[Minimum KSP version - 1.8] Kerbal Attachment System (KAS) v1.7


Recommended Posts

2 hours ago, Angel-125 said:

@IgorZ Question for you as I upgrade Pathfinder:

The old KAS had KASModulePort and KASModuleStrut, both of which I used for pipelines and the Mineshaft crew tube. Do I understand correctly that I now need KASLinkResourceConnector, KASRendererPipe, and KASJointCableBase?

Thanks again for all your hard work! Pathfinder has benefited greatly because of your efforts. :)

Could you, please, describe the use-cases where the legacy KAS modules come to play? Sorry, I never used your mod, so some images or videos may help a lot :)

Link to post
Share on other sites
15 hours ago, DragonsForce said:

Also, EVA attachment does not give me a "preview" for placement anymore, I have to guess where the part will end up. Is that intentional? (I guess it would be a KIS issue and not KAS, but whatevs)

Hello ! 

I have the same issue. I can’t see anymore the parts I’m fixing (only the attachement point in some conditions). 

I noticed it happened when I upgraded from KIS 1.4 to 1.5. 

With KAS 1.5 & KIS 1.4, everything is Ok; but with KIS 1.5 the issue appears.

Note I upgraded KAS a few days before KIS (removing the old folder before, etc).

Downgrading back to KIS 1.4 fixes the issue. 

 

I am on KSP 1.5, running on Linux (and the parts that didn’t show come from the MKS mod, among others).

(Sorry, I can’t provide screenshot nor logs, I just have my phone for a couple of days). 

 

However, thanks for your awesome work :)

Link to post
Share on other sites
12 hours ago, DragonsForce said:

 

This is what I expect it to look based on previous versions (image taken from the KIS handbook)

 

This is what it looks like for me. There is no visual indication of the object to be placed before I actually place it down.

EDIT: I just discovered that this still works for the old parts. It does not work for several of the new parts however. (I tested the non-batterie pylon and the two transfer pipe parts)

Can confirm I'm observing the same with KAS 1.0 and KIS 1.15. Also even with the electric screwdriver cannot get node attachments to happen. It part preview worked prior to KIS 1.15 (so may be a KIS not KAS problem). Node attachment has not worked since KSP 1.5 and KAS 1.0.
Both parts that I tried to attach to the nodes were scraps generated by rescue kerbal & recover scrap missions. I'm happy to do further tests if necessary. I didn't see anything in my log but I can create the situation and make the attempt and get logs if desired.

Link to post
Share on other sites
6 hours ago, IgorZ said:

Could you, please, describe the use-cases where the legacy KAS modules come to play? Sorry, I never used your mod, so some images or videos may help a lot :)

Sure thing. :) Here is what I typically do with the legacy modules. This first image is a connection between my base and a launchpad. The launchpad is a 20m in diameter part, so I drop it on the ground, attach the pipe, and use the pipe to feed the resources it needs to assemble from a box into the pad. Once built, the pipe also serves to transfer the resources needed to build new spacecraft via Extraplanetary Launchpads. This is a typical use case, I have several parts in Pathfinder that use a pipe to get resources.

yj897h5.png

Here's another case. Here I have two rovers connected together through the legacy pipe system. In this case, the crew transfer tube is just one big pipe. As above, the crew tube also transfers resources between the rovers.

6rpnRxq.png

Hope that helps. :)

Edited by Angel-125
Link to post
Share on other sites

I recently tested out the Universal Storage2 mod, and a winch and rts wedge parts would make a good match along with the connector part. Perhaps with integrated battery to fill the wegde with connector.

Just an idea for future parts-catalog.

/mrstoned

Oh, and btw, in the past (before using mks's logistics feature) i used the pipes to connect resource consumers like generators;

 

T7gsgDu.png

NaIX3PW.png

 

The last pic is a drillrig with converters and tanks, connected via pipes. The generators and parts was used from LLL in the waaaayback ago.

 

/mrstoned

Link to post
Share on other sites

@Geeb, @helaeon,

This issue has already been investigated (and will be fixed soon). Thank you for the report!

@Angel-125,

For the first approach you can (and should) use RTS-1 part. So the change is pretty simply and obvious. The second approach is not that straightforward. Technically, RTS-1 or any of the TJ parts can be used for the same purpose (in docked mode). Except they will not look like a "corridor". Old KAS was giving the connector pipes of any diameter from nowhere, but in new KAS you have to bring this stuff. I.e. it should be a new part. Nothing exists for now.

@mrstoned,

Sorry, I didn't get the idea. What is "rts wedge" part and how do you plan to use it with the winches?

Link to post
Share on other sites
50 minutes ago, IgorZ said:

@Geeb, @helaeon,

This issue has already been investigated (and will be fixed soon). Thank you for the report!

@Angel-125,

For the first approach you can (and should) use RTS-1 part. So the change is pretty simply and obvious. The second approach is not that straightforward. Technically, RTS-1 or any of the TJ parts can be used for the same purpose (in docked mode). Except they will not look like a "corridor". Old KAS was giving the connector pipes of any diameter from nowhere, but in new KAS you have to bring this stuff. I.e. it should be a new part. Nothing exists for now.

@mrstoned,

Sorry, I didn't get the idea. What is "rts wedge" part and how do you plan to use it with the winches?

Ok, for the first case of pipe connectors between parts, I see what to do. But for the second case, as you say, pipe connectors cannot be of any diameter any more. How do I make a part with the correct diameter?

Link to post
Share on other sites
4 hours ago, IgorZ said:

Sorry, I didn't get the idea. What is "rts wedge" part and how do you plan to use it with the winches?

I think that he's asking for the resource transfer spool in a Universal Storage II-compatible unit, aka a "wedge". It's certainly an interesting idea, and one that would likely be most welcomed.

Edited by MaverickSawyer
Fixing issues caused by mobile editor weirdness
Link to post
Share on other sites
3 hours ago, Angel-125 said:

How do I make a part with the correct diameter?

Are you maintaining the part on the screenshot? I thought it's a KPBS flexible corridor part. Technically, you can simulate the same behavior (pipes from nowhere) in the new KAS, but it won't be a good idea. One of the solution could be taking TJ-1 part and scaling/texturing the pistons.

Link to post
Share on other sites

Im talking about this mod 

 

It have a sorts of central hub which fits "wedge" style parts.

It's basiclly a slightly downscaled texture with a mountingframe behind it to allow it be slotted into the hub.

I think the winch, rts and a connector with battery(?) wedge parts would fit into the design.

/mrstoned

 

Link to post
Share on other sites
8 hours ago, IgorZ said:

Are you maintaining the part on the screenshot? I thought it's a KPBS flexible corridor part. Technically, you can simulate the same behavior (pipes from nowhere) in the new KAS, but it won't be a good idea. One of the solution could be taking TJ-1 part and scaling/texturing the pistons.

I never thought of the KPBS parts as tubes from nowhere. I always thought of the flexible corridor parts to be a simulation of something like the tube below. The existing KPBS flexible corridor part contain a collapsed section that a Kerbal grabs and extends to make the final tube. It's just been a limitation of the previous KAS that it acts like a rigid tube and the texture makes it look like a rigid tube. All connections already require 2 parts, so half the length would be in each part even though you always grab one end and pull it to link to the other side. In vacuum something like this doesn't need ribs as air pressure would maintain the shape so it could conceivably use very little volume when collapsed. In my imagination any resource transfer hoses and electrical wiring would be laid inside after the tube was connected and not carried by the visible tube itself. I could see changing the KPBS model of the flexible corridor part to be similar in size to the KBPS corridor airlock part to account for a bulkier material.  It really boils down to how much volume for the basic part is necessary to be realistic.

@Angel-125's crew transfer tube looks more like a collapsed folded section section of tubing than KPBS, so again not really tubes from nowhere, but the connected tube texturing doesn't maintain the flex tube look of the bases. I've never used the Buffalo rover, so I'm guessing it acts just like the KPBS flexible corridors.

@IgorZ FYI, I updated to KSP 1.5.1 last week and have been running the latest versions of KIS and KAS as they come out. I haven't had much time to play lately, but so far I haven't seen any new bugs. :)

6a00d83451b71a69e20133ed197c14970b-pi

Edited by Tonka Crash
Link to post
Share on other sites
9 hours ago, IgorZ said:

Are you maintaining the part on the screenshot? I thought it's a KPBS flexible corridor part. Technically, you can simulate the same behavior (pipes from nowhere) in the new KAS, but it won't be a good idea. One of the solution could be taking TJ-1 part and scaling/texturing the pistons.

Yes, I'm maintaining all the parts in that screenshot. :) Is there a special mesh I need to make that I need to make? Why is pipes from nowhere not a good idea in the new KAS? Thank you for answering my questions as I try to understand what changes I need to make to support the latest version. :)

Link to post
Share on other sites
6 hours ago, Tonka Crash said:

It's just been a limitation of the previous KAS that it acts like a rigid tube and the texture makes it look like a rigid

Any old KAS connection is rigid, which doesn't fit the idea of "flexible corridor". In fact, it looks and behaves as a rigid connection. So I'd say assuming it's "a presentation limitation" is kind of too optimistic :) 

4 hours ago, Angel-125 said:

Is there a special mesh I need to make that I need to make?

Depends on your part design. How it should look exactly I cannot tell, I'm not a modeler. I'm thinking about a specialized link type in KAS. Need some time to study the Bezier curves. If I manage to render the pipes on a curve, then we'll be able to introduce a true flexible corridor as described by @Tonka Crash.

4 hours ago, Angel-125 said:

Why is pipes from nowhere not a good idea in the new KAS?

Because new KAS is aimed to be as realistic as possible and feasible. If you mount a pipe in EVA, then this pipe must be either delivered from Kerbin or manufactured locally by expending a material resource. Approach where we only suggest the pipe was somehow hidden in the part is not exactly realistic.

Link to post
Share on other sites
5 minutes ago, IgorZ said:

Because new KAS is aimed to be as realistic as possible and feasible. If you mount a pipe in EVA, then this pipe must be either delivered from Kerbin or manufactured locally by expending a material resource. Approach where we only suggest the pipe was somehow hidden in the part is not exactly realistic. 

Angel's corridors are actually the least hidden of the lot - the whole white corrugated section is the 'docked port', so really what you're seeing is the corrigations extending and meeting.  Given the walls are likely very thin, you could make a fairly long temporary walkway out of those.  Certainly as long as I've ever built something out of them.  You're not going to coil the meter-diameter corridor - you're going to flatten it, so it doesn’t take as much space.

The corridors in MKS and KPBS are much flatter, and would be harder to justify.  (I could still see it in MKS - KPBS though is likely trying to store the corridor inside the building or something - they're just flat.)

If you look at building a corridor part in, I'm sure between @Angel-125, @RoverDude, and @Nils277 they can come up with some designs for you.

The other part that's in common use that's not part of the main KAS is the electrical cord, introduced by the SEP mod, and supported by Pathfinder and KPBS.  This would just be a smaller-diameter resource transfer cord.  (Maybe have the cord itself be something deployed from KIS?)

Link to post
Share on other sites

@IgorZ

I'm not sure this is a bug or not:

I'm updating a mod, and added the following to the part:

        MODULE:NEEDS[KIS]
        {
                name = ModuleKISItem
                shortcutKeyAction = drop
                useName = use
                usableFromEva = false
                usableFromContainer = false
                usableFromPod = false
                usableFromEditor = false
                stackable = false
                volumeOverride = 0
                moveSndPath = KIS/Sounds/itemMove
                equipable = false
                equipMode = model
                equipSlot = <null>
                equipSkill = <null>
                equipRemoveHelmet = false
                equipBoneName = aliasHelmet
                equipPos = (0, 0, 0)
                equipDir = (0, 0, -1)
                carriable = false
                allowPartAttach = 2
                allowStaticAttach = 0
        }

In my test, I'm able to take the part out of the inventory and attach it to another part, and then able to detach and grab it from that part.

The problem I'm having is that I can't put it back into the inventory because the cursor (and green shadowed part) go underneath the inventory window.  Am I doing something wrong, or is this a bug?

Here is the log file, if needed:  https://www.dropbox.com/s/0aw5flhuhtzo4dk/kis.zip?dl=0

Thanks in advance

Edit:  I also tested with other parts (science parts),  and had the same behaviour.

The kerbal was an level 5 engineer

Edit 2:  This seems to be the same issue as what @DragonsForce and @Geeb reported earlier

Edited by linuxgurugamer
Link to post
Share on other sites
3 hours ago, linuxgurugamer said:

The problem I'm having is that I can't put it back into the inventory because the cursor (and green shadowed part) go underneath the inventory window.  Am I doing something wrong, or is this a bug?

This description sounds a usual mistakes for the newbies, who are trying to grab and move instead of pressing and drag. But in your case I'm sure you know how to drag parts from the scene into a KIS inventory, so could you please make a short video to present the issue?

3 hours ago, linuxgurugamer said:

Here is the log file, if needed:  https://www.dropbox.com/s/0aw5flhuhtzo4dk/kis.zip?dl=0

It's a wrong log. The right one is KSP.log.

3 hours ago, linuxgurugamer said:

Edit:  I also tested with other parts (science parts),  and had the same behaviour.

Is there at least one part that works as expected?

3 hours ago, linuxgurugamer said:

Edit 2:  This seems to be the same issue as what @DragonsForce and @Geeb reported earlier

Which issue do you mean? I only seen those guys describing an issue with a preview not shown. This one was fixed in 1.16.

Link to post
Share on other sites
5 hours ago, IgorZ said:

This description sounds a usual mistakes for the newbies, who are trying to grab and move instead of pressing and drag

Ummm, well, I'm not fluent with KIS.  As I was trying to make the video, I realized my mistake, after grabbing it, I was letting go of the G key.  Might I suggest that you put another line in the little popup menu which shows the commands, a line which says to hold the G key to put into an inventory?

I did come up with something else, though, see the attached video with the log file: https://www.dropbox.com/s/4q9mu0edhmcxqfe/kisGlitchDemo.zip?dl=0

Note that on the video, the flashing is intermittent, but on screen, it continuous and very fast, many times per second

 

Link to post
Share on other sites

I am having trouble using RTS-1. If I attach it to something and click it while inside the ship it says "connector state: locked" and if a kerbal walks up to it it says "Grab Connector" but when I click that I get a error beep and nothing happens. What am I missing? The legacy CC-R2 connector port seems to work normally.

I am using KSP 1.5.1.2335 with Making History and with only the KAS 1.1 mod, installed via CKAN.

KAS is a very cool MOD, thank you.

Edit: This happens with EVS 1.9 and KIS 1.16 installed as well, and in a new game.

Edited by Asmodian
Link to post
Share on other sites
2 hours ago, Asmodian said:

If I attach it to something and click it while inside the ship it says "connector state: locked" and if a kerbal walks up to it it says "Grab Connector" but when I click that I get a error beep and nothing happens.

It's expected to see different menu options when you inside the ship or EVA. The error is not expected, though. All "beeps" are also provided with a red message on the screen. Have you seen any? Could you please share a log file?

Link to post
Share on other sites
21 hours ago, kl0buk said:

Hi guys,

I want to ask if my engineer have to be rank 2 or higher to equip screwdriver because I can equip only wrench in my career so far :-/

Thanks

Wrench and screwdriver are available at different tech levels. There is no limit to the kerbal's level.

5 hours ago, Angel-125 said:

@IgorZ Can you show me the Unity mesh hierarchy for your KAS/Models/CommonConnector/Connector.mu? I need that to create the mesh needed for the hose (in my case crew tube) in the new KAS pipe connector system.

After the last Unity update all my mods are down now, so cannot load the model there. If you're working with code, you can use the following method to dump the hierarchy.

Link to post
Share on other sites
1 hour ago, IgorZ said:

Wrench and screwdriver are available at different tech levels. There is no limit to the kerbal's level.

Hi and thank you for your reply. I have both wrench and screwdriver in my kerbal inventory but I can equip only wrench. If I try to equip screwdriver the hand is empty.. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...