Ger_space

[1.7.3] Kerbal Konstructs - 1.7.3.0 - 22.Aug.2019

Recommended Posts

5 hours ago, Spike88 said:

Just downloaded @Beale's South West Launch site in the newest version of Kerbal Konstructs. The launch site is in the middle of the sea, and off to the west of where I believe it should be. What do I need to do to move it back onto land?

For now the only way to get proper rescaling of buildings is to use resizeBuildings set to the same value as Resize

But I'm working on a solution :wink:

...

Nevermind

I thought this was SD thread

Edited by Sigma88

Share this post


Link to post
Share on other sites
8 hours ago, Spike88 said:

Just downloaded @Beale's South West Launch site in the newest version of Kerbal Konstructs. The launch site is in the middle of the sea, and off to the west of where I believe it should be. What do I need to do to move it back onto land?

 

Wait a few more hours and I have a new test- version online, The next release will make it pretty easy to move objects around. (the current beta has a small bug, so edited models show up 40% smaller, then they should).

If you want you can try it: https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/0.9.8.7-beta2

or wait a few hours.

But you can try with the current release:

1. bring a craft of any kind near the base you want to edit. Not onto the object you want to move, because you will fall though them

2. press ctrl +k to open the editor

3. select local instances on the opened window

4. select the object you want to move from the list

5. try to move the object.

 

Share this post


Link to post
Share on other sites

@Spike88

A new release is online: 0.9.8.7-beta3

It's a release for everybody who wishes to edit the statics (moving, placing new ones etc).

Changes:

  • placement of statics is now done by relative movement directions (forward, right, up,...) or absolut movement (north, east. altitude)
  • orientation is relative to the object (pitch, roll, heading)
  • the reference vectors are displayed beside the model.
  • models can be resized
  • if you delete the RadialPosition entry from the .cfg file, a new one will be created with the values from RefLatitude&RefLongitude. this might come handy to move a base over long distances.
  • some smaller bugfixes in the editor

 

Nothing new for users who never intend to touch the editor.

Known issues:

  • editing of Kerbin-side bases might result in duplicates --> This is an old issue
  • the facility editor cannot edit fuel tanks --> also an old issue.

I'll fix the issues for the next release, but feel free to test it.

Share this post


Link to post
Share on other sites
3 hours ago, Ger_space said:

orientation is relative to the object (pitch, roll, heading)

Wow, good news for roadbuilders! :) Thanks, Ger_space !

And... angles have enouch precision?

*download and go to testing*

 

 

Share this post


Link to post
Share on other sites
4 minutes ago, Aerospacer said:

Wow, good news for roadbuilders! :) Thanks, Ger_space !

And... angles have enouch precision?

*download and go to testing*

 

 

Is 0.001 degree precise enough?. There is some minor interlock between roll and pitch, but in the error is smaller than the set value. A self correcting loop could be considered for an other Release, but for the moment I want to fix the other issues first and make a official release.

 

 

Share this post


Link to post
Share on other sites

i think opening up the editor broke in 1.2.2. all the statics show up, but i cant open the editor with ctrl+k.. It may be user error but i tried everything even a recompile of the source so i'm out of ideas lol

no errors in the output log 

 

Edited by Galileo

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

i think opening up the editor broke in 1.2.2. all the statics show up, but i cant open the editor with ctrl+k.. It may be user error but i tried everything even a recompile of the source so i'm out of ideas lol

no errors in the output log 

 

I didn't test the editor in 1.2.2, even when its compiled against 1.2.2 it runs fine in older versions :D (my dev install is 1.2.1, but I link against 1.2.2) I only looked in the 1.2.2 version if the statics are there, --> looked good --> alt+F4 --> back to visual studio

But from the first look in the code... opening the editor should only worked once in a while. the key pressed check runs in FixedUpdate but It should really run in Update, because GetKeyDown is reset each frame (according to unity docs)

the key pressed event is checked in LateUpdate(). I have no idea if it is still allowed in 1.2.2 or if I have to move it to Update(). I'll test it again and release a fixed version as soon as possible.


 

Edited by Ger_space

Share this post


Link to post
Share on other sites
20 minutes ago, Ger_space said:

@Galileo

I tested the Version 1.2.2 I have no problems with the editor. I might be some other mod blocking the KK hotkeys.

The only other mod I had installed was GPP.  OK,  no biggie,  I'll try again and see what happens.  Thanks for looking into it! 

Edited by Galileo

Share this post


Link to post
Share on other sites
10 hours ago, Galileo said:

i think opening up the editor broke in 1.2.2. all the statics show up, but i cant open the editor with ctrl+k

Hi, are you using any other statics apart from the Kerbinside/KK ones,  the editor opening failure can be caused by static models that are made or divided badly, and as you mention usually does not leave an associated error in the log.  If you have added anything new it may be worth removing the instances part of the statics cfg to see if the editor re appears

Share this post


Link to post
Share on other sites

In fact, KAS/KIS has its debug window on that hotkey, either right or left Ctrl+k, but I tried to reassign the KK hotkey to another sequence and nothing happened. KerbinSide bases do not show up either. I'm sorry for being not helpful, I have a day-off tomorrow and really plan to pinpoint the issue.

Share this post


Link to post
Share on other sites
10 minutes ago, SpannerMonkey(smce) said:

Hi, are you using any other statics apart from the Kerbinside/KK ones,  the editor opening failure can be caused by static models that are made or divided badly, and as you mention usually does not leave an associated error in the log.  If you have added anything new it may be worth removing the instances part of the statics cfg to see if the editor re appears

I was using KSC++ but I removed it while trying to troubleshoot and still had the issue.  

I forgot to mention I was using the latest Beta release of KK. I doubt that's the issue though. 

Share this post


Link to post
Share on other sites
1 hour ago, whale_2 said:

In fact, KAS/KIS has its debug window on that hotkey, either right or left Ctrl+k, but I tried to reassign the KK hotkey to another sequence and nothing happened. KerbinSide bases do not show up either. I'm sorry for being not helpful, I have a day-off tomorrow and really plan to pinpoint the issue.

it's KAS and it doesn't matter if it's installed. When the bases are not loaded, KK crashed on startup (mostly because of some broken .cfg files)

 

1 hour ago, Galileo said:

I was using KSC++ but I removed it while trying to troubleshoot and still had the issue.  

I forgot to mention I was using the latest Beta release of KK. I doubt that's the issue though. 

Have you tried to completly remove and install KK?

@whale_2 & @Galileo could you please use the latest beta from gitub and upload the Kerbal Space Program\KSP_x64_Data\output_log.txt file somewhere (open a github issue)

It is a build with DEBUG enabled, normally I should be able to see something in it.

Share this post


Link to post
Share on other sites
Just now, DaGuyAboveYou said:

@Ger_space  I installed KK onto a RSS save to create my own bases but the Ctrl+ K button to bring up the editor does not work. Any solution to this or if Kopernicus is conflicting with KK?

Currently it is a known problem with RSS and KK. (or Kopernicus) I'm sorry about that.

I'll have a look at it next week (on weekends my time for coding is very limited)

I have no idea why there is such a issue, because I know no direct places where a direct reference to Kerbin is made. Maybe Kobernicus doesn't set the "isHome" flag for any planet. but that's my best guess for now.

Share this post


Link to post
Share on other sites

I'm wondering if these issues are a recurrence or the problem from not so long ago, in which KK would not work if added to an existing save, at the time it appeared that KK could not properly create and find the cfg's it writes to the game save file,  symptoms included KK launch selector and KK editor not being functional but all previously placed statics were present. 

The workaround at the time was to uninstall everything except squad and KK from the gamedata folder, then start the game and create a new save, load up that save to check for functionality, then exit,  re add all the mods to gamedata and load up your new save, and usually all was well.  obviously this is no good for players with existing games in which they wanted to add KK but it was usable.

Another possible workaround is to create another install  and use that to position statics etc then copy the cfg's to your existing game. This is the method i use mostly, as it means i don't feel compelled to finish every new base project in one sitting,  as anyone who's spent time making bases and placing statics will tell you, placing statics is not hard but it is very time consuming

For reference i should state that Mondays beta KK is working extremely well for me even without a recompile for 1.2.2,  launch selector, static editor and base boss etc are all fully functional

Share this post


Link to post
Share on other sites

A new Version is online: 0.9.8.8

This version only contains fixes and enhacements for editing/placing the statics.

Special thanks:

@SpannerMonkey(smce) for endless testing and bugreporting of the preview builds

@whale_2 for contributing a load of RunwayMarkings to the default statics pack.

 

Changes:

  • new statics: added runway markings by whale_2. Thank you!
  • new placed objects are written to: GameData\KerbalKonstructs\NewInstances[modelname]-instances.cfg
  • editor: finer increments when editing objects
  • editor: used relative directions instead of altering some vectors.
  • editor: added reference vectors
  • editor: orientation uses reference vectors
  • editor: added scaling of objects
  • editor: facilities are now editable for placed objects
  • editor: fixed editing of Kerbin-Side statics
  • editor: search filters are now case insensitive
  • cfg file loader: "RadialPosition" can be recalculated, when missing, from RefLatitude/RefLongitude
  • all: enabled some more debug output.

 

Now that this release is out, I have some time for the issues with RSS/Kopernicus and hopefully add some cool stuff before the holidays.

 

Edited by Ger_space

Share this post


Link to post
Share on other sites

Thanks, @Ger_space, for this release. I've moved all (or almost all) my statics under NewInstances folder, inspired by @SpannerMonkey(smce) workaround and can confirm that editor window works now and KerbinSide bases can be seen on map.

Share this post


Link to post
Share on other sites
2 hours ago, Ger_space said:

 

 

Now that this release is out, I have some time for the issues with RSS/Kopernicus and hopefully add some cool stuff before the holidays.

 

your the best Ger_space. Keep up the good work man :)

Share this post


Link to post
Share on other sites

@Ger_space
 I'll take a look at it on Monday to see if I can move it properly. Although I do have a question on the changes; Are they made on a save file level or a mod level?

Share this post


Link to post
Share on other sites
15 minutes ago, Spike88 said:

@Ger_space
 I'll take a look at it on Monday to see if I can move it properly. Although I do have a question on the changes; Are they made on a save file level or a mod level?

The changes are all on mod level. You only need to move the base once.

Share this post


Link to post
Share on other sites
Just now, Ger_space said:

The changes are all on mod level. You only need to move the base once.

So if I mess something up I would have to delete the mod and re-install it?

 

Hopefully I can fix the Kosmodrome mod too.

Share this post


Link to post
Share on other sites
5 minutes ago, Spike88 said:

So if I mess something up I would have to delete the mod and re-install it?

 

Hopefully I can fix the Kosmodrome mod too.

NO what he means is that any changes you make are saved to the models cfg, so if you mess it up , you simply delete the instances part of the cfg.

Re SW launch site,  it is where it is supposed to be, right out in the middle of nowhere, I suggest that instead of moving that original spawn a new one in your chosen location and when you are happy with the position use the KK editor again to delete the original version , this will delete the positions instance in the cfg,

and where do you want it to be btw?

Share this post


Link to post
Share on other sites
10 minutes ago, SpannerMonkey(smce) said:

NO what he means is that any changes you make are saved to the models cfg, so if you mess it up , you simply delete the instances part of the cfg.

Re SW launch site,  it is where it is supposed to be, right out in the middle of nowhere, I suggest that instead of moving that original spawn a new one in your chosen location and when you are happy with the position use the KK editor again to delete the original version , this will delete the positions instance in the cfg,

and where do you want it to be btw?

In my game, the SW launch site is showing up in the middle of the ocean. Not on the island it's intended to be on.

Edited by Spike88
Clarification

Share this post


Link to post
Share on other sites
3 minutes ago, Spike88 said:

In my game, the SW launch site is showing up in the middle of the ocean. Not on the island it's intended to be on.

AH thats just a rumor it was always meant to be in the deep as is indicated by the description

Quote

LaunchSiteDescription = Built far out to sea, SWLS is ideal for launching 'less engineered' rockets.

and is why the model is a self contained island,  although i can see why you'd want it elsewhere,  at least a little closer to land.  I can move it and post the cfg for you to paste in if you want, just tell me where.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.