Jump to content

[Min KSP 1.12.2] Blueshift: Kerbal FTL


Angel-125
 Share

Recommended Posts

@Angel-125
Question:

could be an issue in my own install, or is it normal that the various warp generator do not appear selectable in the VAB to be set in the action groups, even with advanced tweakable active?

To simplify my operation I have each time to set them in space (using mods that allow to  modify action groups once a craft is launched) rather than have the possibility to do it in the VAB...

Link to comment
Share on other sites

6 hours ago, Araym said:

warp generator do not appear selectable in the VAB to be set in the action groups

That's something Angel needs to look into. However, you can see them, at least partially, in the in-flight action group editor.

Link to comment
Share on other sites

Hey, I'm new to this mod, but can't quite figure this out.  I built the simplest possible warp ship to see how the mechanics work.  I cheated it into orbit, aimed at eeloo, and started accelerating.  All seemed to work OK until I got most of the way to eeloo, and then the warp drive shut off.  the PAW keeps oscillating between this:
MdWCsLY.png

and this:
eTE6x7R.png

When I try to start the warp drive again, it warps me *backwards* in my orbit, then I continue forwards a bit, and then it shuts off again and the cycle repeats.

Link to comment
Share on other sites

@JonnyOThan Is is possible that your ship's root part is attached in an orientation other than forward, or the warp engine is? Also do you have any actual warp core pieces or warp rings in your craft? The part where the PAWs say you have 0 / 10 warp capacity suggests so. Your ship needs to have all of these:

  • At least one warp core/warp engine. The engine block, basically.
  • A gravimetric displacement generator (maybe) for added ability to use warp capacity. These are your transmission. The warp engine includes this, but not much. The less you have, the less you can do high gear when your ship gets heavy.
  • Warp coils (either rings or nacelle pieces). These produce warp capacity. They're the wheels and wheel axles of your ship.
Link to comment
Share on other sites

57 minutes ago, JadeOfMaar said:

@JonnyOThan Is is possible that your ship's root part is attached in an orientation other than forward, or the warp engine is? Also do you have any actual warp core pieces or warp rings in your craft? The part where the PAWs say you have 0 / 10 warp capacity suggests so. Your ship needs to have all of these:

  • At least one warp core/warp engine. The engine block, basically.
  • A gravimetric displacement generator (maybe) for added ability to use warp capacity. These are your transmission. The warp engine includes this, but not much. The less you have, the less you can do high gear when your ship gets heavy.
  • Warp coils (either rings or nacelle pieces). These produce warp capacity. They're the wheels and wheel axles of your ship.

I mean, I was able to warp 90% of the way to Eeloo.  Then suddenly the thing shuts off.  Activating it again warps me backwards.  I don’t think it’s a problem of ship design...

 

my solar trajectory of course is bonkers, since I’m going ~9000 m/s at an altitude past jool.  I’m wondering if that has something to do without spatial location going nuts, and then maybe why the warp drive stops working.

Link to comment
Share on other sites

10 minutes ago, JonnyOThan said:

I mean, I was able to warp 90% of the way to Eeloo.  Then suddenly the thing shuts off.  Activating it again warps me backwards.  I don’t think it’s a problem of ship design...

Well when you put it that way... There's definitely something fishy going on. Sorry for my bad answer.

Link to comment
Share on other sites

Posted (edited)
1 hour ago, JadeOfMaar said:

Well when you put it that way... There's definitely something fishy going on. Sorry for my bad answer.

No worries, I’m completely inexperienced with this mod so there *might* be something I’m doing wrong, but it seemed like an obvious enough bug that someone must have hit it before...right?

So...while I'm on the way to eeloo, the "spatial location" thing says "interplanetary space."  But when this bug occurs it's flipping between "Insterstellar space" and "Unknown" even though I'm still at a lower altitude than eeloo.  I tried this even with no other planet packs installed too.

If you look at the code here: https://github.com/Angel-125/Blueshift/blob/63bac09bc8057241124fc7f53d43f1b05075a639/Source/Blueshift/SettingsAndScenario/BlueshiftScenario.cs#L537 the only way to get "Unknown" is if `IsInSpace` returns false, and that code is here: https://github.com/Angel-125/Blueshift/blob/63bac09bc8057241124fc7f53d43f1b05075a639/Source/Blueshift/SettingsAndScenario/BlueshiftScenario.cs#L584

So I'm guessing this is just KSP being stupid with vessel situations like it does sometimes...

 

EDIT: ahah, I was on 1.4.0...maybe it's this?  sounds sorta similar:

  • Fixed issue where the warp engine would flame out when transitioning from interplanetary to interstellar space, or when throttling up or down.

I'll grab the latest version and try again.

Edited by JonnyOThan
Link to comment
Share on other sites

The  difficulty option for "enable circularization helper" doesn't really work when turned off.  I can still invoke it *once* after cheating a ship to orbit.  And KOS can still invoke it.

The waterfall warp effects are super cool, but they activate when throttling up the first time the ship is loaded even if the warp drives are off.

Link to comment
Share on other sites

1 hour ago, Angel-125 said:

@JonnyOThan It sounds like the oscillation issue is due to not enough Gravity Waves being generated when going interstellar. I'll have to look at it next week.

No need, I was using blueshift v1.4.0 and it's fixed in the later versions.  I had downloaded it while getting a GU install set up and didn't bother to check for new releases.

But the "enable circularization helper" thing and the waterfall issue I mention are present in the latest version.

Link to comment
Share on other sites

  • 3 weeks later...
20 hours ago, paul63345 said:

I'd like to ask if there's a known reason why adding warp parts to a ship makes it report delta-v of the ship of zero.

If you're hoping to get a dV reading with warp engines, you've got a wrong idea about what you need to know about warp engines.

dV is not a thing here. What you need to know are to simply:

  • Have plenty Graviolium to spare
  • Have enough warp capacity and enough warp core (with extra gravitic generators if needed) that your ship can go faster. The less massive your ship, the more efficient your warp drive is, and the faster you can boldly go.

Once you fly a long trip or two with a warp ship, you get a feel for the fuel consumption. After that, it's only a matter of "If you're worried about fuel, may you just don't have enough"

If, on the other hand, you have a ship that has both warp parts and chemical engines, then maybe the warp engines shouldn't be in the same stage as chemical engines. (I'd advise to avoid that in any case.)

Link to comment
Share on other sites

  • 1 month later...
On 6/16/2021 at 8:33 PM, JadeOfMaar said:

If you're hoping to get a dV reading with warp engines, you've got a wrong idea about what you need to know about warp engines.

dV is not a thing here. What you need to know are to simply:

  • Have plenty Graviolium to spare
  • Have enough warp capacity and enough warp core (with extra gravitic generators if needed) that your ship can go faster. The less massive your ship, the more efficient your warp drive is, and the faster you can boldly go.

Once you fly a long trip or two with a warp ship, you get a feel for the fuel consumption. After that, it's only a matter of "If you're worried about fuel, may you just don't have enough"

If, on the other hand, you have a ship that has both warp parts and chemical engines, then maybe the warp engines shouldn't be in the same stage as chemical engines. (I'd advise to avoid that in any case.)

Thank you, I've tried to make a ship with warp engines for interstellar travel and FFT engines for in-system travel

Link to comment
Share on other sites

Is this Mod compatible with all the Nertea-Mods (like Near Future, Far Future, System heat, Heat Control etc.?)

 

What are dependencies?

Link to comment
Share on other sites

I use Nerteas mods alongside Blueshift, they don't really influence eachother.

For me, Blueshift = long transport, Nerteas stuff= what you do when you arrive:D

No hard dependencies iirc.

Link to comment
Share on other sites

Hi, sorry to ask about something that has been touched on before on this thread, but I'm an idiot and can't figure some things out to do with mining graviolium.

Firstly, how do you know whether an asteroid contains graviolium? The narrow band scanner can happily scan a body I'm orbiting, but it doesn't work for objects without an SOI as far as I can tell, and the surface scanner doesn't scan for graviolium.

Secondly, how do you actually mine graviolium once you've found it? I landed a small test probe on Dres after finding a spot with a small amount of graviolium using the narrow band scanner, but the drill-o-matic doesn't seem to mine the graviolium - it's perfectly content mining the rest of the the ClassicStockResources resources like Hexagen and Rock, but no graviolium. I do have a graviolium tank on the probe, so I don't think it's a matter of there being nowhere to store the graviolium.

Thanks :)

Link to comment
Share on other sites

4 hours ago, Deutschlan_d said:

Hi, sorry to ask about something that has been touched on before on this thread, but I'm an idiot and can't figure some things out to do with mining graviolium.

Firstly, how do you know whether an asteroid contains graviolium? The narrow band scanner can happily scan a body I'm orbiting, but it doesn't work for objects without an SOI as far as I can tell, and the surface scanner doesn't scan for graviolium.

Secondly, how do you actually mine graviolium once you've found it? I landed a small test probe on Dres after finding a spot with a small amount of graviolium using the narrow band scanner, but the drill-o-matic doesn't seem to mine the graviolium - it's perfectly content mining the rest of the the ClassicStockResources resources like Hexagen and Rock, but no graviolium. I do have a graviolium tank on the probe, so I don't think it's a matter of there being nowhere to store the graviolium.

Thanks :)

It sounds like the patch for Blueshift's graviolium isn't installed. Do you have a definition for graviolium? Do you have Kerbal Flying Saucers installed?

Link to comment
Share on other sites

29 minutes ago, Angel-125 said:

It sounds like the patch for Blueshift's graviolium isn't installed. Do you have a definition for graviolium? Do you have Kerbal Flying Saucers installed?

I don't have KFS installed, no. Is it a dependency?

I'm unsure what you mean by 'definition for graviolium', sorry! The resource does indeed exist in my instance of the game, if that's what you're asking.

Thanks for your fast reply, I'll try to supply any more information you need :)

 

Link to comment
Share on other sites

7 hours ago, Deutschlan_d said:

I don't have KFS installed, no. Is it a dependency?

I'm unsure what you mean by 'definition for graviolium', sorry! The resource does indeed exist in my instance of the game, if that's what you're asking.

Thanks for your fast reply, I'll try to supply any more information you need :)

 

The stock surface scanning module will tell you what resources the asteroid has. Have you tried that? It should tell you if the asteroid has Graviolium. To mine it, just use the stock drills, and make sure to have graviolium tanks on your ship.

Link to comment
Share on other sites

14 hours ago, Angel-125 said:

The stock surface scanning module will tell you what resources the asteroid has. Have you tried that? It should tell you if the asteroid has Graviolium. To mine it, just use the stock drills, and make sure to have graviolium tanks on your ship.

That's interesting - in my game, the stock surface scanner doesn't work for graviolium (even in areas I know contain graviolium because the other scanners confirm it). It works for other resources like Hexagen on both asteroids and planets, but in my game it seems only the narrow-band scanner and survey scanner can actually scan for graviolium:

https://imgur.com/a/kiQLvQv

The stock drills don't seem to play nice with graviolium either - they won't mine it even if the narrow band says there should be graviolium below me. I have noticed all the areas I've found that contain graviolium on Dres have very low concentrations of the resource - does the concentration have to exceed a certain value to be mineable?

Link to comment
Share on other sites

12 minutes ago, Deutschlan_d said:

That's interesting - in my game, the stock surface scanner doesn't work for graviolium (even in areas I know contain graviolium because the other scanners confirm it). It works for other resources like Hexagen on both asteroids and planets, but in my game it seems only the narrow-band scanner and survey scanner can actually scan for graviolium:

https://imgur.com/a/kiQLvQv

The stock drills don't seem to play nice with graviolium either - they won't mine it even if the narrow band says there should be graviolium below me. I have noticed all the areas I've found that contain graviolium on Dres have very low concentrations of the resource - does the concentration have to exceed a certain value to be mineable?

The small stock drill does have limits on what it can drill. Below that limit it won't pick anything up. The surface scanner is bizzare; in my game it shows up. My career game, for instance, shows that the asteroid has 27% graviolium. Have you tried the big stock drill?

Link to comment
Share on other sites

10 minutes ago, Angel-125 said:

The small stock drill does have limits on what it can drill. Below that limit it won't pick anything up. The surface scanner is bizzare; in my game it shows up. My career game, for instance, shows that the asteroid has 27% graviolium. Have you tried the big stock drill?

Just tried it with the bigger drill, still nothing unfortunately

https://imgur.com/a/zVBZrkK

I'll try again with an asteroid to see what happens

Link to comment
Share on other sites

18 hours ago, Deutschlan_d said:

Just tried it with the bigger drill, still nothing unfortunately

https://imgur.com/a/zVBZrkK

I'll try again with an asteroid to see what happens

Aaaaand no change :/

@Angel-125If you have time would you be able to send a screenshot of your GameData and GameData\WildBlueIndustries folders for your career save? I wonder if there's a mod I'm missing which for some reason is required for the surface scanner and drill to actually work with graviolium. I don't, for example, have Buffalo installed, whereas I'm guessing you probably do.

Thanks for all your suggestions on this btw :)

Link to comment
Share on other sites

On 8/1/2021 at 5:57 AM, Deutschlan_d said:

Aaaaand no change :/

@Angel-125If you have time would you be able to send a screenshot of your GameData and GameData\WildBlueIndustries folders for your career save? I wonder if there's a mod I'm missing which for some reason is required for the surface scanner and drill to actually work with graviolium. I don't, for example, have Buffalo installed, whereas I'm guessing you probably do.

Thanks for all your suggestions on this btw :)

Out of curiosity, what happens if you install Kerbal Flying Saucers? Are you still unable to drill for graviolium?

https://github.com/Angel-125/FlyingSaucers/releases/tag/v0.4.12

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...