DMagic

[1.8.x] DMagic Orbital Science: New Science Parts [v1.4.3] [11/2/2019]

Recommended Posts

Universal Storage 2 is out now. The Universal Storage science parts from DMagic Orbital Science do not support this version yet. All other science parts are unaffected.

Only the original version of US is supported.

New versions of all of the US parts from this mod will be needed to support the new version of Universal Storage.

Edited by DMagic

Share this post


Link to post
Share on other sites
22 minutes ago, DMagic said:

Universal Storage 2 is out now. DMagic Orbital Science does not support this version yet.

Only the original version of US is supported.

New versions of all of the US parts from this mod will be needed to support the new version of Universal Storage.

Even though things aren't all hooked up/converted/updated yet -- I'm still pretty excited to hear that news!

Orbital Science is a must-have in my game ecosystem, and I've loved the integration with US thus far.

Share this post


Link to post
Share on other sites
1 hour ago, DMagic said:

Universal Storage 2 is out now. DMagic Orbital Science does not support this version yet.

Two things I took from this: 1) US2 is out, and 2) '...yet'.

Thanks, DMagic.  Just out of curiosity, who did do the US - Orbital Science work?

Share this post


Link to post
Share on other sites
7 hours ago, DMagic said:

Universal Storage 2 is out now. DMagic Orbital Science does not support this version yet.

There's no problem with using the regular (non-US) Orbital Science parts alongside having US2 installed, right?

Share this post


Link to post
Share on other sites

@Wyzard That's fine, there is no interaction.

@Brigadier All of the US science parts are mine (you can tell by the generally mediocre quality :D), they just take the outer science bay section of the part from the empty US science bay wedge (the two part models get combined during loading). By themselves the US science parts would just sort of float in space and have hollow backs.

Share this post


Link to post
Share on other sites

I believe the oversized and undersized expandable relay dishes are from this mod, right?  They don't appear to be getting any connection despite being 1T and 10T while staring directly at my station only like 1M away.  Are they just not working right now?

Share this post


Link to post
Share on other sites

I could have sworn it used to be possible to actually use that small optical telescope and zoom in on things... or am I thinking of a different mod?

Share this post


Link to post
Share on other sites
2 hours ago, MR L A said:

I could have sworn it used to be possible to actually use that small optical telescope and zoom in on things... or am I thinking of a different mod?

Yes, you are thinking of a different mod. Either Tarsier Space Technologies, or CactEye Telescopes.

Share this post


Link to post
Share on other sites

@DMagic I wait impatiently to get those parts compatibility with US2 as they're quite useful to me.

I tried, out of curiosity, and they do not work as they get detected as not being in space? And without shells as you described.

And I didn't want to add both US and US2 on my install ;) So going back to US for now!

Share this post


Link to post
Share on other sites
On 8/14/2018 at 8:23 PM, Phraxas said:

I believe the oversized and undersized expandable relay dishes are from this mod, right?  They don't appear to be getting any connection despite being 1T and 10T while staring directly at my station only like 1M away.  Are they just not working right now?

They work fine for me. If they are still causing you problems you will need to provide much more detail: log files, mod version, KSP version, other mods related to CommNet, etc...

 

On 8/20/2018 at 8:33 AM, FrancoisH said:

I tried, out of curiosity, and they do not work as they get detected as not being in space? And without shells as you described.

Yep, they don't work with US 2, which is why I said they don't work a few posts up.

Share this post


Link to post
Share on other sites

Is there a spreadsheet for what experiments work where? its a bit overwhelming XD

Share this post


Link to post
Share on other sites
16 minutes ago, Kepler68 said:

Is there a spreadsheet for what experiments work where? its a bit overwhelming XD

Check the in-game KSPedia entries under DMagic Orbital Science > Experimental Conditions.

Edited by Brigadier

Share this post


Link to post
Share on other sites

I'm having an issue with the new parts for US II.  When they're put into one of the bay service cores, some of them you can no longer click on.  Specifically the Solar Particle Collector, ASERT, Accelerometer/Gravmax, RPWS antenna, PresMat/2Hot.  All the other parts I can select fine.  If I mouse over any of these parts, it just highlights the core instead.  Clicking acts as if I'm trying to click on the core, as if the part wasn't there.

Doesn't seem to matter which core they're on (4,6,8).  Doesn't matter if there's a fairing or not.

Happens in editor and in flight.  I can't even click on them to set action groups.

Not a mod conflict, I removed everything except US II and Orbital Science, same thing.

Is this something on your end, or do I need to bring it to the US II thread?

Share this post


Link to post
Share on other sites
11 minutes ago, Fr8monkey said:

US II is going to have the science to fit those parts.  I don't think the original ones are compatable.

I think I may have mis-read or misunderstood how the interaction happened.  I think I get it now!  Disregard earlier post.

Share this post


Link to post
Share on other sites

Hello, here is a log file for you: https://www.dropbox.com/s/5sdzcbltobydaoj/saves for LoadingScreenManager.1.output_log.rar?dl=0

Inside is this:

Spoiler

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USASERT/USASERT/dmUSAsert'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USGoo/dmUSGoo'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGooMat/USMat/dmUSMat'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USGoreSat/USGoreSat/dmUSGoreSat'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USImagingPlatform/USImagingPlatform/dmUSImagingPlatform'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/MagBoom/dmUSMagBoom'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USProbeSci/RPWS/USRPWS'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USScope/USScope/dmUSScope'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USSoilMoisture/USSoilMoisture/dmUSSoilMoisture'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USSolarParticles/USSolarParticles/dmUSSolarParticles'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/ACCGRAV/dmUSAccGrav'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/ATMOSSENSE/dmUSAtmosSense'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartLoader: Compiling Part 'DMagicOrbitalScience/UniversalStorage/USStock/PRESTEMP/dmUSPresTemp'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

PartCompiler: Cannot clone model 'UniversalStorage/Parts/US_1M110_Wedge_ScienceBay/model' as model does not exist

As many are becoming aware I am posting a lot today. The whole point in to try and clean up that bane called the log file. Or rather to remove stuff from within it. Stuff that may be indeed harmless. But stuff that everyone gets to see any time they have to wade through the log in pursuit of an issue.

So here I am asking if you can help out too. Oh the flip side, this may well be something that does actually have some tangible impact. Who knows, not me for sure. Thanks.

Share this post


Link to post
Share on other sites

Hello,

Maybe U are allready tired by answering those questions, But while I LOVE your mod (I don't imagine play without it), I have installed als US II. AND US I just for parts. can U estimate when U will release update with included US II parts?

Share this post


Link to post
Share on other sites

Hmm, interesting, I really didn't consider that the max. altitude for magnetometers is still 60km / 120km when RSS is installed ...

Share this post


Link to post
Share on other sites

For convenience:
(is this cheating??)

GameData\zFinal\zzz_FixMaxAbundanceAltitude.cfg

@PART[*]:HAS[@MODULE[ModuleResourceScanner]:HAS[#MaxAbundanceAltitude[>0]]]:NEEDS[!SigmaDimensions,RealSolarSystem]:FINAL
{
	@MODULE[ModuleResourceScanner]
	{
		@MaxAbundanceAltitude *= 10.618333333333336685187222222223
	}
}

@PART[*]:HAS[@MODULE[ModuleResourceScanner]:HAS[#MaxAbundanceAltitude[>0]]]:NEEDS[SigmaDimensions,!RealSolarSystem]:FINAL
{
	@MODULE[ModuleResourceScanner]
	{
		systemScale = #$@SigmaDimensions/Resize$
		@MaxAbundanceAltitude *= #$systemScale$
		!systemScale = delete
	}
}

and yes, I know that gas spectrometers and surface scanners are also affected.

Share this post


Link to post
Share on other sites

I have a few missions in flight pretty much built around the Universal Storage experiments - of course mated to a US2 core. :( Is there any way to "hot-fix" the mod to allow the experiments to run? I'm willing to do the leg-work, but I'll probably need a few pointers where to look - I'm completely new to KSP modding. Would it be enough to remove the "USScience = true" from the part config (and maybe remove the parent reference to the science wedge)?

Share this post


Link to post
Share on other sites

For the record - that actually (sort of) worked. I removed the "USScience=true", the bay animation reference, the science wedge model block and the model parent reference. Then I removed the MM patch and manually set the TechRequired and category (although I probably could just have fixed the NEEDS name).

For example, this is the Mag Boom config:

PART
{
name = dmUSMagBoom
module = Part
author = DMagic

MODEL
{
	model = DMagicOrbitalScience/UniversalStorage/USProbeSci/modelMAG
	position = 0.0, 0.0, 0.0
	scale = 1.0, 1.0, 1.0
	rotation = 0, 180, 0
}
rescaleFactor = 1.0

node_stack_back = 0.187, 0.0, 0.0, 1.0, 0.0, 0.0, 0
attachRules = 1,0,1,1,0
TechRequired = miniaturization
entryCost = 6500
cost = 2200
category = Science
subcategory = 0
title = Univ. Storage - Magnetometer Boom
manufacturer = DMagic
description = The magnetometer instruments are used to determine the magnitude and direction of planetary magnetic fields. The long boom separates these instruments from any interference caused by magnetic elements in the probe. Use in low to high orbit or on the surface. Not for use during atmospheric flight. Use with New Horizon's Universal Storage system.


// --- standard part parameters ---
mass = 0.05
bulkheadProfiles = wedge
crashTolerance = 10
maxTemp = 2200
emissiveConstant = 0.95
thermalMassModifier = 4.0

tags = experiment research rerun re-run reus re-us redo re-do reset re-set science dmagic dmos universal wedge (mag field asteroid

angularDrag = 1
dragModelType = default

MODULE
	{
		name = ModuleResourceScanner
		MaxAbundanceAltitude = 60000
		RequiresUnlock = True
		ScannerType = 0
		ResourceName = Ore
	}

MODULE
	{
    name = DMModuleScienceAnimate

	animationName = magBoom

	experimentID = magScan

	experimentAnimation = true
	experimentWaitForAnimation = true
	waitForAnimationTime = -1
	keepDeployedMode = 2

	deployingMessage = Close proximity to the craft scrambles the magnetometer's sensors, deploying the scanner now.
	customFailMessage = The magnetometer is not suitable for use during atmospheric flight, try again on the ground or in space.

	animSpeed = 2
	endEventGUIName = Retract Magnetometer
	showEndEvent = false
	startEventGUIName = Deploy Magnetometer
	showStartEvent = false
	toggleEventGUIName = Toggle Magnetometer
	showToggleEvent = true
	showEditorEvents = true

	experimentActionName = Log Magnetometer Data
	resetActionName = Discard Magnetometer Data

	useStaging = False
	useActionGroups = True
	hideUIwhenUnavailable = False
	rerunnable = True

	xmitDataScalar = 1.0

	dataIsCollectable = True
	collectActionName = Take Data
	interactionRange = 1.2
	externalDeploy = True
	usageReqMaskExternal = 8

	asteroidReports = True
	asteroidTypeDependent = True
	}

MODULE
	{
	name = DMMagBoomModule

	runMagnetometer = True
	resourceToUse = ElectricCharge
	resourceCost = 0.05
	}
}

With these changes, most experiments functioned again.I just can't get the 2HOT/PresMat experiment to work, no idea why.

Edited by karstux

Share this post


Link to post
Share on other sites
On 9/15/2018 at 9:17 PM, Geonovast said:

I'm having an issue with the new parts for US II.  When they're put into one of the bay service cores, some of them you can no longer click on.  Specifically the Solar Particle Collector, ASERT, Accelerometer/Gravmax, RPWS antenna, PresMat/2Hot.  All the other parts I can select fine.  If I mouse over any of these parts, it just highlights the core instead.  Clicking acts as if I'm trying to click on the core, as if the part wasn't there.

Doesn't seem to matter which core they're on (4,6,8).  Doesn't matter if there's a fairing or not.

Happens in editor and in flight.  I can't even click on them to set action groups.

Not a mod conflict, I removed everything except US II and Orbital Science, same thing.

Is this something on your end, or do I need to bring it to the US II thread?

To inform you that i recovered the same issue with the same parts (Solar Particle Collector, Accelerometer/Gravmax,PresMat/2Hot, other not tested as not unlocked).

Restarting the game or reinstalling the mod changed nothing.

Edited by ndiver

Share this post


Link to post
Share on other sites
3 hours ago, ndiver said:

To inform you that i recovered the same issue with the same parts (Solar Particle Collector, Accelerometer/Gravmax,PresMat/2Hot, other not tested as not unlocked).

Restarting the game or reinstalling the mod changed nothing.

Why would you expect these two mods to be compatible when it's been stated that they are not?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.