Jump to content

What did you do in KSP2 today?


Recommended Posts

I used infinite fuel and electricity on a craft with an ion engine..
It is a pod on top of the largest xenon tank with six more of those radially attatched and a single ion engine. Thrust warp kept stopping every 56km/s due to 'running out of fuel' despite infinite fuel being on...


Link to comment
Share on other sites

So what happened along the way...
First there was the warping issue with infinite fuel and warping under thrust.. I found that just spam clicking the last arrow made it go the fastest...

And then at some point, the altimeter failed and read 0m. at this point if I zoomed out to where the sun's SOI went edge to edge, my ship was barely beyond any of the icons.. but in reality it was between 10-100x the distance of Eeloo.. probably closer or beyond the latter. I continued on for a while until suddenly, slightly further away where it was just... idk.. 1/20th the way out, the engine stopped working, I went to ship view and found it vibrating from what I could only assume was floating point errors... so I coasted the rest of the 130 years out to the edge.. when I crossed the edge (shown in the video), an immense amount of lag hit, the orbit line glitched out, and the floating point errors suddenly became SO BAD, that it warped my craft... oh and also Tim cant EVA despite it being at 1x timewarp..

I have a feeling that I wasnt supposed to do this, but it is pretty neat finally being free from Kerbol's SOI, despite having no way of moving (engine long stopped producing thrust). On the top left, it looks like my craft is entirely independant of anything and is just... floating in the world

Oh and also, before exiting the SOI, the floating point errors were ONLY at 1x timewarp... now outside of Kerbol's SOI, it has spread to all warp rates

Edit: NVM timewarp straight up doesnt work...
Neither does throttle, SAS, manuvering, EVA, or... really anything a craft can do...

Edited by JcoolTheShipbuilder
Link to comment
Share on other sites

So yea....

I used an ion craft with a mk1 "explorer" pod connected to 7 xenon tanks and an ion engine along with infinite fuel and electricity. the reason I went with this setup is that thrust warp was that it kept stopping me due to low fuel when most of the stage delta V was used up.. still does it with inf fuel and electricity for some reason.. this setup allowed 50km/s increments.. I had throttle all the way and spam clicked the max timewarp button. A bunch of glitches occures before hitting the edge.. and they all happened looong before the 1/10th mark of the journey.. first was the altimeter failing and reading 0m, and then floating point errors caused the engine to not physically push the craft anymore so I had to drift for 132 years.. also the floating point errors were ONLY present at 1x timewarp in craft view while in Kerbol's SOI

Yea literally nothing works now, everything has stopped working except for the game and maybe the velocity or something... its still running and didnt crash.. 
yea... the craft got warped, and the throttle, timewarp, SAS, movement, pretty much anything (including EVAing) just does not work beyond Kerbol's SOI..

I have a feeling that I wasnt supposed to do this before the interstellar updates lol...

Has anybody else left Kerbol's SOI?

Edited by JcoolTheShipbuilder
Link to comment
Share on other sites

I did what I said I was going to do on launch when they announced early access. I bought it, played it for a bit over an hour, found the amount of broken things and terrible performance wasn't acceptable nor worth the $50 asking price, and refunded it through Steam.

I was expecting it to be on the rough side of things when they announced it as EA after nearly three years of delays which had the tone of finishing / polishing a feature complete game; this launch however is worse than I expected even with my lowered expectations. Very disappointing.

Link to comment
Share on other sites

I played it and I enjoyed it. I flew my minimal Delta-V design (8.6 tonne, 3328 m/s two stage rocket) and reached a 80 km ,x 110 km LKO with 200 m/s to spare. Seems I can still fly after years away from KSP. My kids and I will bring my Kerbal "John Glenn" home to Kerbin tomorrow some time.  

Link to comment
Share on other sites

Put a satellite network into orbit between the Mun and Minmus with a great deal of trial and error. Crashed an Ion probe into the Mun testing out the acceleration under time-warp (it's wonderful). Rebuilt a few of my better plane designs from ksp 1 with the lovely procedural wings and paint and flew, enjoying how pretty Kerbin is. Also picked out a number of things that tend to repeatedly cause bugs (at least in my save). Weirdly, a large number of those revolved around the tracking station, which I've just elected to not use for the foreseeable future. Overall I rather enjoyed my time with it today, though it wasn't without hiccups.

Link to comment
Share on other sites

I flew my first rocket, staged at the wrong time, recovered the capsule, tried again with more boosters, went to the Mun with it, but a heat shield had snuck under the upper stage engine so I couldn't use it, reverted to VAB and fixed that, then flew the rocket again, happened to spot a Mun arch from orbit and successfully landed beside it. Bob returned to Kerbin safely after exploring the arch!

Then I flew a plane around the KSC, buzzed a few structures, then crashed it in the ocean after trying to see how fast I could dive. Valentina bailed out at the last moment and survived unscathed!

Link to comment
Share on other sites

Built an oversized multi-stage lander to the mun, had trouble landing because when the legs extended (THE NEW LARGE LEGS!!!) it would throw the ship into an uncontrollable tumble unless I time warped while the legs where extending (which just reduced the tumble to something manageable). Made a successful landing with the LG sized ship, planted a flag and then went back to Kerbin. Almost made it sadly to the ground, but then the capsule just got suck in the air at about 10,000m, but the menu said I could recover the vessel, so that’s what I did. 

Overall, a terribly buggy experience but it was a blast. A lot of the new little changes, sounds, engine exhaust and flame out/on animations and more just made it exciting.  

Link to comment
Share on other sites

I only had an hour or so to try the game last night, so I launched a simple orbiter and left Jeb with it in orbit.

KSP2 doesn’t seem to have much in the way of VAB tools to estimate your dv at different altitudes, so I ended up wildly overestimating what I needed to get to orbit, so now I’m pondering whether to take my simple orbiter to Duna or something tonight.

Loving the game so far. I was pleasantly surprised that it runs smoothly on my old laptop with specs well below minimum. (Haven’t tried launching anything really large yet though). Haven’t encountered any bugs yet. The UI is going to take a little getting used to. Great first session overall.

Edited by Sp1f
Link to comment
Share on other sites

My first few flights in KSP 2 have been broadly positive. Not without the occasional glitch, but mostly usable:

  • Got a simple 2 stage probe into orbit around Kerbin and back again
  • Took 3 Kerbals to Minmus, planted a flag, and returned almost* safely
  • Briefly tried to drive a rover around the runway

*The Minmus return vessel had a 3-kerbal pod, which apparently doesn't slow much below 50m/s with the single parachute I had fitted. Oops!

Positives I've seen compared to good old vanilla KSP1:

  • Graphically flying over terrain is amazing, far more like a planet and less like a blocky ball. Kerbin and Minmus both have had incredible surface, terrain, biome and lighting updates. Also clouds :cool:
  • A lot of the basic mechanics worked roughly as hoped - staging, launching, SAS for directions, accel/decel to change orbits, etc so for me at least the game was playable
  • Putting spaceships into orbit and landing them places is still fun
  • Map SOI enter/leave graphics are a nice touch

Some of the glitches, oddities and Early-Access behaviours I've seen:

  • Structural booster fixings/decouplers not playing nicely after launch leading to explosions - not sure whether this is  game behaviour or if I just need to rethink some "standard" designs I've used for KSP1 in the new game
  • Odd EVA jetpack behaviour where after turning on & off jetpacks on EVA and switching between a few kerbals their packs wouldn't reignite - thankfully jumping on Minmus works
  • Had a couple of debris parts in the Tracking centre that I seem unable to delete
  • Orbits after a change in SOI don't appear to always predict correctly - while returning from Minmus the path prediction suggested I was going to leave Kerbin's SOI until I had left Minmus' SOI
  • I haven't found the thrust-to-weight ratio indicators for VAB design of stages yet and I miss them!

The game is definitely Early Access, but also has a lot of the positives about it that made KSP one such a success.



Link to comment
Share on other sites

I tried to launch an asparagus staged rocket and the game turned into slide show because of the shoddy fuel flow optimization. I guess I'll have to wait for a couple more patches before I return.

6 hours ago, silent_prtoagonist said:

Built an ion probe to try out the new persistent thrust, and since it's the only new planet added so far in KSP 2 I decided to fly it out to Dres. The rings and equatorial ridge were awesome! This new planet seems really interesting and not boring at all.

Wait, what Dres? I haven't found any Dres in KSP2 either.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...