politas

CKAN (The Comprehensive Kerbal Archive Network); v1.27.2 - Chandrasekhar

Recommended Posts

I've been away from KSP and cKan for a while, now there is a new column "Auto Installed" I can't find any info about it, can someone please explain what its for? I can tick boxes but what does that do?

7pEsnRs.png

Share this post


Link to post
Share on other sites

@kizza42
When a mod is installed because it is needed by another mod, that column will become checked.  When that other mod is removed, the dependencies are removed (if not needed forma different one).  By unchecking that, you can remove it from being a dependency and it will remain on its own

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

I'm experiencing difficulties with CKAN. Every few mods it tosses me a 403 (Forbidden). This goes on random mods of my 1.4.5 install (it did MechJeb2 once, is doing KAS multiple times, has done the GPP Textures once). It makes installation long and painful for those things that need installing via a backup site, and for those that don't have a backup, it cancels the installation.

I'm gonna install those things manually. I just wanted to let you know these mods were being difficult in 1.4.5 installs.

Share this post


Link to post
Share on other sites
8 minutes ago, LittleBitMore said:

I'm experiencing difficulties with CKAN. Every few mods it tosses me a 403 (Forbidden). This goes on random mods of my 1.4.5 install (it did MechJeb2 once, is doing KAS multiple times, has done the GPP Textures once). It makes installation long and painful for those things that need installing via a backup site, and for those that don't have a backup, it cancels the installation.

I'm gonna install those things manually. I just wanted to let you know these mods were being difficult in 1.4.5 installs.

Sounds like #2210. GitHub doesn't like it when you download many things in parallel. Usually you can just retry the same changes and it will work eventually.

Share this post


Link to post
Share on other sites
2 minutes ago, HebaruSan said:

Sounds like #2210. GitHub doesn't like it when you download many things in parallel. Usually you can just retry the same changes and it will work eventually.

I've looked over the bug page and the details on it. I'll try this with installing each of the troublesome mods individually. Thanks for the insight!

Edit: KAS is still not installing, no matter how many times I spam retry. I'll instead install it manually.

Edited by LittleBitMore
Added "edit"

Share this post


Link to post
Share on other sites

just popping in to say nicely done on the DaMichel's mods.

+1 :rep:

more mods coming.

Share this post


Link to post
Share on other sites
2 hours ago, Wuwuk said:

Why in ckan does not have version 1.0.1 for KSP 1.7.x of the DE_IVA Extension - For All the Stock Pod IVAs! mod?

There is only version 1.0.2.

Just added it, try Refreshing in a couple of minutes. Note that you'll need to add KSP 1.6 as a compatible version manually because RPM v0.30.6 isn't supported on KSP 1.7 by its author.

https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions

Share this post


Link to post
Share on other sites

There has been some time since I used CKAN and I am unsure on how the versions and updates are working now.

One place I red that the majority of mods will automatically be compatible to new versions of KSP, but experience tells me otherwise.

How is it now. Should I just set the setting fpr compatible version in CKAN to 1.8.0 and go ahead download whaterver mods I prefer... or should I still wait for the metadata to be up to date?

Share this post


Link to post
Share on other sites
17 minutes ago, EasyAce said:

One place I red that the majority of mods will automatically be compatible to new versions of KSP, but experience tells me otherwise.

This differs from update to update. A lot of mods broke from KSP 1.7 to 1.8 because of a Unity update and thus the old DLLs didn't work anymore.
KSP 1.8 to KSP 1.9 only broke a few visual mods, most others are working fine.

20 minutes ago, EasyAce said:

Should I just set the setting fpr compatible version in CKAN to 1.8.0 and go ahead download whaterver mods I prefer... or should I still wait for the metadata to be up to date?

I'd suggest to take a quick look at the last page of the forum thread for each mod you want to install that isn't shown as 1.9 compatible yet. You'll likely find either the author stating something about the compatibility, and/or others who tried it out.

Additionally, if install the mods in small groups and start + test KSP in between, it'll be easier to catch possibly malfunctioning mods.

Share this post


Link to post
Share on other sites

I just tried to run CKAN to see if any mods had been updated and got an "unhandled exception" error stating "InvalidArgument=Value of "2" is not valid for "index"".  It worked fine this morning when it installed Mechjeb2 into a clean new KSP v1.9 install.  Since then I manually installed KAS/KIS which seems to not cause any issues. 

I deleted CKAN then DLed and installed it again with the same result.   I'm guessing it is something on my end causing this.  Any idea what it might be?

Share this post


Link to post
Share on other sites
On 2/20/2020 at 2:28 AM, HebaruSan said:

Just added it, try Refreshing in a couple of minutes. Note that you'll need to add KSP 1.6 as a compatible version manually because RPM v0.30.6 isn't supported on KSP 1.7 by its author.

https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions

I understand ,thank you.

Edited by Wuwuk

Share this post


Link to post
Share on other sites

Clean 1.9 install, trying to install mods from a ckan mod file. Worked previously with the exact same mods and game version. Getting this error:

Spoiler

Unhandled exception (etc.).
InvalidArgument=Value of '2' is not valid for "index".
Parameter name: index.

************** Exception Text **************
System.ArgumentOutOfRangeException: InvalidArgument=Value of '2' is not valid for 'index'.
Parameter name: index
   at System.Windows.Forms.TabControl.GetTabPage(Int32 index)
   at System.Windows.Forms.TabControl.TabPageCollection.get_Item(Int32 index)
   at CKAN.ThemedTabControl.OnDrawItem(DrawItemEventArgs e)
   at System.Windows.Forms.TabControl.WmReflectDrawItem(Message& m)
   at System.Windows.Forms.TabControl.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

 

Share this post


Link to post
Share on other sites

Hi guys, I'm trying to build CKAN from source and when I open the solution in my Visual Studio, it just hangs on opening ckan-core. Any solutions?

Share this post


Link to post
Share on other sites
Posted (edited)

Supposedly, an astounding 1.3 billion people can read simplified Chinese. If that group includes you, you're invited to test a translation of CKAN generously submitted by GitHub user 050644zf! Say hello here to receive a test build:

We're interested in anything that:

  • Doesn't make sense
  • Doesn't fit in the available space
  • Could be phrased more clearly
  • Is formatted poorly, etc.

The active CKAN team members do not speak Chinese (as far as I know), so we can't evaluate this translation fairly, and we'd like additional sets of eyes to check it out. Thanks in advance!

Edited by HebaruSan

Share this post


Link to post
Share on other sites
Posted (edited)

@HebaruSan just a quick heads up-ScrapYard OhScrap! just hit SpaceDock - and probably sent a CKAN submission. Would you kindly just update the existing one to point at the new one? I just adopted it from @severedsolo; along with ScrapYard.

Thank you in advance!

Edited by zer0Kerbal

Share this post


Link to post
Share on other sites
36 minutes ago, zer0Kerbal said:

@HebaruSan just a quick heads up-ScrapYard just hit SpaceDock - and probably sent a CKAN submission. Would you kindly just update the existing one to point at the new one? I just adopted it from @severedsolo; along with ScrapYard.

Thank you in advance!

You shouldn't need to worry about that, the nice thing about space Dock is that it allows you to just keep pushing releases with no changes to CKAN needed.

Share this post


Link to post
Share on other sites
32 minutes ago, severedsolo said:

You shouldn't need to worry about that, the nice thing about space Dock is that it allows you to just keep pushing releases with no changes to CKAN needed.

oops - meant OhScrap!

Share this post


Link to post
Share on other sites

@HebaruSan could you please update the license of my mod Intake Air-Drain it! To GPLv3.0 ? It is currently having the MIT license

Share this post


Link to post
Share on other sites
7 hours ago, VoidCosmos said:

@HebaruSan could you please update the license of my mod Intake Air-Drain it! To GPLv3.0 ? It is currently having the MIT license

Done.

Share this post


Link to post
Share on other sites
22 minutes ago, HebaruSan said:

Done.

Thanks a lot!

Share this post


Link to post
Share on other sites

https://www.githubstatus.com/ says that GitHub is having some problems right now, which will probably have a big impact on CKAN. Watch that page for the current status, consider waiting to use CKAN, and wish our friends on the GitHub server teams the best as they work on whatever it is.

Share this post


Link to post
Share on other sites
Posted (edited)

@HebaruSan - query:

what can be improved on my end to help ease your efforts? how can improve readme? etc?

Edited by zer0Kerbal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.