linuxgurugamer

[1.5.1, 1.6.1, 1.7.2] Flight Manager for Reusable Stages (FMRS), now with RecoveryController integration

Recommended Posts

54 minutes ago, damonvv said:

The time between staging and FMRS saving both crafts.

OqUsbxr.png

For me it does not seem to save after reloading KSP/launching another craft.

I would have to check, but I'm not sure that is saved.

Share this post


Link to post
Share on other sites
1 hour ago, Kroslev Kerman said:

does it work for 1.4.5?

Yes, except for the occasional loss of contracts when reverting to launch... But that's not specific to 1.4.5. Just save before every mission and you're fine ;)

Share this post


Link to post
Share on other sites
On 10/11/2018 at 8:40 PM, linuxgurugamer said:

I would have to check, but I'm not sure that is saved.

Seems like it resets after a new KSP launch. If you can, maybe have a config that we can change the delay?

Share this post


Link to post
Share on other sites
35 minutes ago, damonvv said:

Seems like it resets after a new KSP launch. If you can, maybe have a config that we can change the delay?

Put in an issue on Github, please. I'm busy with mod updates right now

Share this post


Link to post
Share on other sites

I just noticed something weird: I made a Falcon Heavy, including probe cores for the side boosters. But FMRS failed to save them. The core booster instead got saved just fine. I tried this repeatedly, with the same result. Once I crashed something on decoupling, and FMRS saved the parts that  fell off. What the heck? I should note that the side boosters were subassemblies, with the tank as the root part. I only added the probe cores after adding the boosters to the central stage, so technically, after the separation, the probe core again was not the root part. Could that be the problem?

Share this post


Link to post
Share on other sites
11 minutes ago, infinite_monkey said:

I just noticed something weird: I made a Falcon Heavy, including probe cores for the side boosters. But FMRS failed to save them. The core booster instead got saved just fine. I tried this repeatedly, with the same result. Once I crashed something on decoupling, and FMRS saved the parts that  fell off. What the heck? I should note that the side boosters were subassemblies, with the tank as the root part. I only added the probe cores after adding the boosters to the central stage, so technically, after the separation, the probe core again was not the root part. Could that be the problem?

Yes, your satellite needs to be the root part. I have to put a sample sat inside the fairing so that a probe is always the root of the rocket and not the 2nd stage or something.

Share this post


Link to post
Share on other sites

Help me, I was playing KSP and I notice something, when I load in I can’t see the FMRS window. So I close, check myself, and FMRS folder was completely normal, and no compatible warnings from the game.

So what happened?

Share this post


Link to post
Share on other sites
3 hours ago, TM31D2475 said:

Help me, I was playing KSP and I notice something, when I load in I can’t see the FMRS window. So I close, check myself, and FMRS folder was completely normal, and no compatible warnings from the game.

So what happened?

I have no idea, how about a log file?

Share this post


Link to post
Share on other sites

Hello.

So I use both Stage recovery and FMRS and have been for a long time, and they worked together quite nicely, as such I appreciate all you hardwork with the updates

Today though i had a weird issue where i could not change which recovery mod was in charge of my stages.

I right click on my decouplers but the Recovery Owner button which normally changes the controlling mod is stuck on FMRS, no matter how many times i click it it does not change (not even to off or auto). I tried reinstalling both but the problem persists.

I'd appreciate  if you could take a look.

My log file is here:  https://drive.google.com/open?id=1S0WV1EZdqSSVIMq5n3AAKH7H69ZuTNSq

Thanks in advance.

Share this post


Link to post
Share on other sites
On 12/10/2018 at 11:08 PM, linuxgurugamer said:

I have no idea, how about a log file?

OK, so I have to reinstall FMRS and uninstall some mods and reinstall them back and now it worked
So yeah

Share this post


Link to post
Share on other sites
On 12/10/2018 at 7:51 PM, Shizen said:

Hello.

So I use both Stage recovery and FMRS and have been for a long time, and they worked together quite nicely, as such I appreciate all you hardwork with the updates

Today though i had a weird issue where i could not change which recovery mod was in charge of my stages.

I right click on my decouplers but the Recovery Owner button which normally changes the controlling mod is stuck on FMRS, no matter how many times i click it it does not change (not even to off or auto). I tried reinstalling both but the problem persists.

I'd appreciate  if you could take a look.

My log file is here:  https://drive.google.com/open?id=1S0WV1EZdqSSVIMq5n3AAKH7H69ZuTNSq

Thanks in advance.

You have a lot of other errors in the log file, to the point that I can't isolate FMRS from those, it appears most are related to ContractConfigurator

Share this post


Link to post
Share on other sites

Another problem, after I land the booster and clicked "Jump Back to Main Mission", instead of switching back, it just reverts the launch

Share this post


Link to post
Share on other sites

@linuxgurugamer  I originally posted this in the RecoveryController thread, but I guess you didn't see it.

I've got both FMRS and StageRecovery installed via ckan which included the RecoveryController, but I'm only getting the FMRS option.  Nothing changes when I click the recovery owner toggle button.  I went today and put a fresh copy with only FRMS, SR and all of the required mods and nothing else, and it still doesn't switch modes.  Am I missing something I should be doing in the VAB?

Original log is here https://drive.google.com/uc?export=view&id=1K3GzIWYF-cN7eC9oGU-IJA_6OMncpAAK

Share this post


Link to post
Share on other sites
2 hours ago, Critter79606 said:

@linuxgurugamer  I originally posted this in the RecoveryController thread, but I guess you didn't see it.

I've got both FMRS and StageRecovery installed via ckan which included the RecoveryController, but I'm only getting the FMRS option.  Nothing changes when I click the recovery owner toggle button.  I went today and put a fresh copy with only FRMS, SR and all of the required mods and nothing else, and it still doesn't switch modes.  Am I missing something I should be doing in the VAB?

Original log is here https://drive.google.com/uc?export=view&id=1K3GzIWYF-cN7eC9oGU-IJA_6OMncpAAK

I can confirm this.

@linuxgurugamer It looks like Stage Recovery is not registered properly by the recovery controler wrapper. I've looked through the code of Recovery Controller and added an else condition to the 'Awake' method and some log output:

        private void Awake()
        {
            if (registeredMods.Contains("StageRecovery"))
            {
                Debug.Log("StageRoverey is registred as mod");
                GameEvents.onEditorPartPlaced.Add(onEditorPartPlaced);
                GameEvents.onEditorLoad.Add(onEditorLoad);
                GameEvents.onVesselLoaded.Add(onVesselLoaded);
                GameEvents.onVesselCreate.Add(onVesselCreate);
                GameEvents.onVesselWasModified.Add(onVesselWasModified);

                DontDestroyOnLoad(this);
                RegisterMod(AUTO);
                RegisterMod("none");
                DontDestroyOnLoad(this);

            }
            else
            {
                Debug.Log("StageRoverey is NOT registred as mod");
            }
        }

Which results in this KSP.log output:

[LOG 07:06:06.782] [HighLogic]: =========================== Scene Change : From MAINMENU to SPACECENTER (Async) =====================
[LOG 07:06:07.023] [UIMasterController]: HideUI
[LOG 07:06:07.669] [AddonLoader]: Instantiating addon 'CustomConfigsManager' from assembly 'ModuleManager'
[LOG 07:06:07.670] [AddonLoader]: Instantiating addon 'CBTMonitor' from assembly 'ClickThroughBlocker'
[LOG 07:06:07.671] [AddonLoader]: Instantiating addon 'IntroWindowClass' from assembly 'ToolbarController'
[LOG 07:06:07.671] [AddonLoader]: Instantiating addon 'FMRS_Space_Center' from assembly 'SlingShotter'
[LOG 07:06:07.675] windowPos loaded from file
[LOG 07:06:07.678] [AddonLoader]: Instantiating addon 'FMRS_Register' from assembly 'SlingShotter'
[LOG 07:06:07.679] [AddonLoader]: Instantiating addon 'RecoveryController' from assembly 'RecoveryController'
[LOG 07:06:07.679] StageRoverey is NOT registred as mod
[LOG 07:06:07.679] [AddonLoader]: Instantiating addon 'StageRecovery' from assembly 'StageRecovery'

Is it possible that this issue appears just because the addons are loaded in the wrong order? I'm not quiet sure how to test this, otherwise I would've done it already^^

Full output_log: https://www.dropbox.com/s/iflgalgquh2s6tr/output_log(FMRS%2CSR%2CRC).txt?dl=0

(contains just the FMRS,SR,RC and dependencies)

Oh btw: I noticed that the AssemblyInfo.cs of FMRS contains a wrong entry for the KSPAssembly, it says 'Slingshotter' instead of 'FMRS' ;)

Share this post


Link to post
Share on other sites

@linuxgurugamer I've opened a PR on github for RecoveryController to check the mod registration on each game scene instead of just at the KSC. This will allow at least to switch between FMRS and StageRecovery but not 'none' or 'auto' (at least for me). I fixed that by recompiling StageRecovery as well (wihtout any code changes) and now it's working properly.

Share this post


Link to post
Share on other sites

I could use a little advice on using this.

Despite having it installed for a while, today was my first real time using it.  After watching the tutorial video in the OP, I think I got how it works, however it's not behaving how I'd like it to and I'm hoping there's a way to accomplish my goal.  That said, I do believe it's working as intended, I just may not fully understand what's going on or what I need to do.

I have a Falcon9-ish style rocket.  Two stager to orbit.  All of my staging is being done with action groups (mostly with the help of SmartParts), so I actually have to trigger FMRS with an empty stage before I take off.  I don't think that's an issue, just want it know it's being done.

At 40km the second stage disconnects, and I follow it as it fires its engine.  I get it to orbit, then use the FMRS box to jump back to stage separation.  I do my normal boostback and land back at the KSC.  This is where I have some issues.

I would like to be able to have the save points merged without recovering the booster.  It's my understanding that everything is stitched together when the "Recover Vessel" button is pressed.  However, since I don't want to recover the booster, that leads me with a small issue.

I thought of a way to get around it, but it did not work.  At 500 meters, the interstage, which contains stuff like batteries, RCS tanks, SmartParts controllers, is ejected.  The interstage portion has its own probe core, as does the booster.  I land the booster, then the interstages touches down a few moments later next to the booster with its parachute.  I switch to the interstage and recover that.  It does its thing and focuses back to the second stage in orbit, but both the booster and interstage are missing from the KSC.

What can I do to keep the payload in orbit, and the booster landed?  I don't care about the interstage, it will need to be recovered anyway.  I think the problem is it's not creating another jump back point when the interstage ejects at 500 meters.

Share this post


Link to post
Share on other sites

@Geonovast There is a setting called 'Auto Recover Landed Crafts' which is enabled by default and can be accessed through the difficulty settings in game. Maybe you just need to disable this feature.

If it doesn't help: Where do you land the booster? IIRC, vessels are removed from some KSC buildings as soon as you switch to another vessel which is far away (and I assume your upper stage will be far away ;) ). So maybe try to land on the grass next to the KSC, at least once for testing purposes.

25 minutes ago, Geonovast said:

I think the problem is it's not creating another jump back point when the interstage ejects at 500 meters.

Not quiet sure about this one, I think it is not possible to create a jump back point in another jump back point..that would be jump-ception :confused:

Share this post


Link to post
Share on other sites
Posted (edited)
19 minutes ago, 4x4cheesecake said:

Not quiet sure about this one, I think it is not possible to create a jump back point in another jump back point..that would be jump-ception :confused:

This is likely the issue.

Nothing's being auto-recovered, I have that off.  I keep focus on the second stage at separation, get it to orbit.  Jump back to separation point, land booster.  Booster stays in focus that whole time.

I'd like to be able to get the second stage to orbit and land the booster without every hitting the recover button on the booster.

If, say, at stage separation, a small, third piece was detached.  Maybe just a probe core and a chute.  I fly the payload to orbit, jump back.  Land the booster, jump back, then land that dummy core and recover it, would that work?  I'd still only be creating one jump-back point.

Edited by Geonovast

Share this post


Link to post
Share on other sites
1 hour ago, Geonovast said:

I'd like to be able to get the second stage to orbit and land the booster without every hitting the recover button on the booster.

Uhm, it should be possible just to hit 'jump back to main mission' after landing the booster which will 'stich' the savefiles together so you got the booster on the ground and the second stage in orbit. The second stage need to be the main mission though, so you need to fly the second stage to orbit before you jump back to the booster to land it.

Share this post


Link to post
Share on other sites
56 minutes ago, 4x4cheesecake said:

Uhm, it should be possible just to hit 'jump back to main mission' after landing the booster which will 'stich' the savefiles together so you got the booster on the ground and the second stage in orbit. The second stage need to be the main mission though, so you need to fly the second stage to orbit before you jump back to the booster to land it.

I'd tried that, and it just kicks me back to the payload in orbit and the booster disappears.

Having the dummy probe eject at stage separation, then jumping back after landing the booster and recovering the dummy probe worked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.