Thomas P.

[1.6.1-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

Kopernicus 1.3.1-5 - "The last release literally broke everything - Edition"  Awesome title :)

CKAN isn't giving me that one so i imagine some unnecessary support calls coming your way.

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

Are you saying it failed in 1.3.1-3? Because all I was suggesting was that he return to that version until I updated SVT.

if it was indeed broken, I will need to get an update out ASAP 

I was using 1.3.1-4 which Thomas updated earlier today.

Share this post


Link to post
Share on other sites
5 minutes ago, Tarheel1999 said:

I was using 1.3.1-4 which Thomas updated earlier today.

Oh I know, but I must have read what Thomas said incorrectly. I thought he said me telling you to roll back to 1.3.1-3 was wrong. 

Share this post


Link to post
Share on other sites

so I decided to peek back into the early history of Kopernicus, the history before the first prerelease.

teknoman117, o7.

Screenshot_397.png

Share this post


Link to post
Share on other sites

After sitting through 3 hours of trying to get my KSP working again, pruning my mod list to see if it was a memory error, reinstalling KSP from scratch, etc. I stumbled upon @Tarheel1999's recent post on how 1.3.1-4 broke his game.

 

Even though I had 1.3.1-5 installed, I decided to roll back to 1.3.1-3 and lo and behold KSP starts running again.

 

Here's a link to the lost crash output, along with the Kopernicus Log: https://www.dropbox.com/s/u4b63ik7a6vtcy6/2018-02-11_170822.7z?dl=0

Edited by Spike88

Share this post


Link to post
Share on other sites
1 hour ago, Spike88 said:

After sitting through 3 hours of trying to get my KSP working again, pruning my mod list to see if it was a memory error, reinstalling KSP from scratch, etc. I stumbled upon @Tarheel1999's recent post on how 1.3.1-4 broke his game.

 

Even though I had 1.3.1-5 installed, I decided to roll back to 1.3.1-3 and lo and behold KSP starts running again.

 

Here's a link to the lost crash output, along with the Kopernicus Log: https://www.dropbox.com/s/u4b63ik7a6vtcy6/2018-02-11_170822.7z?dl=0

I can’t look at your logs because I’m on mobile, but what are you trying to run that requires Kopernicus? I don’t think there is anything that has been updated yet to work with it. And some mods, like Sigma’s mods, will cause crashes right now. 

 

Kopernicus us is a tool for planet modders are typically dependent on a particular version of Kopernicus. So, it’s good practice to stay on the last version known to work with that mod until told otherwise. You aren’t missing out on any new features especially if the mod is not updated for the latest Kopernicus anyway.

Edited by Galileo

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

Sigma’s mods, will cause crashes right now. 

except for those I have updated :D

Share this post


Link to post
Share on other sites
3 minutes ago, Sigma88 said:

except for those I have updated :D

I’m driving and can’t be up to date all the time.. h e may have an old version in there..who knows..not me, because I’m on mobile lol :P

It’s my “be helpful, yet unhelpful” approach 

Share this post


Link to post
Share on other sites
8 hours ago, Galileo said:

Even though I had 1.3.1-5 installed, I decided to roll back to 1.3.1-3 and lo and behold KSP starts running again.

Same on me. All custom planets has not loading.

Share this post


Link to post
Share on other sites
8 hours ago, boborene said:

Same on me. All custom planets has not loading.

Then you should report the problem to the developer of the custom planets.  When Kopernicus gets updated it is the job of the planet pack developers to get caught up to the changes in Kopernicus.  If they determine the problem is with Kopernicus, then let them report it.

Share this post


Link to post
Share on other sites

This is what happened to Minmus highlands after the Kopernicus update. I'm considering leaving it as is.

9QaKd04.png

Share this post


Link to post
Share on other sites
19 hours ago, Galileo said:

Kopernicus us is a tool for planet modders are typically dependent on a particular version of Kopernicus. So, it’s good practice to stay on the last version known to work with that mod until told otherwise. You aren’t missing out on any new features especially if the mod is not updated for the latest Kopernicus anyway.

The problem with this logic is that most people don't keep some kind of dependency matrix of their mods. When things go live on CKAN usually I'd just download it and hope for the best. 
In this case it took two days before I figured out what mod was the cause. Not blaming you, but the system might need some improvement, because this is quite often a problem with KSP.

Maybe the CKAN dependency list should include revision numbers so that CKAN can warn about incompatible versions? Well, I assume you are not the developer of it anyway, just throwing it out there.

Share this post


Link to post
Share on other sites
10 minutes ago, Katten said:

Maybe the CKAN dependency list should include revision numbers so that CKAN can warn about incompatible versions?

CKAN dependencies can already be version-specific, but existing planet packs aren't set up that way, possibly because their authors don't want to deal with the extra maintenance hassle, or possibly because they don't know it's an option. If any planet pack authors would like to try it, please let us know:

https://github.com/KSP-CKAN/NetKAN/issues/new

  • Like 2

Share this post


Link to post
Share on other sites

where are previous versions located? I updated and it broke GPP...I should have known better  :/ 

Share this post


Link to post
Share on other sites
2 hours ago, Tyko said:

where are previous versions located? I updated and it broke GPP...I should have known better  :/ 

The latest GPP needs Kopernicus 1.3.1-5.

1.3.1-3 will not work correctly with GPP 1.6.1.0.

GPP 1.6.0.1 uses Kopernicus 1.3.1-3 and should not be used with 1.3.1-5. 

Be sure you are using the correct versions.

 

Edited by Galileo

Share this post


Link to post
Share on other sites

Ever seen this before?    Foreground is kerbin.  I've not changed or messed with any of my mods that have to do with planets and its been fine for weeks, it was just like this when I launched the game today.  Seems to only be an issue with the map view.  I did drop USI life support and add the IFI life support mod, but i played a good bit since then and didn't notice it.  

gYq8Ig5.png

ksp log https://drive.google.com/open?id=1bHb8xRV2n8Bl1zc7DP_8rOPNBUmuoQIi

output log https://drive.google.com/open?id=1Hig-7DfZEHWTXKB1u77BUS8VvKqFE-Pf

Edited by eberkain
  • Like 1

Share this post


Link to post
Share on other sites

I released 1.3.1-6 on Github, this fixes the issues Minmus had in the previous two versions.

I seriously hope that this is the last hotfix release for 1.3.1-4...

And yes I know that the ModuleManager version Kopernicus ships is outdated. I might want to automate that.

  • Like 2

Share this post


Link to post
Share on other sites

Wow, @Thomas P., thanks for the fix! So ironic (for me, at least) that the first time I experienced the bug was only mere minutes after your fix was uploaded! I'm thankful and glad that I don't have to comb through code. Nicely done!

 

Regards,

Björn

Share this post


Link to post
Share on other sites

Not sure if anyone has had this problem yet, but since updating, the orbits of my planets disappear when I zoom out beyond them. I tried going back to an older version of Kopernicus but it still happened. So if I zoom out to a little past Jool, all of the orbits of the inner planets disappear, and when I zoom out past Urlum in OPM, all of them disappear, even the planets beyond Urlum.

  • Like 1

Share this post


Link to post
Share on other sites
On 11-2-2018 at 2:57 PM, Thomas P. said:

 

  • Made the ring and scatter systems modular, so third parties can add their own components to them. While rings don't have built-in components at the moment, the Scatter colliders and experiments were moved into components. To keep the old behaviour, change collides = true to Components { ScatterColliders { } } and move the contents of the Experiment node to Components { ScatterExperiment { } }
  • Unload Scaled Space textures on scene change
  • Fixed the yellow-stripes bug that occured when trying to load textures from PluginData in OpenGL environments
  • Added an experimental OnDemand setting, that manages memory manually and only stores the channels of the texture that are neccessary instead of the whole texture. (useManualMemoryManagement = true in the Kopernicus node)
  • Added proper OnDemand load management for Biome maps
  • The scatter and landClass nodes from LandControl are now named Scatter and LandClass. The old values still work, but they are deprecated.

 

Can someone make this clear? Sorry if I sound stupid but I have no clue how to fix the KSS cfg's.

Can someone maybe poste an example of the new stuff / changes?

Share this post


Link to post
Share on other sites

excuse me but  something in this mod went HORRIBLY wrong it wont let me load my save game due to something about missing planets or something or something meing corrupted i will try to find what it was and report it to you

Share this post


Link to post
Share on other sites
On 2/14/2018 at 5:41 AM, eberkain said:

Ever seen this before?    Foreground is kerbin.  I've not changed or messed with any of my mods that have to do with planets and its been fine for weeks, it was just like this when I launched the game today.  Seems to only be an issue with the map view.  I did drop USI life support and add the IFI life support mod, but i played a good bit since then and didn't notice it.  

gYq8Ig5.png

ksp log https://drive.google.com/open?id=1bHb8xRV2n8Bl1zc7DP_8rOPNBUmuoQIi

output log https://drive.google.com/open?id=1Hig-7DfZEHWTXKB1u77BUS8VvKqFE-Pf

I was having the same issue! It went away when I uninstalled SigmaBinary, but I couldn't figure out why. I thought that maybe I had a stray config file with a :NEEDS[SigmaBinary] node somewhere, but I couldn't find one.

Edited by theonegalen

Share this post


Link to post
Share on other sites
1 hour ago, theonegalen said:

I was having the same issue! It went away when I uninstalled SigmaBinary, but I couldn't figure out why. I thought that maybe I had a stray config file with a :NEEDS[SigmaBinary] node somewhere, but I couldn't find one.

It's an Easter egg built into Sigma Binary.

  • Like 1

Share this post


Link to post
Share on other sites

Quick question: which are the variables that handle the apparent magnitude and "glow" radius of a star? I'm tweaking the Constellations mod configs so that

a) the stars can't be seen during daytime,

b) their apparent size looks realistic, and

c) the outer "glowing" rim gets smaller.

Will fire up KSP now and take some screenshots, if necessary.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now