linuxgurugamer

[1.4.5, 1.5.1, 1.6.1, 1.7.0] Docking Camera KURS Style Re-Adopted

Recommended Posts

New release, 1.3.6.2

  • Added support for the ClickThroughFix

Share this post


Link to post
Share on other sites
On 8/24/2019 at 11:51 PM, linuxgurugamer said:

New release, 1.3.6.2

  • Added support for the ClickThroughFix

Hi @linuxgurugamer!  Tried this for the first time today.  In my relatively-modded install (~60 mods) it triggered a bizarre issue that made me chuckle:

Kerbals are not visually occluded in the Flight Scene by some (all?) parts (things such as Pods that they literally enter are unaffected).

Steps to reproduce:

1.  Create a hollow cube out of Structural Panels.

2. Place a Command Seat inside the hollow space.

3. Assign a Kerbal to the seat and launch the Vessel.

Expected Result:  Kerbal cannot be seen.

Actual Result: Kerbal is visible 'through' the solid panel walls.

Spooky! :o

To be clear, I've verified that this only happens with the mod installed and goes away as soon as it's uninstalled.

I assume that this isn't something I'm missing in the settings, as the mod's UI doesn't appear to have anything interactive I can fiddle with when this happens.

Let me know if you feel the need for screenshots, list of other mods etc. and I'll see what I can do after work.

Share this post


Link to post
Share on other sites

I've been trying to replicate this.  Can you get to a minimal set of mods to replicate? I dont have time right now, going away for a week. Whatever you can do would be helpful.

Thx

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

I've been trying to replicate this.  Can you get to a minimal set of mods to replicate? I dont have time right now, going away for a week. Whatever you can do would be helpful.

Thx

I'm also away now until Friday night, but I'll do it as soon as I can.  I'll grab logs, screenies and mod lists.

Share this post


Link to post
Share on other sites

I experienced some other graphical weirdnesses that I have *tentatively* pinned on the latest KURS update, since they disappeared when I rolled back to the next-most-recent update.  (Tentative because it wasn't the only mod I was fiddling with at the time and I haven't had a chance to do anything approaching a rigorous test, but it is on my "short list.")  There appeared to me to be some sort of unexpected interaction with Scatterer (my ocean and blue sky went away), and (bizarrely) a "waypoint" symbol was appearing in the center of the screen for my active vessel.  It doesn't make any sense to me that KURS would have anything to do with either one, though.   Odd.  I won't really have time to do any digging till this weekend, but I thought I'd mention it in case the symptoms make any sense to anyone else.

Share this post


Link to post
Share on other sites
7 hours ago, MaxwellsDemon said:

I experienced some other graphical weirdnesses that I have *tentatively* pinned on the latest KURS update, since they disappeared when I rolled back to the next-most-recent update.  (Tentative because it wasn't the only mod I was fiddling with at the time and I haven't had a chance to do anything approaching a rigorous test, but it is on my "short list.")  There appeared to me to be some sort of unexpected interaction with Scatterer (my ocean and blue sky went away), and (bizarrely) a "waypoint" symbol was appearing in the center of the screen for my active vessel.  It doesn't make any sense to me that KURS would have anything to do with either one, though.   Odd.  I won't really have time to do any digging till this weekend, but I thought I'd mention it in case the symptoms make any sense to anyone else.

Did you have any docking ports in physics range at the time?

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Did you have any docking ports in physics range at the time?

For the "waypoint" symbol?   Yes, in both cases.

Share this post


Link to post
Share on other sites

@MaxwellsDemon Sounds extremely similar to the Transfer Window Planner glitch I was experiencing this weekend. Do you have that mod? Did you by any chance update that mod recently? Reverting it to the previous version (v1.6.3.0) fixed the issue for me! Hope this helps.

Share this post


Link to post
Share on other sites
On 8/26/2019 at 6:59 PM, MaxwellsDemon said:

I experienced some other graphical weirdnesses that I have *tentatively* pinned on the latest KURS update, since they disappeared when I rolled back to the next-most-recent update.  (Tentative because it wasn't the only mod I was fiddling with at the time and I haven't had a chance to do anything approaching a rigorous test, but it is on my "short list.")  There appeared to me to be some sort of unexpected interaction with Scatterer (my ocean and blue sky went away), and (bizarrely) a "waypoint" symbol was appearing in the center of the screen for my active vessel.  It doesn't make any sense to me that KURS would have anything to do with either one, though.   Odd.  I won't really have time to do any digging till this weekend, but I thought I'd mention it in case the symptoms make any sense to anyone else.

Do you have the Transfer Window Planner installed?  And if so, did you just update it?

if so, please try again without the TWP installed

Share this post


Link to post
Share on other sites
18 hours ago, linuxgurugamer said:

Do you have the Transfer Window Planner installed?  And if so, did you just update it?

if so, please try again without the TWP installed

Interesting.... yes, I had installed it right alongside.  And removed it alongside.  Will try re-updating KURS without it.

Share this post


Link to post
Share on other sites
10 hours ago, MaxwellsDemon said:

Interesting.... yes, I had installed it right alongside.  And removed it alongside.  Will try re-updating KURS without it.

Well, you said you removed this mod and the problem went away.  Would have been nice to know about any other mods which were removed at the same time.

Share this post


Link to post
Share on other sites
Posted (edited)

I believe those were the only two I installed and removed together, though a couple of others I installed close to that time (but have not removed) were Spacetux Library 0.0.1.3 and Comfortable_Landing-1.7.0.

About to reinstall KURS without Transfer Window Planner and see how it goes.

ETA:  I am not seeing the unusual behavior, which would seem to point the finger at Transfer Window Planner.

Edited by MaxwellsDemon
Update

Share this post


Link to post
Share on other sites

Apologies for wrongly fingering KURS on this issue-- I think what misled me was that the icon appeared directly over the docking ports joining my Apollo-analogue and my LM-analogue, so my attention was directed to the docking port.   :/

Share this post


Link to post
Share on other sites
23 hours ago, MaxwellsDemon said:

Apologies for wrongly fingering KURS on this issue-- I think what misled me was that the icon appeared directly over the docking ports joining my Apollo-analogue and my LM-analogue, so my attention was directed to the docking port.   :/

Not a problem, glad you got it resolved

Share this post


Link to post
Share on other sites

Hi I have a problem with this mod. When I get to 2250m from a target that I want to rendezvous with it kills the relative velocity between the two vessels. It wouldn't be a huge problem if it matched the speed of the vessel I'm currently controlling to the target, but it does the opposite. That means the target will match the velocity and the orbit of my currently controlled vessel. When trying to expand my geostationary comm hub this becomes a problem since the geostationary hub won't be very geostationary if I alter it's velocity by 30-50m/s.

I love this mod, and I'm not sure I can dock without it, so is there any way I can turn this off?

Share this post


Link to post
Share on other sites

this is very strange, the mod doesn't touch the vessel speed at all.

I've never seen that, can you please provide a log file

Share this post


Link to post
Share on other sites

Absolutely, is it the KSP.log you want and do you want the whole thing or some specific part?

I also have a number of other mods installed, but when I removed docking cam the problem was resolved. There could still be an incompatibility between your mod and another. Are there any known incompatibilities?

 

Full list of installed mods:

[x] Science! Continued

AlphaMensae's Modular Launch Pads

Astronomer's Visual Pack and Astronomer's Visual Pack-8k Textures

AT Utils

B9 Part Switch

BetterBurnTime

BurstAtomicThrustModule

CapCom - Mission Control On The Go

Chatterer

ClickThrough Blocker

Community Category Kit

Community Resource Pack

Community Tech Tree

Community Terrain Texture Pack

Configurable Containers

Configurable Containers Core

Contract Configurator

Contract Pack: Bases and Stations Reborn

Contract Pack: Clever Sats

Contract Pack: Field Research

Contract Pack: Kerbal Academy

Contract Pack: RemoteTech

Contract Pack: Tourism Plus

Contract Parser

Crowd Sourced Science

Cryo Tanks and Cryo Tanks Core

Cryogenic Engines

Custom Barn Kit

Deployable Engines Plugin

Distant Object Enhancement and Distant Object Enhancement default config

DMagic Orbital Science

Docking Cam

Docking Port Alignment Indicator

Dynamic Battery Storage

Easy Vessel Switch (EVS)

Environmental Visual Enhancements

Feline Utility Rovers

Filter Extensions - Plugin

Global Construction and Global Construction Core

Hangar

Hangar Extender

Heat Control

Hide Empty Tech Tree Nodes

Interstellar Fuel Switch and Interstellar Fuel Switch Core

JSI Advanced Transparent Pods

K2 Command Pod Continued

Kerbal Atomics

Kerbal Attachment System

Kerbal Engineer Redux

Kerbal GPS

Kerbal Inventory System

Kerbal Joint Reinforcement Continued

Kerbal Planetary Base Systems

Kerbalized SpaceX

Kopernicus Planetary System Modifier

kOS: Scriptable Autopilot System

KS3P

KSP AVC

KSP Interstellar Extended

Mk3 Stockalike Expansion

ModularFlightIntegrator

Module Manager

MSP-3000 Material Science Pod

Near Future Construction, Near Future Electrical, Near Future Electrical - Decaying RTGs, Near Future Electrical Core, Near Future IVA Props, Near Future Launch Vehicles, Near Future Propulsion, Near Future Solar, Near Future Solar Core and Near Future Spacecraft

Nehemiah Engineering Orbital Science

Orbital Utility Vehicle Updated

Outer Planets Mod

Patch Manager

Photon Sailor

Pood's Milky Way Skybox

Procedural Fairings and Procedural Fairings - For Everything!

Progress Parser

RasterPropMonitor and RasterPropMonitor Core

RemoteTech

REPOSoftTech-Agencies

ResearchBodies

SCANsat

scatterer, scatterer - default config and scatterer - sunflare

StageRecovery

Stockalike Mining Extension

Stockalike Station Parts Expansion Redux

TextureReplacer

Textures Unlimited

Throttle Controlled Avionics

Toolbar Controller

Trajectories

TweakScale - Rescale Everything!

Universal Storage II

UnKerballed Start

Share this post


Link to post
Share on other sites
15 minutes ago, neder said:

Absolutely, is it the KSP.log you want and do you want the whole thing or some specific part?

I also have a number of other mods installed, but when I removed docking cam the problem was resolved. There could still be an incompatibility between your mod and another. Are there any known incompatibilities?

 

Full list of installed mods:

[x] Science! Continued

AlphaMensae's Modular Launch Pads

Astronomer's Visual Pack and Astronomer's Visual Pack-8k Textures

AT Utils

B9 Part Switch

BetterBurnTime

BurstAtomicThrustModule

CapCom - Mission Control On The Go

Chatterer

ClickThrough Blocker

Community Category Kit

Community Resource Pack

Community Tech Tree

Community Terrain Texture Pack

Configurable Containers

Configurable Containers Core

Contract Configurator

Contract Pack: Bases and Stations Reborn

Contract Pack: Clever Sats

Contract Pack: Field Research

Contract Pack: Kerbal Academy

Contract Pack: RemoteTech

Contract Pack: Tourism Plus

Contract Parser

Crowd Sourced Science

Cryo Tanks and Cryo Tanks Core

Cryogenic Engines

Custom Barn Kit

Deployable Engines Plugin

Distant Object Enhancement and Distant Object Enhancement default config

DMagic Orbital Science

Docking Cam

Docking Port Alignment Indicator

Dynamic Battery Storage

Easy Vessel Switch (EVS)

Environmental Visual Enhancements

Feline Utility Rovers

Filter Extensions - Plugin

Global Construction and Global Construction Core

Hangar

Hangar Extender

Heat Control

Hide Empty Tech Tree Nodes

Interstellar Fuel Switch and Interstellar Fuel Switch Core

JSI Advanced Transparent Pods

K2 Command Pod Continued

Kerbal Atomics

Kerbal Attachment System

Kerbal Engineer Redux

Kerbal GPS

Kerbal Inventory System

Kerbal Joint Reinforcement Continued

Kerbal Planetary Base Systems

Kerbalized SpaceX

Kopernicus Planetary System Modifier

kOS: Scriptable Autopilot System

KS3P

KSP AVC

KSP Interstellar Extended

Mk3 Stockalike Expansion

ModularFlightIntegrator

Module Manager

MSP-3000 Material Science Pod

Near Future Construction, Near Future Electrical, Near Future Electrical - Decaying RTGs, Near Future Electrical Core, Near Future IVA Props, Near Future Launch Vehicles, Near Future Propulsion, Near Future Solar, Near Future Solar Core and Near Future Spacecraft

Nehemiah Engineering Orbital Science

Orbital Utility Vehicle Updated

Outer Planets Mod

Patch Manager

Photon Sailor

Pood's Milky Way Skybox

Procedural Fairings and Procedural Fairings - For Everything!

Progress Parser

RasterPropMonitor and RasterPropMonitor Core

RemoteTech

REPOSoftTech-Agencies

ResearchBodies

SCANsat

scatterer, scatterer - default config and scatterer - sunflare

StageRecovery

Stockalike Mining Extension

Stockalike Station Parts Expansion Redux

TextureReplacer

Textures Unlimited

Throttle Controlled Avionics

Toolbar Controller

Trajectories

TweakScale - Rescale Everything!

Universal Storage II

UnKerballed Start

ksp.log, output_log.txt and the ModuleManage.configcache

 

Share this post


Link to post
Share on other sites
17 minutes ago, neder said:

Absolutely, is it the KSP.log you want and do you want the whole thing or some specific part?

I also have a number of other mods installed, but when I removed docking cam the problem was resolved. There could still be an incompatibility between your mod and another. Are there any known incompatibilities?

Full list of installed mods:

<snip>

Edit: Ninja'd by LinuxGuruGamer

Read the post linked in my signature block below on how to report problems clearly.  This will tell you where to find the log file LGG wants.  Upload it to a file sharing service, such as Dropbox, and post the link.  Don't post the file directly to the forum.

I can see several mods in your list that might interfere with your rendezvous since, as LGG says, KURS doesn't touch vessel propulsion or attitude control.

Edited by Brigadier

Share this post


Link to post
Share on other sites
28 minutes ago, Brigadier said:

Read the post linked in my signature block below on how to report problems clearly.  This will tell you where to find the log file LGG wants.  Upload it to a file sharing service, such as Dropbox, and post the link.  Don't post the file directly to the forum.

I can see several mods in your list that might interfere with your rendezvous since, as LGG says, KURS doesn't touch vessel propulsion or attitude control.

I agree, but the fact remains. The reason I suspected docking cam to begin with was because the problem occurred 2250m away from my target, incidentally the same range my camera was set at. When I removed docking cam the problem was solved. I removed no other mods, only docking cam.

Never used dropbox before so I hope this works.

https://www.dropbox.com/s/otkirwuusu3d8ct/KSP.log?dl=0

https://www.dropbox.com/s/johxhar1xk02ggk/output_log.txt?dl=0

Couldn't find ModuleManage.configcache but I found a log file for module manager and I'm including that instead.

https://www.dropbox.com/s/q5s0kpqb2zwo5ri/ModuleManager.log?dl=0

 

I hope it works now

Edited by neder

Share this post


Link to post
Share on other sites
24 minutes ago, neder said:

I hope it works now

Yes, you did good :cool:.

The .configcache file is in your GameData directory.

Edited by Brigadier
More info

Share this post


Link to post
Share on other sites
25 minutes ago, neder said:

I agree, but the fact remains.

True, but just because you removed KURS and the  problem disappeared doesn't mean that the problem lies there.  The failure might be with another mod and KURS just exposes it.  Since KURS doesn't manipulate propulsion modules, it's an unlike implication, and it what you're seeing could be a coincidental, not a causal, connection.

However, since I haven't looked at the KURS code, I'm not the best source of info.  I'm confident LGG will find an answer (he's very good, you know).

Share this post


Link to post
Share on other sites
15 minutes ago, Brigadier said:

Yes, you did good :cool:.

The .configcache file is in your GameData directory.

Here we go, thanks for the help.

https://www.dropbox.com/s/75xybe0fhbmwdvy/ModuleManager.ConfigCache?dl=0

 

4 minutes ago, Brigadier said:

True, but just because you removed KURS and the  problem disappeared doesn't mean that the problem lies there.  The failure might be with another mod and KURS just exposes it.  Since KURS doesn't manipulate propulsion modules, it's an unlike implication, and it what you're seeing could be a coincidental, not a causal, connection.

However, since I haven't looked at the KURS code, I'm not the best source of info.  I'm confident LGG will find an answer (he's very good, you know).

Again I fully agree with you :)

Share this post


Link to post
Share on other sites

Btw, I should clarify something. This is not a propulsion or attitude problem. If that was the case the relative speed would change over a certain period of time. This happens instantaneously, one second I'm moving at 100m/s towards the target and at a blink of an eye the relative speed is zero.

Share this post


Link to post
Share on other sites
30 minutes ago, neder said:

Btw, I should clarify something. This is not a propulsion or attitude problem. If that was the case the relative speed would change over a certain period of time. This happens instantaneously, one second I'm moving at 100m/s towards the target and at a blink of an eye the relative speed is zero.

I've been able to replicate it.  Could you try the following:

Go into the Difficulty Settings, select the Docking Camera tab, and enable the 2250 toggle (leave the others alone), and see what happens.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.