blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

Posted (edited)
Quote

I am, and no significant problems that I can see (KSP v1.6.1, Galileo's Planet Pack + Grannus Expansion Pack)

Well that's exciting! Are you using the latest release or the dev version?

Edited by zdkroot
Formatting

Share this post


Link to post
Share on other sites
8 hours ago, zdkroot said:

Well that's exciting! Are you using the latest release or the dev version?

Scatterer v0.0336

Share this post


Link to post
Share on other sites
Posted (edited)

New release is up.

It contains the new lighting, anti-aliasing, tsunami bug fix, ocean shadows, and manyother features and fixes.

Full changelog and download links in the OP/spacedock/github.

I have as well now a bitcoin donation address in the OP, I'm going through a difficult period so any help is welcome.

Enjoy :)

6CmOGWl.jpg

WN75zik.jpg

4pbyFG9.jpg

xOR5zaB.jpg

Note: In the screenshot, you have stock EVE, latest scatterer, and for the part shaders Textures Unlimited with some moduleManager patches for stock parts (can't remember where I grabbed it but probably this https://spacedock.info/mod/1841/Textures Unlimited Default Stock Config - Unofficial)

Full Release album:

https://imgur.com/a/gLhsAT1

Edited by blackrack

Share this post


Link to post
Share on other sites

Good lord i don't know how you work your wizadry. This looks amazing!

Share this post


Link to post
Share on other sites

Heck yeah. I will have to download this to update my configs tonight :) 

Share this post


Link to post
Share on other sites
Posted (edited)

Sparktacular!!! my goodness. :D

 

------

@blackrack

I know it may be gauche to speak of $$ -- but is your paypal supposed to point to a French portal? I don't do the bitcoin thing as yet. -- your humble plea isn't falling on deaf eyes. ;)

Edited by Beetlecat

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

New release is up.

Looks absolutely wonderful! I can't wait to play with it.

The changelog says you removed godrays. Is there any chance they'll come back? Godrays are one of my favourite effects in scatterer.

1 hour ago, blackrack said:

I'm going through a difficult period so any help is welcome.

Best of luck, friend.

Share this post


Link to post
Share on other sites

I just installed Stock Visual Enhancements, Stock Visual Terrain, Environmental Visual Enhancements, Kopernicus, and Scatterer.

I got the clouds from the map view and main menu like I want. However, when I'm at the kerbal space center I get infinite dark clouds like this: video

I took out Scatterer and the problem is fixed; however I get this weird blue effect on the map mode and on the main menu. Does anyone know a way to fix this?

Thanks.

 

 

Share this post


Link to post
Share on other sites

Hey! Just a heads up, I've had a number of people post on Spectra that the ocean is black and the clouds look completely different after installing the update. I don't have any ocean configs in Spectra and didn't change anything with the clouds, so I don't know exactly what's up. I'll let you know if I run into anything else.

Share this post


Link to post
Share on other sites
1 minute ago, Avera9eJoe said:

Hey! Just a heads up, I've had a number of people post on Spectra that the ocean is black and the clouds look completely different after installing the update. I don't have any ocean configs in Spectra and didn't change anything with the clouds, so I don't know exactly what's up. I'll let you know if I run into anything else.

Im updating SVE currently and there is a lot that needs to change in the cfgs if have custom scatterer cfgs in spectra.

Share this post


Link to post
Share on other sites
1 minute ago, Galileo said:

Im updating SVE currently and there is a lot that needs to change in the cfgs if have custom scatterer cfgs in spectra.

Hm... I do have custom configs. Are the new changes fairly simple to make or do you think I'd need a guide? Scatterer is the parent mod I know the least about sadly :( I'm surprised that the oceans look different though considering I don't even include ocean configs. Something in the atmosphere must be effecting them then.

Share this post


Link to post
Share on other sites
On 4/12/2015 at 3:37 AM, blackrack said:

-Shadows visible on the ocean (may be buggy in dx11)

@Avera9eJoe Could the atmosphere config in Spectra have caused a massive shadow over the ocean to make it look black? I'm not a modder so I'm not too sure, but it could be a start.

Share this post


Link to post
Share on other sites
2 minutes ago, Avera9eJoe said:

Hm... I do have custom configs. Are the new changes fairly simple to make or do you think I'd need a guide? Scatterer is the parent mod I know the least about sadly :( I'm surprised that the oceans look different though considering I don't even include ocean configs. Something in the atmosphere must be effecting them then.

The syntax is a lot simpler now. A lot of what is in our old cfgs is outdated and no longer needed. Having old syntax in the cfgs is likely causing some issues. I had to re-do SVEs from scratch so far. 

Share this post


Link to post
Share on other sites

@blackrackThis is so beautiful...

Looks perfect. What cloud config do use, BTW? 

Hope my old radeon 7950 can handle it, otherwise I'll have to upgrade just to use scatterer :)

Share this post


Link to post
Share on other sites
12 minutes ago, Galileo said:

The syntax is a lot simpler now. A lot of what is in our old cfgs is outdated and no longer needed. Having old syntax in the cfgs is likely causing some issues. I had to re-do SVEs from scratch so far. 

Oh, its good they're getting simpler then :). Do you mind if I use your configs as syntax reference when I find the time to update Spectra? Bit swamped in school projects at the moment sadly (Space Shuttle Infographic due on Wednesday that I need to still make).

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Avera9eJoe said:

Oh, its good they're getting simpler then :). Do you mind if I use your configs as syntax reference when I find the time to update Spectra? Bit swamped in school projects at the moment sadly (Space Shuttle Infographic due on Wednesday that I need to still make).

Yeah, that's fine. Don't know exactly when I'll have them finished. I was almost finished this evening.

 

Edited by Galileo

Share this post


Link to post
Share on other sites
2 hours ago, Avera9eJoe said:

Oh, its good they're getting simpler then :). Do you mind if I use your configs as syntax reference when I find the time to update Spectra? 

You know, just a suggestion, but you could use the default Scatterer configs as a reference... 

Share this post


Link to post
Share on other sites
2 hours ago, Poodmund said:

You know, just a suggestion, but you could use the default Scatterer configs as a reference... 

True haha. The real question is do they play nice with the .half files I have for each planet. They're the real heart and soul of each planet's appearance.

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, blackrack said:

New release is up.

congratz!! awesome work

btw I'm wondering about the eva visor reflections , is the one seen on picture below meant to appear with scatterer,

BIv9ScT.png

Or is it enabled by some particular mod?

I got this ingame (with avp, also do the same with SVE) (on ksp 1.6.1, with this release, as previous one) :

UFhY0BU.png

thanks!

edit: sry, pretty sure it's texture replacer related thing.. :/

Edited by kurgut

Share this post


Link to post
Share on other sites
Posted (edited)

@blackrack

Really thank you for the release! Unfortunately, I also have a bug report - this effect appears with rescale mod. I used fresh 1.6.1 install with just sigma dimensions set to 6.4 and newest scatterer release, it seems easy to reproduce. I know that you don't really support resized systems - any chances for fix...?

EDIT - after Phineas Freak explained to me KSP camera problems - this concerns scatterer effects on the vehichle. Thanks for help!

UgZeluE.jpg

 

 

 

 

Edited by Walker

Share this post


Link to post
Share on other sites
3 hours ago, Avera9eJoe said:

True haha. The real question is do they play nice with the .half files I have for each planet. They're the real heart and soul of each planet's appearance.

They should do, nothing changed with respect to the Proland Tool output.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, kurgut said:

I'm wondering about the eva visor reflections , is the one seen on picture below meant to appear with scatterer

Scatterer does...scattering effects. You are looking for either TextureReplacer (mainly for visor reflections) or TexturesUnlimited (mainly part reflections).

30 minutes ago, Walker said:

I also have a bug report - this effect appears with rescale mod.

If you mean the missing sphere edge then it has absolutely nothing to do with Scatterer (hint: the "camera01" far clip value must be increased).

Edited by Phineas Freak

Share this post


Link to post
Share on other sites

 Thank you for the update!

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, Phineas Freak said:

If you mean the missing sphere edge then it has absolutely nothing to do with Scatterer (hint: the "camera01" far clip value must be increased).

There are three problems here: 1) missing sphere you mentioned, 2) small, flickering black artifacts (one can be seen on shore, just below missing sphere) - those relatively minor, and 3) scatterer effects on the vehicle. First two dissappear at high altitude, third after scene reload and therefore is more troublesome. What should be done to increase "camera01" far clip value? Is this Sigma Dimensions issue then?

Edited by Walker

Share this post


Link to post
Share on other sites
9 minutes ago, Walker said:

What should be done to increase "camera01" far clip value? Is this Sigma Dimensions issue then?

It is a general issue when celestial bodies are rescaled (usually upwards). The stock KSP camera values are good enough for stock but not for custom planetary systems.

Camera clip values must be set via a plugin. Not sure about Sigma Dimensions but RSS (~10X rescale compared to stock) has provisions for setting these camera values for that reason.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.