UomoCapra

Kerbal Space Program 1.4.2 is live!

Recommended Posts

Anyone else noticing that RCS sometimes just goes bonkers?

Share this post


Link to post
Share on other sites
2 hours ago, Mark Kerbin said:

Anyone else noticing that RCS sometimes just goes bonkers?

For me it happens most often on the new MEM pod

Share this post


Link to post
Share on other sites

MEM? Remind me what that is. =P

14 minutes ago, prgmTrouble said:

For me it happens most often on the new MEM pod

 

Ah Nvm

Yeah seems to happen more with the new parts. Like the SAS is offcenter... hmmm

Edited by Mark Kerbin

Share this post


Link to post
Share on other sites

I landed a small lander on Eeloo and the thing relentlessly bounced all over the place like a drunken kangaroo. I made the mistake of going EVA and spent the next few minutes attempting to chase down my bouncing ship before giving up. I got a good laugh out of it, anyway.

Also, I've noticed in 1.4.1 and 1.4.2 that my large rocket visually appears to be "coming apart at the seams" during ascent, until I hit 2600 meters. Then it suddenly it all goes "solid" and looks fine the rest of the way up.

  • Like 1

Share this post


Link to post
Share on other sites

Using any mods? I tested a small lander onto the surface of eeloo. the landing legs seem more sensitive than expected and blew up on the launchpad, and then on eeloo on my first attempt. but not on my second.

No bouncing issues

Share this post


Link to post
Share on other sites

THANK YOU for fixing the bug where Kerbals think they're on a ladder after being thrown off!!!

That helps with the EVA parachutes as I like jumping out of supersonic planes.....

:sticktongue: 

Great job @SQUAD!!!!!

Share this post


Link to post
Share on other sites

So does that mean that there is a way of adjusting the settings on a lander's legs before the physics kicks in and they blow up? Specifically - LT2

Also I was able to roll back to 1.4.1 on Steam, but my game would not load because it had already saved in 1.4.2. Is there any way around that as I did not have any issues with 1.4.1

Cheers

Share this post


Link to post
Share on other sites

I have some LT2 legs on a craft landed on the Mun - they'd blowup as soon as the physics finished easing in. Went to Alt-F12 under the cheat menu and turned off crash damage and haven't had problems since. Not ideal but I'm not going to lose my drill rig to a bug.

PS. Like that picture RedeyePete.

Edited by wasml

Share this post


Link to post
Share on other sites
3 hours ago, RedeyePete said:

So does that mean that there is a way of adjusting the settings on a lander's legs before the physics kicks in and they blow up? Specifically - LT2

Also I was able to roll back to 1.4.1 on Steam, but my game would not load because it had already saved in 1.4.2. Is there any way around that as I did not have any issues with 1.4.1

Cheers

1) MAKE A BACKUP COPY of all your savegames.

2) Make another one. :-)

3) Using a text editor, open every file looking for "version = 1.4.2". Change it for "1.4.1"

4) Pray. This can hurt you epically.

I managed to salvage my crafts (VAB and SPH), but didn't tried with a full savegame. Luckily, I only played in sandbox on 1.4.2, so rolling back to 1.4.1 was just porting back the vessels.

If you are really on the mood, there's a tool called KDIFF3. You can use it do compare every single file from both savegames (your new 1.4.2, and a hypothetical old version from 1.4.1). This at least can help you to diagnose if (of when) something explodes below your nose due this stunt.

Good luck.

Share this post


Link to post
Share on other sites

I tried disabling crash damage and it worked. I'll leave it like that until 1.4.3 comes out (or longer if need be?)

So I won't try to revert to 1.4.1 for now, but I did save the instructions which might come in handy some day.

Now I can land my refuelers back on Pol, juice up the tanker in orbit and refuel the Lathe floating base so that it can deorbit.

 

Thank you

PS: that's what I look like after staring at the screen for too long.

Share this post


Link to post
Share on other sites

Regarding the legs exploding. You can disable crash damage or you can modify the legs crashTolerance value in their cfg file - change it to a higher value.
A fix is in the works.

  • Like 15

Share this post


Link to post
Share on other sites
10 minutes ago, JPLRepo said:

A fix is in the works.

Lets hope quite a few fixes are in the works. :wink:

  • Like 5

Share this post


Link to post
Share on other sites
On 3/31/2018 at 1:24 PM, silverfox101 said:

Was attempting to fly my aircraft, before I even started the engines it bounced off the runway. What's all that about :)

isnt there a mod for that? I thought this bug arrived in 1.3.x rather than 1.4.x...theres a mod out there that will slowly lower your craft onto the runway upon launch to avoid bouncing ships such as you describe. I think it has something to do with the collision meshes of the runway and the wheels/legs interfering with each other or something. Im too lazy to find the post about it...its somewhere around here. But the mod is called WorldStabilizer however there's no recompile for 1.4 and up. good luck!

  • Like 1

Share this post


Link to post
Share on other sites

What is a reasonable time frame to expect a fix for buggy landing gear from SQUAD? If it's just a couple lines in come config files it shoulda been like 48 hours, it's been almost 2 weeks...

 

Edited by g00bd0g

Share this post


Link to post
Share on other sites
18 minutes ago, g00bd0g said:

If it's just a couple lines in come config files it shoulda been like 48 hours, it's been almost 2 weeks...

It's not... This has been stated before... I'm not a dev, but my understanding is it has something to do with the game physics, and is much more complicated than it might first appear. Otherwise it would have been a quick patch and done.

And according to the newest KSPweekly, the fix is in the next patch... cool.

Edited by Just Jim

Share this post


Link to post
Share on other sites
2 hours ago, Just Jim said:

It's not... This has been stated before... I'm not a dev, but my understanding is it has something to do with the game physics, and is much more complicated than it might first appear. Otherwise it would have been a quick patch and done.

And according to the newest KSPweekly, the fix is in the next patch... cool.

Coolio,  any timeframe for the next patch?

Share this post


Link to post
Share on other sites
7 hours ago, g00bd0g said:

Coolio,  any timeframe for the next patch?

That I don't know. But it usually depends on the bugs they're trying to fix... sometimes they're a lot harder to pin down and eliminate than it might seem. I doubt over the weekend, so hopefully sometime next week. 

Share this post


Link to post
Share on other sites
On 4/1/2018 at 12:41 PM, JonathanPerregaux said:

-snip-

the thing relentlessly bounced all over the place like a drunken kangaroo.

-snip-

Have you tried using a drill as a sort of lock?

Share this post


Link to post
Share on other sites
10 minutes ago, DatBoi said:

Have you tried using a drill as a sort of lock?

Drills do nothing for that

Share this post


Link to post
Share on other sites

@StrandedonEarth It seems to have worked for me...

I was basically locked to Gilly when I landed there and deployed a drill.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now