Jump to content

[1.8 - 1.12] KSPCommunityFixes - Bugfixes and QoL tweaks


Gotmachine
 Share

Recommended Posts

5 hours ago, swjr-swis said:

Or... and hear me out a moment... add an option for us to entirely disable (and I really do mean with absolute prejudice disable) the code that does the 'let's disable stuff when parts are shielded' thing.

That would solve So. Many. Bugs. in one fell swoop.

Anyway. Never mind me.

This is the approach I would take, but I understand if gotmachine may not want to mess too much with intended stock functions.  His call really.

Edited by R-T-B
Link to comment
Share on other sites

6 hours ago, swjr-swis said:

add an option for us to entirely disable (and I really do mean with absolute prejudice disable) the code that does the 'let's disable stuff when parts are shielded' thing.

This would only cover stock code and not mods, and that this wouldn't fix more fundamental consequences like incorrect drag. I'm here to fix bugs, not to create weirder ones.

7 hours ago, Aelfhe1m said:

Perhaps use the orientation of the nodes? The decouple node and the various engine nodes all point one direction while the top node that connects to the rest of the vessel points the opposite direction. That's an already present distinction which doesn't rely on node names.

Mmmh... won't be 100% reliable, but feels like it would require a very weird part setup for this solution to fail.
Might look at doing that, this is likely the only way to tackle this issue without requiring additional configs for each case.

Link to comment
Share on other sites

On 7/1/2022 at 1:49 AM, Gotmachine said:

Don't be sorry, thank you for testing and reporting :)

There was indeed an additional bad interaction between CustomBarnKit and KSPCF (and turns out other mods as well).
Hopefully, things should now work fine with KSPCF 1.18.3 !

Excuse me, I was leaving for my son's birthday. Just returned now. Quickly I looked at the new version — everything works. Thank you very much!

Link to comment
Share on other sites

On 7/1/2022 at 2:21 PM, Gotmachine said:

Mmmh... won't be 100% reliable, but feels like it would require a very weird part setup for this solution to fail.
Might look at doing that, this is likely the only way to tackle this issue without requiring additional configs for each case.

Just pitching in to say maybe please don't fix this, or at least make it toggelable. I found a cool exploit using these to make a craft that has absolutely zero drag. it just falls through the atmosphere as if there was none

Link to comment
Share on other sites

4 hours ago, HB Stratos said:

Just pitching in to say maybe please don't fix this, or at least make it toggelable. I found a cool exploit using these to make a craft that has absolutely zero drag. it just falls through the atmosphere as if there was none

Pretty much every fix in this mod is toggleable, so safe to say it will be here if done as well.

Link to comment
Share on other sites

V1.19.0 is out, with a bunch of hot stuff thanks to all contributors.

Available from GitHub and CKAN.

Changes in that release :

  • New performance patch : CommNetThrottling [KSP 1.12.0 - 1.12.3]
    Disabled by default, you can enable it with a MM patch. Prevent full CommNet network updates from happening every frame, but instead to happen at a regular real-world time interval of 5 seconds while in flight. Enabling this can provide a decent performance uplift in games having an large amount of celestial bodies and/or vessels, but has a detrimental impact on the precision of the simulation and can potentially cause issues with mods relying on the stock behavior. (contributed by @JonnyOThan)
  • New performance patch : DisableMapUpdateInFlight [KSP 1.8.0 - 1.12.3]
    Disable the update of orbit lines and markers in flight when the map view isn't shown. Provides decent performance gains in games having a large amount of celestial bodies and/or vessels. (contributed by @JonnyOThan)
  • New performance patch : ProgressTrackingSpeedBoost [KSP 1.12.0 - 1.12.3]
    Remove unused ProgressTracking update handlers. Provides a very noticeable performance uplift in career games having a large amount of celestial bodies and/or vessels. (contributed by @JonnyOThan)
  • New QoL patch : ToolbarShowHide [KSP 1.8.0 - 1.12.3]
    Add a button for hiding/showing the stock toolbar. Also allow accessing the toolbar while in the space center facilities windows (mission control, admin building, R&D...). (contributed by @NathanKell)
  • New QoL patch : ResourceLockActions [KSP 1.8.0 - 1.12.3]
    Add part actions for locking/unlocking resources flow state.
  • New KSP bugfix : EnginePlateAirstreamShieldedTopPart [KSP 1.11.0 - 1.12.3]
    Fix engine plates causing the part attached above them to be incorrectly shielded from airstream. (Thanks to @flart for reporting and to  @Aelfhe1mfor coming up with a clever solution).
  • New KSP bugfix : AsteroidInfiniteMining [KSP 1.10.0 - 1.12.3]
    Fix asteroid/comet mass being restored to 100% when reloading after having mined it down to 0%. (Thanks to @Rodger for reporting).
Link to comment
Share on other sites

Thanks so much!  This will really help in my mid game with satellites everywhere before a massive consolidation of sats when i get the claw.

Just wondering if this first one:

13 minutes ago, Gotmachine said:

potentially cause issues with mods relying on the stock behavior

Will impact kerbalism?

Link to comment
Share on other sites

Just now, theJesuit said:

Will impact kerbalism?

In theory it shouldn't, but untested. In any case, enabling that patch alongside Kerbalism is perfectly useless, as Kerbalism should disable the stock throttling mechanism.
Also, this patch won't do much of a difference unless you have really silly amounts of both bodies and vessels.

Link to comment
Share on other sites

@Gotmachine
Map update fix introduced something that looks like a greyed out ap/pe marker in the middle of the screen when any vehicle is launched, also happens if I switch to a vehicle through the tracking station and the map view. It goes away if I enter and leave the map view, happens in 1.10.1 and 1.12.3, doesn't say anything in the log. Disabling the patch also fixes the issue. 
kAeMYs2.jpg

Edited by dok_377
Link to comment
Share on other sites

4 hours ago, Gotmachine said:

Add a button for hiding/showing the stock toolbar.

Can this be expanded to all UI elements (Via config or similar), something alike to "Quick Hide" mod?

Link to comment
Share on other sites

1.19.1 made all the planetary bodies wobble in both flight and map scenes for me. Didn't notice any FPS improvements that would make the wobble worth it, so reverting to 1.18.3 for now. Playing RSS/RO with Parallax and PRVE.

Link to comment
Share on other sites

3 minutes ago, attosecond said:

1.19.1 made all the planetary bodies wobble in both flight and map scenes for me. Didn't notice any FPS improvements that would make the wobble worth it, so reverting to 1.18.3 for now. Playing RSS/RO with Parallax and PRVE.

Can you try 1.19.1 with  DisableMapUpdateInFlight = false in the settings?

Link to comment
Share on other sites

11 minutes ago, attosecond said:

1.19.1 made all the planetary bodies wobble in both flight and map scenes for me. Didn't notice any FPS improvements that would make the wobble worth it, so reverting to 1.18.3 for now. Playing RSS/RO with Parallax and PRVE.

Have you recently installed/updated scatterer too? It's option for Temporal Antialiasing can have that effect. You can disable it in the scatterer settings (blue icon on toolbar in the KSC scene -> customize  settings -> scattering section)

Link to comment
Share on other sites

11 minutes ago, JonnyOThan said:

Can you try 1.19.1 with  DisableMapUpdateInFlight = false in the settings?

No change to the wobbling behavior, unfortunately.

2 minutes ago, Rodger said:

Have you recently installed/updated scatterer too? It's option for Temporal Antialiasing can have that effect. You can disable it

That seems to have fixed it, thanks! Unsure why the jump from 1.18.3 to 1.19.1 would have exposed this issue. Scatterer has been part of my modkit for a long time and hasn't been updated in a while. *shrug*

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...