pizzaoverhead

[1.3] RCS Sound Effects (2017-06-12)

Recommended Posts

I noticed that i have some sounds gor rcs after removing this mod. Did they add some sounds for rcs to stock?

Share this post


Link to post
Share on other sites
21 minutes ago, Errol said:

Did they add some sounds for rcs to stock?

It's been in for a few versions now.  I forget when it was added.

Share this post


Link to post
Share on other sites

That and gear sounds. I remember when I first hit "g", heard the gear come up, and wondered how I had a mod with a totally fresh KSP install!

Share this post


Link to post
Share on other sites
On 2017-6-12 at 5:51 PM, razark said:

It's been in for a few versions now.  I forget when it was added.

I don't know what am I doing wrong: I'm trying to install version 5.2 on KSP 1.3 under Linux and I get no sounds at all... :/

Actually, I tried stock sounds and got nothing either... Can someone help me, please?

Share this post


Link to post
Share on other sites
On 12/06/2017 at 9:29 PM, Errol said:

I noticed that i have some sounds gor rcs after removing this mod. Did they add some sounds for rcs to stock?

Yes, it's now stock. Since the lighting is broken, the only advantages this mod has over stock is the end firing/valve close sound, silencing it in vacuum, or that you prefer the sounds in this mod. If you want a lighter-weight version of this mod, you can just grab either of the firing sound files from it (cold and hot gas thrusters) and replace the stock ones using a ModuleManager cfg on the EFFECT node.

On 15/06/2017 at 4:28 AM, jlcarneiro said:

I don't know what am I doing wrong: I'm trying to install version 5.2 on KSP 1.3 under Linux and I get no sounds at all... :/

Actually, I tried stock sounds and got nothing either... Can someone help me, please?

No sounds anywhere in the game or no RCS sounds? Check your in-game sound settings to make sure the volumes are all turned up. Also check the console log on the Alt+F12 menu to make sure there is no red text there.

Share this post


Link to post
Share on other sites
1 hour ago, pizzaoverhead said:

[...]

No sounds anywhere in the game or no RCS sounds? Check your in-game sound settings to make sure the volumes are all turned up. Also check the console log on the Alt+F12 menu to make sure there is no red text there.

No RCS sounds. Everything sounds fine, except RCS... To test RCS I even muted Chatterer! The only other sound mods I have are RoverWheelSounds and CollisionFX.

I only got one read message in the console log:

 

Edited by jlcarneiro
Added reference to RoverWheelSounds

Share this post


Link to post
Share on other sites

Houston, I've got a problem! :0.0:

I tried removing ALL my mods and settings.cfg and tested RCS (on the launchpad): I got NO sound at all! Set all volumes to maximum to no avail.

I'm on Linux, does anyone have this problem?

ETA: Well, sorry for the alarm. I think I got some more info:

  1. Sound seems to work when I use the Place-Anywhere 7 Linear RCS Port at 100%.
  2. Deactivating the normalizer seems to help a lot...

Shouldn't the RV-105 RCS Thruster Block also make sounds?

Edited by jlcarneiro

Share this post


Link to post
Share on other sites

Did you try the RCS in space? It's a lot weaker in atmosphere, which might be mirrored by quieter sounds.

Share this post


Link to post
Share on other sites
On 16/06/2017 at 3:49 PM, jlcarneiro said:

No RCS sounds. Everything sounds fine, except RCS... To test RCS I even muted Chatterer! The only other sound mods I have are RoverWheelSounds and CollisionFX.

I only got one read message in the console log:

 

I probably should have asked for your output_log.txt file first. Your screenshot shows the issue, just a few lines above the error:

Quote

Error: AudioFX: Cannot find transform of name ''

Check your configuration file (and especially any changes module manager is making to it from other files), and revert to a stock version if you can. It looks like the thrust transform line of your EFFECT node in the .cfg file for that RCS is missing.

Share this post


Link to post
Share on other sites

Yes, it's now stock. Since the lighting is broken, the only advantages this mod has over stock is the end firing/valve close sound, silencing it in vacuum, or that you prefer the sounds in this mod. If you want a lighter-weight version of this mod, you can just grab either of the firing sound files from it (cold and hot gas thrusters) and replace the stock ones using a ModuleManager cfg on the EFFECT node.

 

Where are the stock sounds located?

Share this post


Link to post
Share on other sites

I wasn't getting RCS sounds so installed this mod (via ckan). I made a couple of adjustments to it and hopefully pizzaoverhead will take a look. I didn't particularly like the main sound so I had downloaded another file pizzaoverhead had linked to at curseforge (rcsnoise.wav). I renamed it to  RcsHeavy.wav and replaced the original. I also didn't want the shutoff sound so I deleted that one. I pretty much left ModuleManager_RcsSounds.cfg as is other than change the volume which was too high for me and changed the lighting effects to false. There were two places that listed the volume, one was at .6 and the second one was at 2.5. I changed them both to .1. Do I need to delete the references to the shut off sound since I'm not using it? Here is part of the config.

 

Default: true

@PART[*]:HAS[@MODULE[ModuleRCS]] {
    MODULE
    {
        name = RcsSounds
        rcsSoundFile = RcsSounds/Sounds/RcsHeavy
        rcsShutoffSoundFile = RcsSounds/Sounds/RcsHeavyShutoff
        rcsVolume = 0.1
        loopRcsSound = true
        internalRcsSoundsOnly = false
        useLightingEffects = false
    }
}
@PART[*]:HAS[@MODULE[ModuleRCSFX]]
{
    MODULE
    {
        name = RcsSounds
        rcsSoundFile = RcsSounds/Sounds/RcsHeavy
        rcsShutoffSoundFile = RcsSounds/Sounds/RcsHeavyShutoff
        rcsVolume = 0.1
        loopRcsSound = true
        internalRcsSoundsOnly = false
        useLightingEffects = false    }
}

Edited by MikeO89

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.