Search the Community

Showing results for tags 'texture'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • The Daily Kerbal
  • General KSP
    • KSP Discussion
    • Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website
  • KSP Pre-release
    • 1.3.1 Pre-release Branch
    • 1.3.1 Pre-release Modding Discussions

Categories

  • Developer Articles

Found 38 results

  1. I accidentally forgot to backup when I was messing with my textures. Do anyone here has Wings.dds in Squad\Parts\Aero\Wings folder? Now all my airplane wings are black. Please help me. Also, it will be better if you can upload all the stuff in Parts folder.
  2. SPC - Spaceplane Corrections Hello everyone! Personally I've been pretty annoyed that a number of stock parts don't have matching colors or shades. There are two generic white coats used for splaceplane or rocket parts, and there are at least five different shades of gray used for trim (Mk1, Mk2, Mk3, Spaceplane, Airliner, etc...). This really bugs me when building intricate craft so I decided to fix this with FireSpitters texture switch plugin (FSTextureSwitch2) to add a widget to swap between textures and trim colors as well as fix a number couple of misaligned textures and add a few aesthetic changes as well. I hope they suit your fancy This mod is dependent on the Firespitter plugin maintained by @RoverDude and ModuleManager maintained by @sarbian. Thank you all so much for making this mod work. Make sure to download and install the latest ModuleManager.dll! Firespitter is bundled with the download. Complain about mismatched textures here! It's the best way for me to find and fix them. http://imgur.com/a/KjyV5 (Album in-case the embed breaks; open sequential images in new tabs to see differences) Download: SPC v0.19 (Spacedock) License: This mod is published under the MIT lisense. View it here. Things to do Tell people to give suggestions. ??? Well, that's all for now folks! Thanks for the read, and I'll see you all later. - Avera9eJoe
  3. I was having problems when I was playing Kerbal career with funds. I had this idea to re-texture a part as a billboard and use it some way to get funds in the game. I think someone pointed out that the only way to do it would be to assiociate the part with a contract. I originally envisioned having a billboard on board to generate funds over time. I havent looked at this in a while, I would like to get it working and release it if possible. I have no 3D model making skills but have made numerous retextures for flight unlimited 3 and flight simulator (2002 and 2004) in the past and more recently Company of Heroes 2: http://steamcommunity.com/id/kokoro/myworkshopfiles/?appid=231430 So this is as far as I got with Kerbal in January 2016. In the folder in Gamedata I have a cfg, a dds texture and the solar panel .mu file. Sorry if my questions sound stupid, but I have looked and I don't know where to find the answers. First, does model.mu need to be in there or is there a way to associate the cfg with the existing solar panel model in the game, so that the model.mu doesnt have to be bundled? In order to get multiple billboards would subfolders with different cfgs and texture files be needed or what other ways are there?
  4. Suit set now finished up, will probably add onto it in the future when I have time, files are currently jpgs but if somebody could convert to DDS then that would be a great help! Will update to png again when I have time. There's 3 tiers of suits, with a custom IVA and EVA and 3 diff variants for each, also includes a range of male/female head variations. Enjoy! Download link: https://drive.google.com/file/d/0B0jTBhRYrQ-8ajBNTllIME5NRXc/view?usp=sharing Curseforge download link: http://kerbal.curseforge.com/ksp-mods/233646-scart91-texture-pack-wip And a couple pics to show off some detailing
  5. Hello guys ! I'm currently working with @HuXTUS on a part. Adding a diffuse and a bump/normal map is very easy but what's up about specular ? Shaders have no slot for that. I just found an 1 year old discussion about that : Is it still the way to add specular ? And moreover, does someone has a great tutorial on how to add this alpha channel to the diffuse (not sure it works with JPG and PNG should be a mess for the game, no ?) Hope to see some help quickly Thanks
  6. Hello forum people (I'm Running out of intros!) I have a question about texture replacer/ texture replacer replaced, and the usi class suit pack. texture replacer replaced seems to not know that i installed it. I also installed the old texture replacer, but that didnt work either. I'm thinking maybe its outdated (the USI class suit is version 1.2.2, and I have an install for version 1.3) Thank you!
  7. So, for the mod I am making, I am trying to make a 2 stars, but I have noticed that it uses a lot of textures compared to planets, does anyone know how to make each of those textures?
  8. {SOLVED}Texture not loading

    I edited a texture in GIMP, and it is not loading in the game. Can someone please help? Texture saved as .dds
  9. I really dont know, came back to ksp, auto updated all my mods, went in game but some of the textures are really buggy and my game crashes alot. Can someone tell me which of the following mods to delete because i have no idea how to check which one is causing the problems I basically had all the mods from here https://www.reddit.com/r/KerbalSpaceProgram/comments/37nedh/installing_mods_to_make_ksp_look_nicer_step_by/?st=j4atev6i&sh=8cacf8ac Which one should i delete from this list?
  10. Hello. So i have a problem. Not always, but quite often, when i land on any celestial body (Kerbin included) after getting close to the ground (like 10-15 seconds before touchdown) the ground tiles start disconnecting (clearly showing their boprder lines), and then some of them shoot up to the sky. It looks cool, but unfortunatelly it messes my landings, as all indicators show distance to the tile, regardless if that is the distance to the actual ground. After reaching the tile, it disappears and show up in the correct place just to start rising again. The whole thing is shown in the GIF linked below. The link Have anyone encountered this and if so, do You know what causes it? I have tried to disable all mods that potentially could change anything in terrain (anything that isn't just adding parts), but for now no success and so, here i am.
  11. After the overwhelming "kill it with fire!" response from test audiences to my "realistic" Kerbal faces, I've decided to override common sense and popular opinion and post them here on the official forums! Space Dock Link All of these match up to the in-game UV maps and can be applied to any desired Kerbal with TextureReplacer. These are intended to be the first of a small-ish series of astro/cosmonauts and we begin where it all started with Yuri Gagarin. Also included are the Apollo 11 crew, Neil Armstrong, Buzz Aldrin, and Michael Collins. The last inclusion in this first round is our very own Scottish Physicist, Scott Manley! 2016-06-04 - Added Buzz Lightyear at the request of someone on the Facebook group. Enjoy! 2016-06-23 - Added Valentina Tereshkova to the already hero-laden list! Not quite sure what to do about her ponytail, though. At the moment, it's just showing up black instead of transparent. Planned later additions include Vladimir Komarov, Sally Ride, Alan Shepard, John Glenn, Gus Grissom, Chris Hadfield, John Young and Robert Crippen. Further fictional faces will include Ripley from Alien. I'm very open to suggestions, though. Thanks for viewing! P.S. I didn't learn the story behind Yuri's messed-up eyebrow until after I finished his face on here. I now know that it is anachronistic at the time of his flight, but it's a good enough story that I decided to leave it in.
  12. Hi. I've been trying to replace a texture on @raidernick's Huygens probe with one I edited in GIMP. It's saved as a .dds, though strangely it's five times the size of the original skin, and the edit is just the ESA logo replaced with the NASA logo. I have tried to use Module Manager to perform the texture swap, but nothing I tried work. The texture that the game used would always be the default one. My last MM file looks like this: @PART[rn_huygens]:FOR[RN_US_Probes] { @MODEL { %texture = huygens_main, RN_US_Probes/Cassini/huygens_main_NASA } } I'm not at all familiar with Module Manager, but I did read the tutorial. Tried to use no symbol in front of the texture line and then tried the %, but neither worked. Today, I tried renaming my texture file to the one the game uses. What I got was a Huygens probe that was grey. I'm overall unsure exactly what the problem is since I don't know enough about texturing and Module Management to troubleshoot further reliably with a major time investment. I will likely continue to work at the problem myself, but I feel I'm just missing something simple that a more experienced modder would see in an instant such as a syntax error or misuse of Module Manager config files. If anyone can give me some feedback, I would be really appreciative of that. Overall, I wonder if either my .dds is too large (5.4MB vs 1.3MB for the original file), or my MM file is trying to find the wrong part.
  13. Hey guys. Quick question. What font did they use for the big red "USA" on the S-IC and S-IVB and "United States" on the S-II stages of the Saturn V? Google searches turn up the possibility of Armadillo and Helvetica fonts being used on the S-II stage, but nothing on the other stages. I'm just curious so I can do a quick texture edit for the FASA Saturn V parts and replace the KSP and Kerbal States with their real-life conterparts.
  14. Recently I succeeded in adding some colour bands to the stock engine textures, so one can tell an oxidizer-using jet engine separate from a liquid fuel-using one. Simple stuff; just colourize certain bits and add the texture line to any MODEL configs to replace the stock texture with the edited one. The "Jet Engines.dds" texture is giving me trouble with the Goliath engine. First, the original file name has a space in it, so I'm surprised this even works at all: (Note: Module Manager syntax) @MODEL { %texture = Jet Engines, [path]/JetEnginesOx } For all Mk1 jet engines in Squad/Parts/Engine/jetEngines, this seems to work. For the Goliath analogue, I'm getting an NRE telling me it can't find any reference to an object. The game loads but the part fails to load because of the missing texture. That's interesting in itself because the first time I saw a texture failure I could still get a translucent outline of a part. I'm editing the texture in GIMP, saving the images with DXT5 compression and having it create mipmaps for me. When I go through the Module Manager database afterward, I can find the modded part and verify that the edits I made are correct. The resulting DDS files have the same size and apparent characteristics of the originals. All of the parts in Squad/parts/engine/jetEngines use the same single "Jet Engines.dds" texture file. All of my modded parts from there should use the same edited texture.
  15. For some reason, in the VAB (or SPH), some of the part thumbnails show a white quad in the location of where the flag decal would normally be placed. This isn't happening for all parts (most of them don't show the flag in the preview thumbnail, as expected). This is happening in a fresh, un-modded install. What's causing this? Here's a screenshot exhibiting the behavior:
  16. I'm trying to be clever with asset use (trying to be clever is how most issues start). I have a set of parts that all use the same mesh, and mostly the same texture, so I'm trying to use all the same model, except for different versions, apply a different transparent texture as a label. This should be stock behaviour when using the MODEL{model=, texture=} mesh references. And for the life of me, I cannot spot why it's not working for me. Example part snippet; PART { name = USAFOrionMag012kt920kN module = OrionMagazine author = WinchellChung MODEL { model = USAFOrionTD/Parts/Orion/Magazines/USAFStackable/Magazine scale = 1.0,1.0,1.0 texture = baselabel, USAFOrionTD/Parts/Orion/Magazines/Labels/r1ktlabels } The intention being that I change the texture = line to point at a new label for each new edition of the part. So far I'm just messing with two of them. Dir listings; Directory of G:\NothaSteam\Kerbal Space Program\GameData\USAFOrionTD\Parts\Orion\Magazines\USAFStackable 2017-03-18 11:33 AM <DIR> . 2017-03-18 11:33 AM <DIR> .. 2017-03-18 11:33 AM 16,512 baselabel.dds 2017-03-18 11:30 AM 42,598 Magazine.mu 2017-03-18 11:15 AM 1,398,256 NewMagazine.dds 2017-03-18 11:15 AM 1,398,256 NewMagazineNRML_NRM.dds 2017-03-18 11:41 AM 5,466 part.cfg 5 File(s) 2,861,088 bytes 2 Dir(s) 447,172,456,448 bytes free Directory of G:\NothaSteam\Kerbal Space Program\GameData\USAFOrionTD\Parts\Orion\Magazines\Labels 2017-03-18 11:46 AM <DIR> . 2017-03-18 11:46 AM <DIR> .. 2017-03-18 11:46 AM 87,486 r09ktlabels.tga 2017-03-18 10:55 AM 87,568 r1ktlabels.dds 2 File(s) 175,054 bytes 2 Dir(s) 447,172,456,448 bytes free I've copy/pasted the paths, switching \ for /, copy pasted file names without extensions. I've moved the replacement textures to a different folder, converted their names to all lower-case, starting with a letter, tried square textures (it started as 512x128), tried dds vs tga vs png. If the place-holder texture is dds, game loads, no errors in the output_log. But the part just has a blank texture where the replacement should be; If the placeholder isn't dds, then I get errors about null references; PartLoader: Compiling Part 'USAFOrionTD/Parts/Orion/Magazines/USAFStackable/part/USAFOrionMag012kt920kN' (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) PartLoader: Encountered exception during compilation. System.NullReferenceException: Object reference not set to an instance of an object at PartLoader.ReplaceTextures (UnityEngine.GameObject model, System.Collections.Generic.List`1 textureNames, System.Collections.Generic.List`1 newTextures) [0x00000] in <filename unknown>:0 at PartLoader.CompileModel (.UrlConfig cfg, .ConfigNode partCfg, Single scaleFactor, .AvailablePart partInfo) [0x00000] in <filename unknown>:0 at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0 at PartLoader+<CompileParts>c__Iterator65.MoveNext () [0x00000] in <filename unknown>:0 (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) PartCompiler: Cannot compile part And the part doesn't load (Cannot compile part seems fairly clear on that). If I skip the texture = (or comment it out) then the part loads with the placeholder texture. If I apply one of the label textures in unity and compile the mu that way, it also loads fine. Or just substitute the placeholder with one of the actual textures, it also loads fine. So, what I know is it's definitely reading the texture = line, and doing something with the named texture. That bit is working. It just never seems to find the replacement texture. Which suggests there's something wrong in the paths. But I've checked that so many times I can't see there being any typos or what have you there. I'm at the "try stupid things" stage. One thing I do like to do for sticky issues, is write a big long post about the issue so I have to get it clear in my head, on the hope that the process of explaining it, solves the issue. And so far that hasn't helped, except I ran a few extra tests to get the post more complete, but with no greater success than my other attempts. So, gonna step away from the 'puter for a bit. Clean my head with a wee bit of dilute WWII German rocket fuel, and come back to this later.
  17. I'm pretty sure I can change the texture on an asteroid, and I know how to dynamically change textures in KSP, but does anybody know the name of the transform for the asteroid model itself? Basically I need the name of the mesh so I can call SetTexture on the Renderer. Also, what is the name of the texture file for the rocky asteroid texture (and for that matter, magic boulder)? Anybody know? @JPLRepo, can you shed some light on this? Thanks for your help.
  18. Suit set now finished up, will probably add onto it in the future when I have time, files are currently jpgs but if somebody could convert to DDS then that would be a great help! Will update to png again when I have time. There's 3 tiers of suits, with a custom IVA and EVA and 3 diff variants for each, also includes a range of male/female head variations. Based on real space suits such as the Sokol Enjoy! Download link: (WORKING) https://drive.google.com/file/d/0B0jTBhRYrQ-8ajBNTllIME5NRXc/view?usp=sharing Curseforge download link: (NOT WORKING) http://kerbal.curseforge.com/ksp-mods/233646-scart91-texture-pack-wip And a couple pics to show off some detailing
  19. This morning I taught myself to apply both Firespitter fuel switch and Interstellar Texture Switch to stock parts (Mk2 fuel tanks) copied out to another folder. I have what I believe is a lovely idea which will ultimately and fashionably integrate with (all of) the life support mods. I've developed some custom textures for them following the format of the stock parts' associated DDS so I can have 2 or 3 tanks referencing the same texture file, keeping down the number of texture files, but my altered parts only recognize the stock texture and I would like to have a Mk2 quarter size among them for the "simpler" of LS mods like Snacks! and Closed Loop Life Support. I have not learned Unity yet so I have no power to even hack at the mu files myself. If it's as simple as fixing how I use the model node let me know since everything else works, or do I need to ask someone to make copies of the models that will natively recognize an array of textures? MODEL { model = JadeOfMaar/DSAF/mk2tac/FuselageShortMono texture = mk2FuselageShort, JadeOfMaar/DSAF/mk2tac/tac_all_short texture = tac_food_short, JadeOfMaar/DSAF/mk2tac/tac_food_short texture = tac_water_short, JadeOfMaar/DSAF/mk2tac/tac_water_short texture = tac_air_short, JadeOfMaar/DSAF/mk2tac/tac_air_short } The mod that this is all required for is here:
  20. For some reason i've started noticing that the orbit ground texture of Kerbin seems to be flipped upside down when i zoom out far enough from a flight in progress. I see the normal terrain fade out into the upside-down orbit texture =/ I do have quite a few mods but never had this issue until yesterday, and i havent really changed anything in terms of the mods or settings, tried without a few of them and the problem still persists. I'm stumped. Running with, among others, Scatterer, TextureReplacer, SVE, EVE, Kopernicus, OPM. But as i said, i ran all these without this issue a few days ago. Only today this problem occured, the only change i can remember doing was updating Scatterer to the latest 0.0300 version, but even removing Scatterer from GameData doesnt resolve it so i doubt it had anything to do with that. Tried removing TextureReplacer, no change. As for SVE, EVE, Kopernicus and OPM, no changes to those mods, no updates. Anyone got any ideas? Cheers. Edit: Solved. Sigma-Binary was the mod that caused the issues.
  21. Problem 1 I use a DialogGUIButton and an image (weird target sight) to create an image button (code). However, the resulting button is not quite what I desire. The default state of the button is missing the button texture while the highlighted state is missing the image. It acts as if the button texture is changed instead of overlaying multiple textures. Can anyone figure out why it does this? Problem 2 This image is explicitly set to 32 in both width and height (code) but the resulting image is stubbornly more than 32 in width as shown in the above picture (the green borders are drawn by DebugStuff). I do not understand why this particular image is stretched despite its width is locked to 32. The interface engine has a free reign to how to draw bunch of GUI components. So I edited the DialogGUILabel object next to the DialogGUIImage to be excessive in its width so that it "steals" all the free space, leaving the image no space to expand in width.
  22. Rocket Texture Replacer mod

    I've been looking for a mod that can change the texture of the rocket, like if I want to, I can change the rocket so it has some sort of red thing on the side, I cant/really don't want to draw the stuff myself, so is there a mod that works with 1.2.2 that allows you to change the texture of a rocket, not texture replacer, that I'm not really sure how it works... but is there a mod for it, because I have looked for about a month, and haven't found one that works with 1.2.2, and procedural parts I'm not really sure even works anymore...
  23. Planet mod texture issues/help?

    I've recently begun developing a planet pack and I'm running into some texture issues so far, if someone could let me know what's wrong here, I'd appreciate it: Code for moon: The image below is the Color map (upper left), the Normal map (lower left), and the VertexColor (right) map. Once I launch the game, the in-game moon looks like this:
  24. On Vall and Minimus (so far) I have noticed the textures go multicolured and flicker. I thought it was the biomes bleeding through but I think it is something more Version: 1.2.1 64-bit Linux (Manjaro Linux running AMD CPU and GPU) What happens: When below 5000 meters or so the landscape of the planets go rainbow Steps to Replication: 1) Set orbit over Vall/Minimus 2) Get below 3000 meters (the effect starts being the most visible around there) 3) Watch the descent into the rainbow Result: The planets texture will go like the image below Log:http://pastebin.com/prYJXwdT
  25. I copied and modified the Stratus-V Monopropellant tank (leaving the original intact) to make a LF/OX radial tank. Everything works as intended, except the tank doesn't inherit the texture from the original part. The cfg file references "mesh" and so I've left it alone where it resolves as "model". I assumed this just looks to whatever model shares the same folder as said cfg file. Except it isn't doing that, and the tanks just have a standard grey scale texture, in-game. Something tells me I'm missing something obvious.