blowfish

[1.7.3] B9PartSwitch v2.10.0 (Aug 18) - module switching!!!

Recommended Posts

17 minutes ago, Eli the Space Nerd said:

Is there a fix to this?

Sadly no. That's entirely up to @CobaltWolf to fix. This is a harmless warning. It means certain mesh options won't be available, but it's not game-breaking (in opposition to having subtypes with undefined tank types).

Share this post


Link to post
Share on other sites

Yeah it would be nice if there was a fix for this, I have to dismiss that dialog every time I start the game.

Share this post


Link to post
Share on other sites

It's fixed in the dev version of BDB.  If the popup bothers you enough you can try using Dev BUT...it's at your own risk.  Dev is for dev and testing, so you won't get any support if it breaks stuff!

Share this post


Link to post
Share on other sites

I have several mods installed which have B9PS as a dependency, but aren't updated to use 2.9.0 yet. Will things break if I install 2.9.0 anyway?

Share this post


Link to post
Share on other sites
32 minutes ago, RealKerbal3x said:

I have several mods installed which have B9PS as a dependency, but aren't updated to use 2.9.0 yet. Will things break if I install 2.9.0 anyway?

you should be fine /ymmv/ - other way round might cause problems, but unless it is a gamebreaking update (like KIS/KAS was) - B9 adding features, fun features, but didn't change anything (that I know of) public facing.

Share this post


Link to post
Share on other sites
10 hours ago, Eli the Space Nerd said:

Hi, I'm facing through a situation in which I received a warning from this mod. The warning popped out when the game loaded into the main menu.

Is there a fix to this?

Those parts have been remade from scratch as part of the current dev cycle for Bluedog, so I'm not fixing the ones in the current release. Those errors shouldnt break anything. :)

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/8/2019 at 12:03 PM, Autolyzed Yeast Extract said:

I think it would be fair to mention that Community Resource Pack is required for this mod to not have fatal errors and link to its download.

If you have a mod installed that requires CRP and uses B9PartSwitch and you don’t have CRP installed, you will encounter a fatal error.

11 hours ago, RealKerbal3x said:

I have several mods installed which have B9PS as a dependency, but aren't updated to use 2.9.0 yet. Will things break if I install 2.9.0 anyway?

If there was a breaking change I knew about I would have documented it and updated the major version to 3.0.  Alas, 2.9.0 is fully backwards compatible.

Edited by blowfish

Share this post


Link to post
Share on other sites
Posted (edited)
On 8/9/2019 at 9:37 AM, CobaltWolf said:

Those parts have been remade from scratch as part of the current dev cycle for Bluedog, so I'm not fixing the ones in the current release. Those errors shouldnt break anything. :)

Alright then. :D

Edited by Eli the Space Nerd

Share this post


Link to post
Share on other sites

@blowfish Question about the switching.

I'm converting the Octosat mod to B9, and have all the parts (all 37 of them) configured.  Works nice.

Is there a way to have ALL the parts switch when changing colors?

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

@blowfish Question about the switching.

I'm converting the Octosat mod to B9, and have all the parts (all 37 of them) configured.  Works nice.

Is there a way to have ALL the parts switch when changing colors?

I have not implemented themes yet.  IIRC there's an open issue for it.

Share this post


Link to post
Share on other sites

B9PartSwitch v2.10.0 for KSP 1.7.3

  • Use funds symbol for cost in tooltips
  • Fix vessel size including disabled objects
  • add new upgradeRequired field to SUBTYPEs
    • References the name of a PARTUPGRADE require do unlock the subtype
    • At least one subtype on every switcher must have no tech restriction (i.e. unlocks with the part), otherwise it will complain and remove the restriction from the first subtype
    • All subtypes are unlocked in sandbox regardless of whether upgrades are applied
    • Warning if the upgrade doesn't exist
    • If you attempt to load a craft with a locked subtype you get a warning that it was replaced with the highest priority unlocked subtype
  • Add defaultSubtypePriority to SUBTYPEs
    • Number (float) that determines a subtype's priority as the "default" subtype (i.e. the one that is chosen when you freshly add the part).
    • The subtype with the highest priority that is also unlocked will be chosen
    • If two subtypes have the same priority and both are unlocked, it will choose the first
    • The default value is zero.
  • Add basic implementation of module switching
    • HIGHLY EXPERIMENTAL
    • Subtypes now accept a MODULE node
      • inside is an IDENTIFIER node which is used to identify the module
        • it must have a name which is the same as the module
        • it can have any other fields that are used to identify the module
          • e.g. engineID on ModuleEngines
        • Identifying the module by nodes is not currently supported
      • It accepts a DATA node which provides new data to be loaded into the module
      • It accepts a moduleActive = false value which causes the module to be disabled
    • Not everything will work initially, custom handling will have to be added for some modules
    • Some modules are blacklisted for loading new data and disabling. This list is subject to change.
      • ModulePartVariants
      • ModuleB9PartSwitch
      • ModuleB9PartInfo
      • ModuleB9DisableTransform
      • FSfuelSwitch
      • FSmeshSwitch
      • FStextureSwitch
      • FStextureSwitch2
      • InterstellarFuelSwitch
      • IntersteallarMeshSwitch
      • InterstellarTextureSwitch

 

Big thanks to @Gotmachine who's initial implementation of module switching this is based on

Please talk to me before you attempt to use module switching.  Like I said in the changelog not everything will work initially.  I'm willing to add additional code to support specific modules, but I'd like to understand the use cases before doing so.

Share this post


Link to post
Share on other sites
2 hours ago, Natokerbal said:

Seems like your installation of RationalResources might be out of date?  Try updating that

Thanks for posting the log though, allowed me to quickly see what's in your install and what might be wrong

Edited by blowfish

Share this post


Link to post
Share on other sites
47 minutes ago, blowfish said:

Seems like your installation of RationalResources might be out of date?  Try updating that

Thanks for posting the log though, allowed me to quickly see what's in your install and what might be wrong

yup it was rational resources. also I thought it was an expectation to have a log. :) thanks for the help

Share this post


Link to post
Share on other sites
17 hours ago, MegaMindy said:

I am getting a fatal error on startup, running KSP 1.7.0 and I don't really understand why. Any help would be greatly appreciated!

I have tried with multiple versions of B9PS, but all of them create this same fatal error.

https://www.dropbox.com/sh/giodmbcr6az553e/AAB5DCuDU_qe1uB36ydXClTFa?dl=0 

Welcome to the forums!

The error you're getting has nothing to do with the version of B9PartSwitch you have installed.

The problem appears to be that your GameData/Squad directory is missing some pieces.  So in this case the stock resources (LiquidFuel, Oxidizer, etc) are not defined.  Try deleting and re-installing GameData/Squad.

Share this post


Link to post
Share on other sites
2 hours ago, blowfish said:

Welcome to the forums!

The error you're getting has nothing to do with the version of B9PartSwitch you have installed.

The problem appears to be that your GameData/Squad directory is missing some pieces.  So in this case the stock resources (LiquidFuel, Oxidizer, etc) are not defined.  Try deleting and re-installing GameData/Squad.

Thank you! 

It's been a while since I played KSP, and I got this error message after a new install I did with CKAN. I tried the exact same mods on a manual install, and everything worked perfectly.

Thank you for taking the time to troubleshoot! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.