K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

1 hour ago, JadeOfMaar said:

@stali79 Got screenshots of when they worked? I'd like to see.

Unfortunately no, but when I last heard from @K.Yeon he mentioned he wanted to do body parts that had integrated landing gear.

Share this post


Link to post
Share on other sites
19 hours ago, Stone Blue said:

I see you have OPT Legacy installed.. the Humpback to Juno (J-class) adapter is just that... your issue is that that is *not* a Juno (J-class) aerospike... It is Stail class...
The Stail class is *very* close to the Juno profile, but as you can see, doesnt *quite* fit... vOv

Currently, there are no parts to cross Humpback directly with Stail parts.

Also, there is technically only *one* J-class part specific to OPT Legacy, and that's the J Cockpit Legacy...
The drone core and RCS unit are actually parts from OPT Main, but are cloned in Legacy, if Main is not installed as well...
If you want a full line-up of J-class parts, you need to install OPT Main, as well...

By OPT main am I correct to assume you mean "OPT Space Plane" in CKAN? it says it is updated to work in 1.3.9, but does it still work on the current version? I'd hate to lose my campaign installing a mod that doesnt work well with it.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, mcwaffles2003 said:

By OPT main am I correct to assume you mean "OPT Space Plane" in CKAN? it says it is updated to work in 1.3.9, but does it still work on the current version? I'd hate to lose my campaign installing a mod that doesnt work well with it.

I dont touch CKAN, so I do not know what its specifically called there... I even get confused with the naming between it and Legacy on SpaceDock...

However, *this* thread you are posting in, is the thread for OPT "Main"... "Main" is an "unofficial" name that has been given to it by the community, to differentiate between it and Legacy. You can probably refer to the first post, to clarify your CKAN question... or at least use the link to manually grab the pack from SpaceDock...

I believe KYeon intended to have the parts in Legacy completely disappear forever, after the "remake" that contains the new stuff... So I assume there was no need to rename the mod, so "officially", its still only Orbit Portal Technology Space Plane Parts...
It was after that, that idk who exactly, grabbed up the old parts and "re-released" them as a seperate pack, naming them OPT Legacy... I dont think there was ever a new, seperate thread created for the "Legacy" pack, until JadeOfMaar created one when he made the Reconfig patches...

*That* thread is where both OPT Reconfig and OPT Legacy mods are hosted and discussed... NOT this thread... ;)
Sorry for any confusion, but it is what it is... it can be difficult to have clear threads and discussions when mods are taken over, or split off, without a good "hand-off", from original dev to anyone else who gets involved... vOv

Heres the Reconfig/Legacy thread:

And to answer your question, OPT is a strictly parts pack, and does not include any plugins (.dll files) of its own, so it should pretty much work in any version of KSP.... from 1.3.0 (possibly even earlier), up to and including any future versions...
So, yes... it does still currently work as-is... I would however highly recommend *always* having OPT Reconfig installed with either OPT Main, or Legacy pack... It is an awesome set of patches that tweaks both packs, and helps keep them current and compatable with both stock KSP and many other great mods.

Edited by Stone Blue

Share this post


Link to post
Share on other sites

I finally had the time to try the mod out and once again I have to say that I really like it. :D

Only thing that bothers me is that I have two buttons to switch the fuel type. Does anyone else have this?

Share this post


Link to post
Share on other sites
3 hours ago, ISOREX_ said:

Only thing that bothers me is that I have two buttons to switch the fuel type.

My first guess is that you have OPT Reconfig installed twice. Make sure that it only exists where it should within your GameData. My second guess is that you have a fuel switcher mod that affects OPT but is not disabled by OPT Reconfig.

Share this post


Link to post
Share on other sites
39 minutes ago, JadeOfMaar said:

My first guess is that you have OPT Reconfig installed twice. Make sure that it only exists where it should within your GameData. My second guess is that you have a fuel switcher mod that affects OPT but is not disabled by OPT Reconfig.

Thanks for the fast reply. I don't think it's two installs of OPT Reconfigurations since they are different kind of switches (see here). Here's a modlist of my current mods, maybe anyone can spot the problem. https://imgur.com/a/J7LGLkf

Share this post


Link to post
Share on other sites

@ISOREX_ That's not a problem. That's a recent new feature of B9PS. It's for convenience when you have tanks that have many options.

Share this post


Link to post
Share on other sites
Posted (edited)
32 minutes ago, JadeOfMaar said:

@ISOREX_ That's not a problem. That's a recent new feature of B9PS. It's for convenience when you have tanks that have many options.

Ah my apologies then, I thought it was a bit confusing but I guess if you have many more fuel types it can be useful. Thanks for the help.

Edited by ISOREX_

Share this post


Link to post
Share on other sites
Posted (edited)

Can I request a new part?

- Mounted H cockpit, used for KH sized planes with K sized cargo doors in front.

Edited by Penkover

Share this post


Link to post
Share on other sites
32 minutes ago, Penkover said:

Can I request a new part?

- Mounted H cockpit, used for KH sized planes with K sized cargo doors in front.

Unfortunately this mod has been in a maintennance state for over 12 months now as @K.Yeon is mia.

Share this post


Link to post
Share on other sites
On 10/20/2014 at 10:34 AM, NathanKell said:

Well now, that looks pretty cool! Welcome to the forums, and what a first post! :)

Do these engines makes the aircraft go at the speed of sound? But, sonic booms do not happen in-game.

Share this post


Link to post
Share on other sites

@Stephen Locksley Look at your navball. 320m/s is the speed of sound in KSP, however it drifts a bit when atmosphere temperature and pressure changes. Sonic booms only exist when you're in a static position and something else passes you at the speed of sound. You'll never experience a sonic boom while you're in the object moving at incredible speed. And lastly, KSP does not , and will not, model that.

Also, what's with the quote?

Share this post


Link to post
Share on other sites
2 minutes ago, JadeOfMaar said:

@Stephen Locksley Look at your navball. 320m/s is the speed of sound in KSP, however it drifts a bit when atmosphere temperature and pressure changes. Sonic booms only exist when you're in a static position and something else passes you at the speed of sound. You'll never experience a sonic boom while you're in the object moving at incredible speed. And lastly, KSP does not , and will not, model that.

Also, what's with the quote?

This mod has its engines reach the speed of sound, but Airplane Plus planes can also reach the speed of sound. The Wheesley engine, which is a stock part in KSP, has an enough thrust to reach the speed of sound.

Share this post


Link to post
Share on other sites

All engines in KSP allow you to go past that speed. :/ This is confusing.

Share this post


Link to post
Share on other sites

Is there anything additional needed that adds the OPT parts in their own category? I have KSPIE, B9 wings, and Kerbal Attachment System, and they all have their own category, but OPT does not. This makes locating parts difficult unless I look in the 'all _' section, or search for OPT.

Share this post


Link to post
Share on other sites
22 minutes ago, wkwied said:

Is there anything additional needed that adds the OPT parts in their own category?

Filter Extensions, or Community Category Kit.

Share this post


Link to post
Share on other sites
Just now, JadeOfMaar said:

Filter Extensions, or Community Category Kit.

Is there any particular version of CCK? I'm running 4.1 (for 1.6.x). Think an update will fix this?

Thanks

Share this post


Link to post
Share on other sites

There shouldn't be a particular version requirement for CCK. It should just work afaik. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.