UomoCapra

Kerbal Space Program Update 1.5 Grand Discussion thread

Recommended Posts

3 minutes ago, Ultimate Steve said:

Wait... It's been out since Thursday and I haven't noticed? Wow, I must really be tired...

2 minutes ago, RealKerbal3x said:

Yeah. How the hell did I not notice?

It wasn't, the release got delayed a couple of days. They must've just hidden the thread.

  • Like 8

Share this post


Link to post
Share on other sites
Just now, CobaltWolf said:

It wasn't, the release got delayed a couple of days. They must've just hidden the thread.

Interesting. Well, we needn't worry. The update is here and I can't wait to play with the shiny new textures!

Share this post


Link to post
Share on other sites
3 minutes ago, RealKerbal3x said:

Yeah. How the hell did I not notice?

I saw the post for the annoucement this morning... then it disappeared or got merged into this thread or somefin.   I was looking for my post to the thread this morning, but it's gone.

Share this post


Link to post
Share on other sites
4 minutes ago, Ultimate Steve said:

Wait... It's been out since Thursday and I haven't noticed? Wow, I must really be tired...

A release takes time and we prepared some posts beforehand hehe :D

  • Like 10

Share this post


Link to post
Share on other sites
On 10/11/2018 at 4:48 PM, UomoCapra said:

* Kerbals can now be placed in external command seats in the VAB/SPH.

Yey! Finally we don't need to have a mod for this. :D

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, worir4 said:

Yey! Finally we don't need to have a mod for this. :D

Yep. One less mod for @linuxgurugamer to maintain :wink:

I'm launching 1.5 now, apparently AVC really doesn't like me updating. Pretty much every mod I have said something like 'Please use 1.4.1'. I'm sure they'll be fine though.

Edited by RealKerbal3x
  • Like 3

Share this post


Link to post
Share on other sites

What's the new FL-T100 skin? Mine looks the same as it always has... or I'm missing some super-subtle detail?
Se9Ewch.png

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Dark Lion said:

What's the new FL-T100 skin? Mine looks the same as it always has... or I'm missing some super-subtle detail?
Se9Ewch.png

try verifying your install

Share this post


Link to post
Share on other sites
Just now, Lupi said:

try verifying your install

What does that mean? I got it fresh from the KSP store... is that a Steam thing?

Share this post


Link to post
Share on other sites

Just took the SSTO I was working on for a spin after updating to 1.5 and it struggled to make headway at low altitude and had about 200 less dV by orbit.

Something changed  that's not mentioned in the release note?

 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Dark Lion said:

What does that mean? I got it fresh from the KSP store... is that a Steam thing?

You must have downloaded 1.4.x accidentally or Squad have packaged the wrong version on the Store.

This is what the FL-T100 should look like (along with awesome looking white Mk1 command pod!)

CgaQDiJ.jpg

 

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, severedsolo said:

You must have downloaded 1.4.x accidentally or Squad have packaged the wrong version on the Store.

Nawp! I mean, I'm pretty thorough when it comes to that. Also, check that image I posted again, closer this time. Note the FL200-800 look just like the 1.5.0 tanks should, which would not be present in a 1.4.x install... ;) 

Share this post


Link to post
Share on other sites
Quote

Rotated the RoveMate ninety degrees to make it match with its Navball orientation

FINALLY

  • Like 8

Share this post


Link to post
Share on other sites
2 minutes ago, Dark Lion said:

Nawp! I mean, I'm pretty thorough when it comes to that. Also, check that image I posted again, closer this time. Note the FL200-800 look just like the 1.5.0 tanks should, which would not be present in a 1.4.x install... ;)  

Heh I did miss that the first time. Either way though, the advice is still sound. Purge the directory entirely, redownload it. If it's still happening, chances are something is funky at the store.

  • Like 1

Share this post


Link to post
Share on other sites

So far, so good... looking forward to trying out all the revamped parts and modifications.

The new suits look great.

Just one thing... am I seeing things, or is the old HECS model still there alongside the new one?

  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Vexillar said:

Just one thing... am I seeing things, or is the old HECS model still there alongside the new one?

That's no hallucination! 
Kgf1SUS.png

The old one gets specular bump though.... and the new one doesn't get the mentioned rotation...

Edited by Dark Lion
Noticed more differences
  • Like 2

Share this post


Link to post
Share on other sites

 

Any word on this?

I don't play KSP since then, waiting for the fix playing other games until is fixed. Maybe 1.6?

Edited by DoToH

Share this post


Link to post
Share on other sites
2 hours ago, drewthedrewman said:

Wow, Better Burn Time and Take Command both obviated?! Tasty :)

Well, BetterBurnTime's not quite obviated-- it does have a few features that are not in stock (i.e. assistance with vacuum landings, target rendezvous, and atmosphere transition).

But yeah, the big feature that's probably the reason most folks really liked it is now not just stock, but better in stock.  So, well done Squad, as far as I'm concerned.  That's a seriously shiny new toy there.  :)

(I mean metaphorically.  As opposed to the actually, literally shiny toys you've given us in 1.5 too...)

  • Like 9

Share this post


Link to post
Share on other sites

To me, the most exciting thing in this update is the shiny "VesselDeltaV" class !

As for the shiny parts... not fond of that, I find that it doesn't fit well with the overall "matte" style of KSP.

Share this post


Link to post
Share on other sites
20 minutes ago, DoToH said:

Any word on this?

I don't play KSP since then, waiting for the fix playing other games until is fixed. Maybe 1.6?

Reading that thread, I wouldn't expect any action till SQUAD receives a save file that reproduces the problem, since a member of their QA staff already tried on his own and didn't experience it.

Share this post


Link to post
Share on other sites

Wondering what change affected the first test I ran? Figured I'd do a real quick check mostly just to see how things looked (particularly UI scale, which at first glance does seem better, but that's not what I'm writing about here). New career, moderate difficulty, make the simplest flyable rocket (pod 1, chute, flea, 3 fins - no science experiment or anything else bothered with - not that there's much else in the way of options at that stage). Turn on Jeb's SAS and launch straight up, doing nothing til max altitude, where I hit the stage to trigger chute deploy.

what am I doing at 20.9 K meters? Actually a hair high for the chute to semi-deploy. When I do get low enough for it to semi-deploy up here, it doesn't have enough drag to keep from accelerating til the chute is destroyed. (In retesting, I discovered that the chute destruction was from the physics warp I did on the way down; without the warp, it does stay under the destruction limits - barely). Went back and rechecked the same setup with 1.4.33, 1.4.4, and 1.4.5, all of which I still happen to have loaded on that same machine. They all get to about 13.9 k meters instead of 20.9 k. Drag difference? Atmosphere?

 

Share this post


Link to post
Share on other sites

It seems to me like Mk1 Pod, despite previous information on "not changing its properties too much" is now flipping in atmosphere (with no SAS) to fly with pointy side down, while it should keep its orientation with thick bottom side to prograde. Is it intended? Anybody else can observe this?

  • Like 1

Share this post


Link to post
Share on other sites

why is it still not possible to stage while in map mode?

 

its cool now you see when your stage is gonna be empty, but then you have to quit the map, stage, and reopen it.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now