Jump to content

[1.8.1] JNSQ [0.9.0] [03 Feb 2020]


Recommended Posts

55 minutes ago, Kwebib said:

Could there be any issues with editing the minmus.cfg to put its orbit inside the Mun if I am not using Principia?

No problems that I can think of.

Note that Mun's orbit changes slightly too for Principia users.  As well as Bop's orbit, which becomes retrograde.

There's also a trick you can use to force the Prinicipia changes to take effect in JNSQ without actually installing Principia.  Create a folder in GameData named Principia, and place the following config into it:

@Kopernicus:FOR[Principia]
{
}

That will make JNSQ think there's a mod named Principia installed, so it will make all the Principia related changes without you having to edit any configs.
 

Edited by OhioBob
Link to post
Share on other sites
35 minutes ago, infinite_monkey said:

Will installing principia in an ongoing career cause trouble?

As I understand it, yes.  Any game intended to be played using Principia has to be started after installing Principia.  Principia makes changes to the game that are incompatible with non-Principia saves.

However, if you're referring to my config to make JNSQ think Principia is installed, then I think you should be OK installing it mid-game. Any vessels orbiting Minmus should stay with Minmus after it moves.
 

Edited by OhioBob
Link to post
Share on other sites
13 hours ago, FlyingGeeze said:

Is there some map or chart which I can go by to know which biome is where? I really have no idea where to fly to if I were to find southern mountains.

I added initial support for this to Kerbal Maps some time last year. I'll make sure it gets carried forward in the new version so it's available for all planet packs.

Link to post
Share on other sites

MkNphdY.jpg

https://kerbal-maps-ui-staging.herokuapp.com/

This isn't the final URL, so be warned if you bookmark it.

Kerbal Maps v0.5.1 is a near-total rewrite of the app, so there are some things that still haven't been ported over from the production version, including

  • latitude and longitude grid markers
  • search
  • overlays
  • a legend for the biome map

(Come to think of it, I'm not sure all of those are working in the production version, either.)

Those of you who are familiar with the bodies in JNSQ: please browse through the maps to see if they look right.

Everyone: please poke around, and let me know of anything you find that doesn't work the way you think it should.

  • If you have a GitHub account, the most efficient way to report an issue is by creating one at https://github.com/FiniteMonkeys/kerbal-maps-ui/issues.
  • Otherwise, please feel free to DM me here or (assuming the topic owners are okay with it) add a reply to this topic.
  • I'll be posting news of this to the Kerbal Maps topic soon, so you'll be able to report issues there as well. If possible, please wait until after I've announced it, so as not to cause too much confusion.

A big thank you goes out to @RowBear for contributing time and CPU cycles to extract the map tiles, and @JadeOfMaar, @Galileo, @Sigma88, and anyone else I might be forgetting for assistance with JNSQ and the tooling used in Kerbal Maps.

Link to post
Share on other sites

Alright -- so this is funny...

I had no idea that JNSQ's kerbin wasn't just a scaled-up and cleaned-up stock Kerbin until looking at it in Kerbal Maps ^^ up there. Those thick, gorgeous clouds were providing lots of literal and figurative cover. ;)

what are the lat/lon for KSC? The fact that it's on a somewhat-similar peninsula added to the initial illusion.

Link to post
Share on other sites

Hi, finally started my 1.8.1 save from scratch with the latest JNSQ. I have a miner drilling on the surface to  get some experience with the whole RR ISRU process. When I make that miner lander ship active, it jumps a small amount, not enough to break anything. I did see some posts about bases jumping from a 1.7.3 save, but this is not the case here.  Are there surface issues on Minmus (or anywhere else) that would affect bases or landers?

Thanks

Link to post
Share on other sites
3 hours ago, Gilph said:

Hi, finally started my 1.8.1 save from scratch with the latest JNSQ. I have a miner drilling on the surface to  get some experience with the whole RR ISRU process. When I make that miner lander ship active, it jumps a small amount, not enough to break anything. I did see some posts about bases jumping from a 1.7.3 save, but this is not the case here.  Are there surface issues on Minmus (or anywhere else) that would affect bases or landers?

Thanks

Sounds like you need: 

 

Link to post
Share on other sites

I'm trying to redirect an asteroid but the Advanced Grabbing Unit won't connect. This is the first time I've tried grabbing an asteroid in JNSQ. It's a massive class E asteroid. I searched this thread and didn't find any similar reports. Are there any known asteroid difficulties or glitches caused by JNSQ's asteroid rescale?

Approach speeds ranging from 0.2 m/s to 4.5 m/s keep bouncing off. Most of my attempts have been at 1.2 m/s. Sometimes the grabber bounces off before visual collision, like the asteroid has an invisible force field a meter above the surface. Other times my asteroid tug sinks a few meters into the surface before bouncing off.

Note that I've already tried pressing [ rapidly just as docking should occur. That sometimes helped when docking was stubborn in stock. I've also confirmed that the grabber is working; I can grab debris.

 

Link to post
Share on other sites
1 hour ago, DeadJohn said:

I'm trying to redirect an asteroid but the Advanced Grabbing Unit won't connect. This is the first time I've tried grabbing an asteroid in JNSQ. It's a massive class E asteroid. I searched this thread and didn't find any similar reports. Are there any known asteroid difficulties or glitches caused by JNSQ's asteroid rescale?

Approach speeds ranging from 0.2 m/s to 4.5 m/s keep bouncing off. Most of my attempts have been at 1.2 m/s. Sometimes the grabber bounces off before visual collision, like the asteroid has an invisible force field a meter above the surface. Other times my asteroid tug sinks a few meters into the surface before bouncing off.

Note that I've already tried pressing [ rapidly just as docking should occur. That sometimes helped when docking was stubborn in stock. I've also confirmed that the grabber is working; I can grab debris.

 

I had a similar issue with a class B not too long ago. I totally forgot about it. I was never able to grapple it.

Link to post
Share on other sites
27 minutes ago, JadeOfMaar said:

@DeadJohn @leatherneck6017 The problem of grabbing large asteroids is that the colliders don't perfect fit the visible mesh. The difference becomes more prominent as the size goes up. Either that, or the module that does the resizing of the asteroid does something weird to the collider.

Can the top post be updated to say that asteroids are broken? The changelog merely says "Updated asteroids: Now they are only 3.3x dense as stock where they were 33x which was far too much." which suggests that they are working okay.

Link to post
Share on other sites

While we're talking about asteroids, I took a (stock) SENTINEL contract to find 14 asteroids with 20 degree tilts or more. It has like a 600 year time limit. I have no mods that affect asteroids or contracts, except JNSQ. I don't have Contract Configurator installed, even.

I've gone about 8 years past the day I took the contract, and maybe 7 years since putting the SENTNEL scanner in place (it matched the orbit, yes :)) and so far have found 0 asteroids. Granted, I'm only 1% or so of the way through the time limit but I'm starting to wonder if maybe none of these asteroids will be generated.

Link to post
Share on other sites
1 hour ago, 5thHorseman said:

While we're talking about asteroids, I took a (stock) SENTINEL contract to find 14 asteroids with 20 degree tilts or more. It has like a 600 year time limit. I have no mods that affect asteroids or contracts, except JNSQ. I don't have Contract Configurator installed, even.

I've gone about 8 years past the day I took the contract, and maybe 7 years since putting the SENTNEL scanner in place (it matched the orbit, yes :)) and so far have found 0 asteroids. Granted, I'm only 1% or so of the way through the time limit but I'm starting to wonder if maybe none of these asteroids will be generated.

Is your target orbit past kerbin? I had a sentinal contract that wanted asteroids intercepting kerbin, but it said the orbit should be past kerbin. I edited my save file to change the SMA of the target orbit (from 42-something to 32-something to be between eve and kerbin), and it worked, scanning all the asteroids within 1-2 years.

Link to post
Share on other sites
2 minutes ago, Rodger said:

Is your target orbit past kerbin? I had a sentinal contract that wanted asteroids intercepting kerbin, but it said the orbit should be past kerbin. I edited my save file to change the SMA of the target orbit (from 42-something to 32-something to be between eve and kerbin), and it worked, scanning all the asteroids within 1-2 years.

Hmm. Mine's actually surprisingly close to Eve. 30ap 28pe. Maybe I should do similar.

Link to post
Share on other sites
On 3/17/2020 at 7:35 PM, DeadJohn said:

I'm trying to redirect an asteroid but the Advanced Grabbing Unit won't connect. This is the first time I've tried grabbing an asteroid in JNSQ. It's a massive class E asteroid. I searched this thread and didn't find any similar reports. Are there any known asteroid difficulties or glitches caused by JNSQ's asteroid rescale?

Approach speeds ranging from 0.2 m/s to 4.5 m/s keep bouncing off. Most of my attempts have been at 1.2 m/s. Sometimes the grabber bounces off before visual collision, like the asteroid has an invisible force field a meter above the surface. Other times my asteroid tug sinks a few meters into the surface before bouncing off.

Note that I've already tried pressing [ rapidly just as docking should occur. That sometimes helped when docking was stubborn in stock. I've also confirmed that the grabber is working; I can grab debris.

 

So I have Restock installed and I was able to grab a Class B......   With the 0.625 claw in Restock on an Agena.....   I don't know if the altered meshes for Restock would cause this to grab better with JNSQ but I just targeted COM before I attached, aligned with COM and grabbed away.

 

Agena didn't do anything (I thought I was intercepting a class C, turns out it was a B!)   I had a rocket go boom, and then I notice an Asteroid at an intersecting orbit of the lift path.  However I freely admit it could been a space Kraken, I was using Mechjeb and was away from my computer on the phone when the mission failed.

 

Anyway here is screenie:

McxSjGE.jpg

Yes that little red blob to the left of the Asteroid is a Bell 8096C engine on my "Shuttle Agena" trying to alter the trajectory of the Asteroid (I think the entire Agena along with 4 of it's 6 SOT tanks only adjusted this by 3 m/s!)

Mods used for this are Bluedog DB, Restock and my custom Hypergolic patch that I am testing for BDB.

===========Edited================

woke up this AM and realized that Restock+ is also in the modlist (and that is likely where the 0.625 claw comes from!)

Edited by Pappystein
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...